Αποστολέας Θέμα: Αλγόριθμος Τρό'ι'κα  (Αναγνώστηκε 2519 φορές)

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Αλγόριθμος Τρό'ι'κα
« στις: 04 Φεβ 2012, 07:46:51 μμ »
μιας και το θέμα είναι επίκαιρο σας παρουσιάζω τον Αλγόριθμο Τρό'ι'κα. αν αισθάνεται κανείς προσβεβλημένος ή το θεωρείτε παρατραβηγμένο τότε ευχαρίστως να διαγραφεί το θέμα.

Αλγόριθμος σχέδιο_Τροικα
Διάβασε πληθος_ανεργων, μεσος_μισθος
οι_ελληνες_ειναι_δουλοι ← Ψευδής
στοχος_επιτευχθη ← Ψευδής
Όσο πληθος_ανεργων < 800000  επανάλαβε
Διάβασε απολυσεις, μειωσεις_μισθων
πληθος_ανεργων ← πληθος_ανεργων + απολυσεις
μεσος_μισθος ← μεσος_μισθος - μειωσεις_μισθων
Τέλος_επανάληψης
Αν μεσος_μισθος < 0 τότε
οι_ελληνες_ειναι_δουλοι ← Αληθής
στοχος_επιτευχθη ← Αληθής
Τέλος_αν
αν στοχος_επιτευχθη = αληθης τοτε
Εμφανισε "Τα καταφέραμε"
αλλιως
Εμφανισε "Δεν πτοούμαστε συνεχίζουμε δυναμικά"
τέλος_αν
Τέλος σχεδιο_Τροικα

αυτό είναι λοιπόν το σχέδιο Τρό'ι'κα....