Αποστολέας Θέμα: ΛΥΣΗ ΑΣΚΗΣΗΣ - ΔΙΑΤΥΠΩΣΗ  (Αναγνώστηκε 1989 φορές)

groenendael

  • Νέος
  • *
  • Μηνύματα: 8
ΛΥΣΗ ΑΣΚΗΣΗΣ - ΔΙΑΤΥΠΩΣΗ
« στις: 21 Δεκ 2011, 05:51:34 μμ »
ΓΡΑΨΕ ΑΛΓΟΡΙΘΜΟ ΠΟΥ ΔΙΑΒΑΖΕΙ 100 ΑΚΕΡΑΙΟΥΣ ΑΡΙΘΜΟΥΣ ΣΤΟ ΔΙΑΣΤΗΜΑ (1,20) ΚΑΙ ΥΠΟΛΟΓΙΖΕΙ ΠΟΣΕΣ ΦΟΡΕΣ ΔΙΑΒΑΣΤΗΚΕ Ο ΚΑΘΕ ΑΡΙΘΜΟΣ ΞΑΝΑ. ( ΠΧ ΤΟ 2 ΔΟΘΗΚΕ 5 ΦΟΡΕΣ). ΠΟΙΑ ΕΙΝΑΙ Η ΒΕΛΤΙΣΤΗ ΛΥΣΗ ΣΕ ΕΥΤΗΝ ΤΗΝ ΑΣΚΗΣΗ; ΜΗΠΩΣ ΣΑΝ ΑΣΚΗΣΗ ΧΩΛΑΙΝΕΙ ΣΤΗΝ ΔΙΑΤΥΠΩΣΗ ΤΗΣ;

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: ΛΥΣΗ ΑΣΚΗΣΗΣ - ΔΙΑΤΥΠΩΣΗ
« Απάντηση #1 στις: 21 Δεκ 2011, 05:58:14 μμ »
Σαν πρώτη σκέψη.. χρειάζεσαι 20 μετρητές   :(

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 6034
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: ΛΥΣΗ ΑΣΚΗΣΗΣ - ΔΙΑΤΥΠΩΣΗ
« Απάντηση #2 στις: 21 Δεκ 2011, 06:27:41 μμ »
politis, αν μπορείς γράφε πεζά, είναι πιο ευανάγνωστα.
Το διάστημα [1, 20] θέλει μεν έλεγχο δεδομένων εισόδου, αλλά η ουσία δεν είναι εκεί, είναι ότι μπορείς να χρησιμοποιήσεις έναν πίνακα Εμφανίσεις[20] με 20 στοιχεία - μετρητές. Σταματάω εδώ για να μην μαρτυρήσω πολλά. :)

Stefevan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 274
Απ: ΛΥΣΗ ΑΣΚΗΣΗΣ - ΔΙΑΤΥΠΩΣΗ
« Απάντηση #3 στις: 21 Δεκ 2011, 06:34:38 μμ »
Σταματάω εδώ για να μην μαρτυρήσω πολλά. :)

 :P

groenendael

  • Νέος
  • *
  • Μηνύματα: 8
Απ: ΛΥΣΗ ΑΣΚΗΣΗΣ - ΔΙΑΤΥΠΩΣΗ
« Απάντηση #4 στις: 24 Δεκ 2011, 10:19:22 πμ »
thanks men!!! 8)

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
Απ: ΛΥΣΗ ΑΣΚΗΣΗΣ - ΔΙΑΤΥΠΩΣΗ
« Απάντηση #5 στις: 25 Δεκ 2011, 01:11:51 μμ »
μια ενδεικτική λύση:

Αλγόριθμος ασκ
Για ι από 1 μέχρι 20
  π[ι] ← 0
Τέλος_επανάληψης
Για ι από 1 μέχρι 100
  Αρχή_επανάληψης
    Διάβασε α
  Μέχρις_ότου α ≥ 1 και α ≤ 20
  π[α] ← π[α] + 1
Τέλος_επανάληψης
Για ι από 1 μέχρι 20
  Εμφάνισε "Ο ", ι, " διαβαστηκε ", π[ι], " φορες"
Τέλος_επανάληψης
Τέλος ασκ

« Τελευταία τροποποίηση: 30 Δεκ 2011, 11:24:37 πμ από Πανάγος94 »

dkonetas

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 116
Απ: ΛΥΣΗ ΑΣΚΗΣΗΣ - ΔΙΑΤΥΠΩΣΗ
« Απάντηση #6 στις: 27 Δεκ 2011, 05:01:25 πμ »
χρησιμοποιήσα πίνακες αλλά τι να κάνουμε....απο το να χρησιμοποιήσεις 20 μετρητές.....
μα 20 μετρητές χρησιμοποίησες όπως ακριβώς είχε προτείνει και ο Άλκης : "...πίνακα Εμφανίσεις[20] με 20 στοιχεία - μετρητές..."

κατά τα άλλα αυτη είναι η βέλτιστη λύση ενδιαφέρουσα δε παραλλαγή- επέκτασή της είναι η δημιουργία σχετικού οριζόντιου ιστογράμματος όπου πρέπει να δημιουργήσουμε αντίστοιχο δισδιάστατο πίνακα όπου θα γεμίζουμε για κάθε στοιχείο , έστω i, με κάποιο σύμβολο πχ "*" τις θέσεις από την (100, i)  μέχρι την (100-Εμφανίσεις, i)  ...