Αποστολέας Θέμα: Ωριαίο διαγώνισμα στα κεφ. 1 και 2 απο τον Βρακόπουλο Αθανάσιο 2ο ΓΛ Κατερίνης  (Αναγνώστηκε 4385 φορές)

Βρακόπουλος Αθανάσιος Λ.

  • Θαμώνας
  • ***
  • Μηνύματα: 35
2ο Γενικό Λύκειο Κατερίνης
Θέματα πρόχειρου διαγωνίσματος στο μάθημα:
Ανάπτυξη Εφαρμογών σε Προγραμματιστικό Περιβάλλον
Κατερίνη 17-12-2007
  Θέμα 1
Ομάδα Α
A.   Πως χωρίζονται τα προβλήματα με κριτήριο την λύση που επιζητούν.
B.   Ποια κριτήρια πρέπει να πληροί ένας αλγόριθμος.
C.   Με ποιους τρόπους μπορούμε να παρουσιάσουμε έναν αλγόριθμο.
   Μονάδες 12
Ομάδα Β
Δίνεται ο παρακάτω αλγόριθμος σε φυσική γλώσσα κατά βήματα:
Βήμα 1   Διάβασε Α
Βήμα 2   Αν Α>20 τότε πήγαινε στο βήμα 1
Βήμα 3   Κ=0
Βήμα 4   Διάβασε Β
Βήμα 5   Αν Β>10 τότε Σ=Σ+Β ,  Πήγαινε στο Βήμα 4
Βήμα 6   Κ=Κ+1
Βήμα 7   Αν Κ<>20 τότε Πήγαινε στο Βήμα 4
Βήμα 8   Γράψε Κ, Σ
Ζητείται ο αντίστοιχος αλγόριθμος σε ψευδογλώσσα.   Μονάδες 13
 
Θέμα 2
Ομάδα Α
Δίνεται ο αλγόριθμος
Αν Α<20 τότε
Κ<--Α-10
Αλλιώς_Αν Α<40 τότε
Κ<--Α-11
Αλλιώς_Αν Α<60 τότε
Κ<--Α-12
Αλλιώς_Αν Α<80 τότε
Κ<--Α-13
Αλλιώς_Αν Α<90 τότε
Κ<--Α-14
Τέλος_Αν
Κ<--Κ-20
Γράψε Κ

Ζητείται η τιμή της  μεταβλητής Α ώστε να εκτυπωθεί ο αριθμός 45    Μονάδες 10

Ομάδα Β
Δίνεται ο αλγόριθμος
Α<--20
Όσο Α>10 επανάλαβε
   Γράψε Α
   Α<--Α+1
Τέλος_Επανάληψης.
Αν μπορεί, να γραφεί αλγόριθμος ισοδύναμος με την εντολή επανάληψης «Για».
Αν όχι αιτιολογήστε την απάντησή σας.    Μονάδες 15

  Θέμα 3
Μια εταιρεία μεταφέρει αντικείμενα συσκευασμένα σε δέματα, τα δέματα δεν ζυγίζουν περισσότερο από 50 κιλά. Τα φορτηγά που χρησιμοποιεί, μπορούν να μεταφέρουν μέχρι και 2000 κιλά ή μέχρι 200 δέματα. Τα δέματα ζυγίζονται και  φορτώνονται με την σειρά που καταφθάνουν στο σημείο  ζύγισης και φόρτωσης. Ζητείται να γραφεί αλγόριθμος στον οποίο:
A.   Θα διαβάζεται το πλήθος των Ν αντικειμένων που θα μεταφερθούν. Τα αντικείμενα είναι περισσότερα από 5000.   Μονάδες 5
B.   Θα διαβάζεται το βάρος κάθε δέματος λαμβάνοντας υπόψη την παραπάνω προϋπόθεση.    Μονάδες 5
C.   Θα υπολογίζει πόσα δρομολόγια πρέπει να γίνουν για να μεταφερθούν τα παραπάνω Ν αντικείμενα.   Μονάδες 15

  Θέμα 4

Σε διαγωνισμό του ΑΣΕΠ πρόκειται να διαγωνισθούν  Ν υποψήφιοι. Οι υποψήφιοι θα διαγωνισθούν σε Κ αίθουσες των 15, 20, 30 ατόμων.  Για την διενέργεια του  διαγωνισμού θα χρειασθούν Ε επιτηρητές. Με δεδομένο ότι στις αίθουσες: των 15 και 20 ατόμων χρειάζονται 2 επιτηρητές, και των 30 ατόμων 3 επιτηρητές. Να γραφεί αλγόριθμος στον οποίο:
A.   Θα διαβάζεται το πλήθος Ν των διαγωνιζόμενων.  Ν>400   Μονάδες 5
B.   Για τις Κ αίθουσες να διαβάζεται η χωρητικότητα των αιθουσών (15,20,30).    Μονάδες 5
C.   Θα υπολογίζει και θα εκτυπώνει το πλήθος των επιτηρητών και των αιθουσών που θα χρειασθούν για την διενέργεια των εξετάσεων.    Μονάδες 15

Καλή επιτυχία

tony

  • Νέος
  • *
  • Μηνύματα: 2
Θα μπορούσε κάποιος συνάδελφος να λύσει τα θέματα 3 και 4;

Πανάγος94

  • Βετεράνος
  • ****
  • Μηνύματα: 65
  • what doesn't kill you only makes you pissed off..
μπορεί να μου απαντήσει κάποιος αν ο παρακάτω αλγόριθμος που αντιστοιχεί στο 3ο θέμα είναι σωστός;

Αλγόριθμος θεμα_3
Αρχή_επανάληψης
Διάβασε ν
Μέχρις_ότου ν > 5000
δρομ ← 1
Σ ← Αληθής
Αρχή_επανάληψης
Αν Σ = Αληθής τότε
κιλα ← 2000
δεματα ← 200
Σ ← Ψευδής
Τέλος_αν
Αρχή_επανάληψης
Διάβασε βαρος
Μέχρις_ότου βαρος ≤ 50
Αν κιλα - βαρος < 0 ή δεματα - 1 < 0 τότε
Σ ← Αληθής
δρομ ← δρομ + 1
αλλιώς
κιλα ← κιλα - βαρος
δεματα ← δεματα - 1
ν ← ν - 1
Τέλος_αν
Μέχρις_ότου ν = 0
Εμφάνισε δρομ
Τέλος Θεμα_3

dkotanid

  • ΠΛΗΝΕΤ
  • *
  • Μηνύματα: 66
  • Να μην επιθυμείς αδύνατα πράγματα.
μπορεί να μου απαντήσει κάποιος αν ο παρακάτω αλγόριθμος που αντιστοιχεί στο 3ο θέμα είναι σωστός;

Αλγόριθμος θεμα_3
Αρχή_επανάληψης
Διάβασε ν
Μέχρις_ότου ν > 5000
δρομ ← 1
Σ ← Αληθής
Αρχή_επανάληψης
Αν Σ = Αληθής τότε
κιλα ← 2000
δεματα ← 200
Σ ← Ψευδής
Τέλος_αν
Αρχή_επανάληψης
Διάβασε βαρος
Μέχρις_ότου βαρος ≤ 50
Αν κιλα - βαρος < 0 ή δεματα - 1 < 0 τότε
Σ ← Αληθής
δρομ ← δρομ + 1
αλλιώς
κιλα ← κιλα - βαρος
δεματα ← δεματα - 1
ν ← ν - 1
Τέλος_αν
Μέχρις_ότου ν = 0
Εμφάνισε δρομ
Τέλος Θεμα_3
Σωστή μου φαίνεται! Αλλά όταν διαβάζει την 201 τιμή ή την τιμή που ΑΛΗΘεύει την Συνθήκη (κιλα-βαρος<0) δεν την λαμβάνει υπ όψιν για το επόμενο δρομολόγιο και πρέπει ουσιαστηκά να τη ξαναδιαβάσει!
« Τελευταία τροποποίηση: 19 Δεκ 2011, 01:12:13 μμ από dkotanid »
Μη μου τους κύκλους τάραττε
Αρχιμήδης