Αποστολέας Θέμα: Επαναληπτικές 2005  (Αναγνώστηκε 11587 φορές)

αντώνης

  • Επισκέπτης
Επαναληπτικές 2005
« στις: 05 Ιουλ 2005, 11:12:19 πμ »
Δεν ξέρω αν είδατε τα θέματα των επαναληπτικών εξετάσεων. Υπάρχουν στο site του Υπουργείου http://www.ypepth.gr/docs/them_plir_kat_c_hmer_epan_0605.pdf .

Αυτά και αν είναι απαιτιτικά θέματα. Πιστεύω ότι μπαίνουμε σε νέα εποχή θεμάτων από του χρόνου αφού πηγαίνουμε στις παλιές δέσμες.

Περιμένω τον δικό σας σχολιασμό.

Φιλικά

Μανουσάκης Αντώνης

Ηλεκτρονικός Μηχανικός &
Μηχανικός Υπολογιστών

Αντώνης

  • Επισκέπτης
Θέμα 1ο
« Απάντηση #1 στις: 05 Ιουλ 2005, 11:37:27 πμ »
Απαντήσεις Θεμάτων

Θέμα 1ο
Α
1. Λ
2. Σ
3. Σ
4. Σ
5. Σ

Β.  
     1  β
     2  δ
     3  α
     4  β
5  γ

Γ. 1

     Πρόταση Α : ΨΕΥΔΗΣ
     Πρόταση Β : ΑΛΗΘΗΣ
     Πρόταση Γ :  ΨΕΥΔΗΣ
     Πρόταση Δ : ΑΛΗΘΗΣ
Γ.2

     Α ή Β    : ΑΛΗΘΗΣ
     Α ή Γ    : ΨΕΥΔΗΣ
Γ και Δ : ΨΕΥΔΗΣ
Α και Δ:  ΨΕΥΔΗΣ
Όχι Α   : ΑΛΗΘΗΣ
Όχι Β   :  ΨΕΥΔΗΣ

Δ.
           Για Ι από 2 μέχρι 10 με_βήμα 2
           Διάβασε Α
           Εμφάνισε Α
     Τέλος_επανάληψης

Ε.       Σχολικό βιβλίο σελ:  65

ΣΤ.       Σχολικό βιβλίο σελ: 208

Αντώνης

  • Επισκέπτης
Λύσεις - Θέμα 2ο
« Απάντηση #2 στις: 05 Ιουλ 2005, 12:32:50 μμ »
Α)
ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: Θ, Μέση, Σύνολο
ΑΚΕΡΑΙΕΣ: i
ΑΡΧΗ
Σύνολο 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
   ΓΡΑΨΕ “∆ώσε τη θερμοκρασία”
   ∆ΙΑΒΑΣΕ  Θ
   Σύνολο  Σύνολο + Θ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Μέση   Σύνολο/30
ΓΡΑΨΕ “Μέση Θερμοκρασία:”, Μέση
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Β)   ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: Θ, Φ,  Μέση, Σύνολο
ΑΚΕΡΑΙΕΣ: i
ΑΡΧΗ
Σύνολο  0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
   ΓΡΑΨΕ “∆ώσε τη θερμοκρασία”
   ∆ΙΑΒΑΣΕ  Θ
  Φ  ΜΕΤΑΤΡΟΠΗ ( Θ )    
   Σύνολο  Σύνολο + Θ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Μέση   Σύνολο/30
ΓΡΑΨΕ “Μέση Θερμοκρασία:”, Μέση
       ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

      ΣΥΝΑΡΤΗΣΗ ΜΕΤΑΤΡΟΠΗ ( Θ ) : ΠΡΑΓΜΑΤΙΚΗ  
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: Θ

     ΑΡΧΗ
     
     ΜΕΤΑΤΡΟΠΗ  32 + (9*Θ)/5
   
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Σχόλιο : Πολύ πρωτότυπο αλλά και αρκετά απαιτητικό ειδικά για δεύτερο θέμα. Να ετοιμάζεστε για του χρόνου!!

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Λύσεις Θέμα 2ο - Διορθωμένο
« Απάντηση #3 στις: 05 Ιουλ 2005, 12:55:59 μμ »
Α)
ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: Θ, Μέση, Σύνολο
ΑΚΕΡΑΙΕΣ: i
ΑΡΧΗ
Σύνολο <- 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
   ΓΡΑΨΕ "Δώσε τη θερμοκρασία"
   ΔΙΑΒΑΣΕ  Θ
   Σύνολο <- Σύνολο + Θ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Μέση  <- Σύνολο/30
ΓΡΑΨΕ "Μέση Θερμοκρασία:", Μέση
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Β)  
ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: Θ, Φ,  Μέση, Σύνολο
ΑΚΕΡΑΙΕΣ: i
ΑΡΧΗ
 Σύνολο <- 0
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
    ΓΡΑΨΕ "Δώσε τη θερμοκρασία"
    ΔΙΑΒΑΣΕ  Θ
    Φ <- ΜΕΤΑΤΡΟΠΗ ( Θ )    
    Σύνολο <- Σύνολο + Φ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 Μέση  <- Σύνολο/30
 ΓΡΑΨΕ "Μέση Θερμοκρασία", Μέση
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΜΕΤΑΤΡΟΠΗ ( Θ ) : ΠΡΑΓΜΑΤΙΚΗ  
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Θ
  ΑΡΧΗ

       ΜΕΤΑΤΡΟΠΗ <- 32 + (9*Θ)/5
 
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Σχόλιο : Πολύ πρωτότυπο αλλά και αρκετά απαιτητικό ειδικά για δεύτερο θέμα. Να ετοιμάζεστε για του χρόνου!!
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Λύσεις Θέμα 3ο
« Απάντηση #4 στις: 05 Ιουλ 2005, 01:27:20 μμ »
ΠΡΟΓΡΑΜΜΑ ΑΣΕΠ
ΜΕΤΑΒΛΗΤΕΣ
 ΧΑΡΑΚΤΗΡΕΣ: Ο[100]
 ΠΡΑΓΜΑΤΙΚΕΣ: Β[100,3], Max, Min, Μέσος
 ΑΚΕΡΑΙΕΣ: i , j
  ΑΡΧΗ
  ! ερ'ωτημα α
   ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
         ΔΙΑΒΑΣΕ  O
         ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 3
         ΔΙΑΒΑΣΕ  B[i,j]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ερώτημα β

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
  Max <- B[i,1]
  Min <-  B[i,1]
   ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 3
       AN B[i,j] > Max TOTE
          Max <- B[i, 1]
       ΑΛΛΙΩΣ_ΑΝ   B[i,j] < Min TOTE
           Min <-  B[i,1]      
       ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΡΑΨΕ   Max, Min
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ερώτημα γ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
   Μέσος  <-  Μέσος_Όρος( Β[i,1], Β[i,2], Β[i,3])
   ΓΡΑΨΕ " Ο Μέσος Όρος του μαθητή ", Ο, "είναι : ", Μέσος
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΣΥΝΑΡΤΗΣΗ Μέσος_Όρος ( Α,Β,Γ ) : ΠΡΑΓΜΑΤΙΚΗ  
ΜΕΤΑΒΛΗΤΕΣ  
 ΠΡΑΓΜΑΤΙΚΕΣ: Α, Β, Γ

     ΑΡΧΗ      
     Μέσος_Όρος <- (Α + Β + Γ)/3
   
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Σχόλιο : Επιτέλους ζητήθηκε και άσκηση κατασκευής αλλά και κλήσης υποπρογράμματος, κάτι που αναμέναμε πολύ καιρό. Αλλά μου φαίνεται ότι το τώρα το παράκαναν ( θέμα 2 - θέμα 3).
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Λύσεις Θέμα 4ο
« Απάντηση #5 στις: 05 Ιουλ 2005, 01:54:49 μμ »
Αλγόριθμος Θέμα4
! ερώτημα 1
Για i από 1 από 15
     Διάβασε Πρ
Τέλος_επανάληψης

! ερώτημα 2
Για i από 1 από 15
Για j από 1 από 12
           Αρχή_επανάληψης
   Διάβασε Ποσ[i,j]
 Μέχρις_ότου Ποσ[i,j] >=0 και Ποσ[i,j] <= 100
Τέλος_επανάληψης
Τέλος_επανάληψης

! ερώτημα 3
Για i από 1 από 15
     Sum <- 0
 Για j από 1 από 12
  Sum <-  Sum  + Ποσ[i,j]      
 Τέλος_επανάληψης
 M <- Sum / 12 !κατασκευή πίνακα με το μέσο ετήσιο ποσοστό πληρότητας  για κάθε προορισμό
Τέλος_επανάληψης

Για i από 1 μέχρι 15
Αν M > 65 τότε
      Εμφάνισε Πρ
Τέλος_αν
Τέλος_επανάληψης

! ερώτημα 4
Για i από 1 μέχρι 15
Αν M < 40 τότε
      Εμφάνισε Πρ
Τέλος_αν
Τέλος_επανάληψης

! ερώτημα 5

Για i από 1 μέχρι 15
Αν M >= 40 και Μ <=65 τότε
       Εμφάνισε Πρ
       Εμφάνισε "Θα γίνουν περικοπές στους ακόλουθους μήνες:"
  Για j από 1 από 12
         Αν Ποσ[i,j] < 40 τότε
                      Εμφάνισε j
         Τέλος_αν
  Τέλος_επανάληψης
Τέλος_αν
Τέλος_επανάληψης
Τέλος Θέμα4


Σχόλιο: Νομίζω ότι το θέμα αυτό ήταν αρκετά βατό

Συνολικά όμως ολόκληρο το διαγώνισμα ήταν αρκετά απαιτητικό.

Οποιαδήποτε παρατήρηση σχετικά με τις λύσεις καλοδεχούμενη.

Φιλικά,

Μανουσάκης Αντώνης

Ηλεκτρονικός Μηχανικός &
Μηχανικός Υπολογιστών

Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3320
    • P.Tsiotakis
Re: Επαναληπτικές 2005
« Απάντηση #6 στις: 05 Ιουλ 2005, 02:51:22 μμ »
Αγαπητέ Αντώνη... οι καθηγητές πληροφορικής κάνουν μπάνια, θα τοποθετηθούν επί των θεμάτων του χρόνου

Όσο για τα θέματα των επαναληπτικών, υπάρχουν και στην ιστοσελίδα:

http://users.kor.sch.gr/ptsiotakis/aepp/aepp_panel_epanen_2005.htm

Θεωρώ οτι ταυτιζόμαστε στον τρόπο επίλυσης

Με εκτίμηση,
« Τελευταία τροποποίηση: 05 Ιουλ 2005, 02:57:43 μμ από ptsiotakis »

pathan

  • Οπαδός
  • **
  • Μηνύματα: 15
  • Γράψτε το προσωπικό σας σλόγκαν!
Re: Επαναληπτικές 2005
« Απάντηση #7 στις: 07 Ιουλ 2005, 11:06:13 πμ »
Φίλοι γειά σας

Πράγματι τα θέματα των Επαναληπτικών Ενιαίων 2005 ήταν τα δυσκολότερα πιστεύω όλων των ετών. Συμφωνώ πως το παράκαναν με τα υποπρογράμματα. Να περιμένουμε και τα επαναληπτικά των εσπερινών 11/7 . Τι πιστεύετε μάλλον θα προστεθεί ύλη ( πιστεύω και το υπολοιπο του Κεφ. 10 ) και ίσως λίγο παραπέρα τπυ 4.2 (Δυαδική Αναζήτηση)
Αθανασόπουλος Παντελής  
Εκπαιδευτικός - Πληροφορικός ΠΕ 19

Φίλιππος

  • Επισκέπτης
Re: Λύσεις Θέμα 3ο
« Απάντηση #8 στις: 12 Ιουλ 2005, 11:50:11 πμ »
Παράθεση
ΠΡΟΓΡΑΜΜΑ ΑΣΕΠ
ΜΕΤΑΒΛΗΤΕΣ
 ΧΑΡΑΚΤΗΡΕΣ: Ο[100]
 ΠΡΑΓΜΑΤΙΚΕΣ: Β[100,3], Max, Min, Μέσος
 ΑΚΕΡΑΙΕΣ: i , j
  ΑΡΧΗ
....
....
....
! ερώτημα γ
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
     Μέσος  <-  Μέσος_Όρος( Β[i,1], Β[i,2], Β[i,3])
     ΓΡΑΨΕ " Ο Μέσος Όρος του μαθητή ", Ο[i ], "είναι : ", Μέσος
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΣΥΝΑΡΤΗΣΗ Μέσος_Όρος ( Α,Β,Γ ) : ΠΡΑΓΜΑΤΙΚΗ  
ΜΕΤΑΒΛΗΤΕΣ  
 ΠΡΑΓΜΑΤΙΚΕΣ: Α, Β, Γ

     ΑΡΧΗ      
     Μέσος_Όρος <- (Α + Β + Γ)/3
   
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Μια μικρή διαφοροποίηση στο θέμα 3.  Η εκφώνηση ζητάει:

Να γραφεί υποπρόγραμμα, το οποίο να καλείται από το κύριο πρόγραμμα, για τον υπολογισμό και την εκτύπωση του μέσου όρου κάθε υποψηφίου στα τρία μαθήματα που διαγωνίστηκε.

Δεν προσδιορίζει ότι πρέπει να γραφεί απαραίτητα συνάρτηση όπως κάνει στο προηγούμενο θέμα (2ο).  Επομένως ο εξεταζόμενος πρέπει να επιλέξει και το σωστό τύπο υποπρογράμματος: διαδικασία ή συνάρτηση.
Αφού η εκφώνηση καθορίζει ότι το υποπρτόγραμμα θα υπολογίζει και θα εκτυπώνει το αποτέλεσμα, ο σωστός τύπος υποπρογράμματος πιστεύω ότι είναι η διαδιδικασία αφού το υποπρόγραμμα, εκτός από υπολογισμό θα πρέπει και να εκτυπώνει.  Βάση των προδιαγραφών του σχολικού βιβλίου, η συνάρτηση υπολογίζει και επιστρέφει μία τιμή με το όνομά της, ενώ η διαδικασία μπορεί να εκτελέσει όλες τις λειτουργίες του κυρίως προγράμματος.  Εξάλλου, και στο σχολικό βιβλίο, όπου υπάρχουν εντολές εισόδου / εξόδου, παρουσιάζονται λύσεις με διαδικασίες και όχι συναρτήσεις.  

Επομένως πιστεύω ότι η σωστή απάντηση του ερωτήματος γ είναι:


....
! ερώτημα γ
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
     ΚΑΛΕΣΕ Μέσος_Όρος( Β[i,1], Β[i,2], Β[i,3], Ο)
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΔΙΑΔΙΚΑΣΙΑ Μέσος_Όρος ( Α,Β,Γ,Δ )
ΜΕΤΑΒΛΗΤΕΣ  
 ΠΡΑΓΜΑΤΙΚΕΣ: Α, Β, Γ, Μ
 ΧΑΡΑΚΤΗΡΕΣ: Δ
ΑΡΧΗ      
   Μ <- (Α + Β + Γ)/3
   ΓΡΑΨΕ " Ο Μέσος Όρος του μαθητή ", Δ, "είναι : ", Μ
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Καλό καλοκαίρι σε όλους!

amanou

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 52
  • Γράψτε το προσωπικό σας σλόγκαν!
Re: Επαναληπτικές 2005
« Απάντηση #9 στις: 12 Ιουλ 2005, 01:47:42 μμ »
Σωστή η παρατηρησή σου, ωστόσο δεν είναι ξεκάθαρο από την διατύπωση τουλάχιστον αν η εμφάνιση θα γίνετε και αυτή απο το υποπρόγραμμα (Διαδικασία) ή θα γίνεται από το κυρίως πρόγραμμα αφού έχει γίνει ο υπολογισμός  (Συνάρτηση). Οπότε θεωρώ ότι και τα δυο είναι σωστά.

Με εκτίμηση,

Αντώνης Μανουσάκης
Αντώνης Μανουσάκης

Ηλεκτρονικός και Μηχανικός Η/Υ

mop

  • Νέος
  • *
  • Μηνύματα: 2
Απ: Επαναληπτικές 2005
« Απάντηση #10 στις: 09 Μαρ 2008, 12:05:03 μμ »
Το 3ο Θέμα λύνεται με πίνακες και χωρίς πίνακες.
Επειδή στην σελίδα 191 λέει ότι, όταν είναι περιττή η χρήση των πινάκων τότε πρέπει να αποφεύγονται,
αν τα παιδιά το λύσουν με πίνακες χάνουν μονάδες?

Και γενικά σε τέτοια προβλήματα οι μαθητές πρέπει να γράφουν κώδικα χωρίς πίνακες ή δεν έχει σημασία?

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3320
    • P.Tsiotakis
Απ: Επαναληπτικές 2005
« Απάντηση #11 στις: 09 Μαρ 2008, 05:57:11 μμ »
Δεν εξετάζεται στις εξετάσεις η βέλτιστη λύση, αλλά η σωστή λύση.

Προσοχή !! Αν το πλήθος των επαναλήψεων δεν είναι γνωστό, δεν μπορούν να χρησιμοποιηθούν πίνακες.
Στο διδακτικό μας πακέτο οι πίνακες είναι στατική δομή δεδομένων, ακόμα