Γενικό Λύκειο > Δομή επιλογής

Απορία Αν..Αλλιώς_Αν..Αλλιώς

<< < (2/18) > >>

George Eco:

--- Παράθεση από: petrosp13 στις 15 Δεκ 2015, 05:07:57 μμ ---Τετράδιο μαθητή, σελίδα 20

--- Τέλος παράθεσης ---
Εκτός ύλης, κι αλγόριθμος σε ψευδογλώσσα.
Και με το νέο υλικό δεν έχει αλλάξει κάτι.
Τυπικά είναι λάθος, γιατί η επί χάρτου ΓΛΩΣΣΑ ορίζεται από ότι υπάρχει στο βιβλίο.
Υπάρχουν και χειρότερα ατοπήματα στο βιβλίο από αυτό βέβαια...
Αυτό διορθώνεται, τα άλλα όχι...



--- Παράθεση από: petrosp13 στις 15 Δεκ 2015, 03:04:07 μμ ---Πού αναφέρεται στο βιβλίο η υποχρεωτική χρήση του Αλλιώς;

--- Τέλος παράθεσης ---

Πού εμφανίζεται στο βιβλίο σύνταξη χωρίς την ΑΛΛΙΩΣ;
Μιλάω για τμήμα ΘΕΩΡΙΑΣ και εντός εξεταστέας ύλης.



--- Παράθεση από: Obelix στις 14 Δεκ 2015, 11:52:47 μμ ---Σωστότατο.

--- Τέλος παράθεσης ---
Αμφιβάλλω.

Πάνε πολλά χρόνια από αυτά τα post, αλλά αν σήμερα αυτό συνεχίζει να με βασανίζει, νομίζω αξίζει συζητήσεως.

ApoAntonis:
Στο βιβλίο καθηγητή θα βρούμε διατυπωμένες δραστηριότητες με πολλαπλή επιλογή χωρίς την χρήση του ΑΛΛΙΩΣ.

petrosp13:
Υπάρχει η δομή απλής επιλογής και η χρήση του Αλλιώς δεν είναι υποχρεωτική
Είναι υποχρεωτική στην δομή Πολλαπλής Επιλογής;
Δηλαδή
Αν σε ένα πρόβλημα θα πρέπει να εκτελούνται ενέργειες για τιμές 1,2,3 και για τις υπόλοιπες να μην εκτελείται τίποτα, είμαι υποχρεωμένος να χρησιμοποιήσω τρεις δομές απλής επιλογής;
Το ότι δεν υπάρχει παράδειγμα στο σχολικό εγχειρίδιο για αυτό δεν σημαίνει τίποτα
Ούτε παράδειγμα με εμφωλευμένη επανάληψη σε δομή Επίλεξε υπάρχει, σημαίνει ότι δεν επιτρέπεται;

Διδάσκουμε ένα μάθημα που βασίζεται στην λογική
Πώς δικαιολογούμε την υποχρεωτικότητα της χρήσης Αλλιώς;

George Eco:

--- Παράθεση από: ApoAntonis στις 23 Σεπ 2020, 07:27:07 πμ ---Στο βιβλίο καθηγητή θα βρούμε διατυπωμένες δραστηριότητες με πολλαπλή επιλογή χωρίς την χρήση του ΑΛΛΙΩΣ.

--- Τέλος παράθεσης ---

Το βιβλίο του Καθηγητή, δε το εξετάζεται όμως ο μαθητής.


ΑΝ Χ = 1 ΤΟΤΕ
   ! Κάτι.
ΑΛΛΙΩΣ_ΑΝ Χ = 2 ΤΟΤΕ
   ! Κάτι άλλο
ΑΛΛΙΩΣ
   ΑΝ Χ = 3 ΤΟΤΕ
        ! Το παράλλο
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΑΝ

bugman:
Το Αλλιώς είναι προαιρετικό. Πχ έχω ένα πρόγραμμα και αν η τιμή του Χ είναι πάνω από 200 το βάζω στο 200. Τι να γράψω στο Αλλιώς; Δεν υπάρχει κάτι!


Να το κάνουμε και με το Αλλιώς Αν; Πχ αν Χ<100 τότε Χ<-100 αλλιώς αν Χ>200 τότε Χ<-200. Τώρα τι νόημα θα έχει το Αλλιώς; Χ<-Χ ???

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

[*] Προηγούμενη σελίδα

Μετάβαση στην πλήρη έκδοση