Αποστολέας Θέμα: Αλγοριθμος ΑΦΜ και μετατροπη σε batch script  (Αναγνώστηκε 309 φορές)

giannisn1990

  • Νέος
  • *
  • Μηνύματα: 7
Αλγοριθμος ΑΦΜ και μετατροπη σε batch script
« στις: 14 Φεβ 2021, 09:12:59 πμ »
Μπορει καποιος να με βοηθήσει ώστε να μετατρέψω τον παρακάτω αλγόριθμο σε batch script ?

Παράθεση
ΠΡΟΓΡΑΜΜΑ AFM_check
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: x, S, ΥΠΟΛΟΙΠΟ, i  ,Σ
ΑΡΧΗ
  ΓΡΑΨΕ 'Δώσε 1-1 τα ψηφία του ΑΦΜ'
  Σ <-- 0
  ΓΙΑ i  ΑΠΟ   1  ΜΕΧΡΙ  9
    ΔΙΑΒΑΣΕ x
    Σ <-- Σ + 2^(9-i)*x
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  S <-- Σ-x

  ΥΠΟΛΟΙΠΟ <-- S MOD 11

!ΠΡΟΣΟΧΗ: Επειδή διαιρούμε με το 11 υπάρχει περίπτωση το υπόλοιπο είναι 10.
!Αν είναι 10 το τελευταίο ψηφίο του ΑΦΜ πρέπει να είναι 0 για να είναι έγκυρο.

  ΑΝ ΥΠΟΛΟΙΠΟ =10 ΤΟΤΕ
    ΥΠΟΛΟΙΠΟ <-- 0
  ΤΕΛΟΣ_ΑΝ

  ΑΝ ΥΠΟΛΟΙΠΟ = x ΤΟΤΕ
    ΓΡΑΨΕ 'ΤΟ ΑΦΜ ΕΙΝΑΙ ΣΩΣΤΟ'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΤΟ ΑΦΜ ΕΙΝΑΙ ΛΑΝΘΑΣΜΕΝΟ'
  ΤΕΛΟΣ_ΑΝ


  ΓΡΑΨΕ 'Το άθροισμα των ψηφίων είναι',S
  ΓΡΑΨΕ 'Το υπόλοιπο της διαίρεσης ειναι',ΥΠΟΛΟΙΠΟ
  ΓΡΑΨΕ 'Το τελευταίο ψηφίο του αριθμού είναι το ' ,x

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ AFM_check