Δήλωση νέου πίνακα Β που θα δημιουργηθεί με μόνο τα θετικά στοιχεία πίνακα Α

Ξεκίνησε από turn_on, 16 Δεκ 2021, 05:48:30 ΜΜ

« προηγούμενο - επόμενο »

turn_on

Καλησπέρα σας, θα ήθελα τη βοήθειά σας σε μια ερώτησή μου. Έστω το παρακάτω τμήμα προγράμματος:

Μ ← 0 ! Δείκτης του νέου πίνακα
Για i από 1 μέχρι 100
    Αν (Α > 0) τότε
       Μ ← Μ + 1 !δίνουμε θέση στον πίνακα Β
       Β[Μ] ← Α
    Τέλος_αν
Τέλος_επανάληψης
Ο πίνακας Α θα δηλωθεί ως ακέραιος Α[100]. Πως θα πρέπει να δηλωθεί ο νέος πίνακας Β που θα δημιουργηθεί με τα θετικά στοιχεία του Α;
Σας ευχαριστώ πολύ για το χρόνο σας.


Λαμπράκης Μανώλης

#1
καλησπέρα σε όλους

και ο πίνακας Β θα δηλωθεί ως ακέραιος με 100 στοιχεία, γιατί δε γνωρίζουμε πόσα θα χρησιμοποιήσουμε εξ αρχής , μπορεί να έχει από 0 μέχρι και 100, άρα δηλώνουμε το μέγιστο δυνατό.., στην πράξη θα είναι  όσο και η τιμή του δείκτη Μ που χρησιμοποιείς στο παράδειγμα σου... η προσπέλαση του πίνακα Β θα γίνεται πχ

για ι απο 1 μεχρι Μ
  γραψε Β[ι]
τελος_επαναληψης

ελπίζω να βοήθησα

turn_on

Αυτό είχα σκεφτεί και εγώ από την αρχή... ήθελα απλά επιβεβαίωση
Ευχαριστώ πολύ
:)

ioannis.giftakis

Παράθεση από: turn_on στις 16 Δεκ 2021, 05:48:30 ΜΜ
Καλησπέρα σας, θα ήθελα τη βοήθειά σας σε μια ερώτησή μου. Έστω το παρακάτω τμήμα προγράμματος:

Μ ← 0 ! Δείκτης του νέου πίνακα
Για i από 1 μέχρι 100
    Αν (Α > 0) τότε
       Μ ← Μ + 1 !δίνουμε θέση στον πίνακα Β
       Β[Μ] ← Α
    Τέλος_αν
Τέλος_επανάληψης
Ο πίνακας Α θα δηλωθεί ως ακέραιος Α[100]. Πως θα πρέπει να δηλωθεί ο νέος πίνακας Β που θα δημιουργηθεί με τα θετικά στοιχεία του Α;
Σας ευχαριστώ πολύ για το χρόνο σας.

Hi, αυτό συνήθως το λέμε αρχικές θέσεις ως τύπο ερωτήματος.

Καρκαμάνης Γεώργιος

Παράθεση από: limitcracker στις 16 Δεκ 2021, 11:23:49 ΜΜ
Hi, αυτό συνήθως το λέμε αρχικές θέσεις ως τύπο ερωτήματος.

Τι σημαίνει "αρχικές θέσεις" ως τύπο ερωτήματος;