Γενικό Λύκειο > Εντολή ΑΝ

Απορία

(1/2) > >>

Obelix:
Σε μία ερώτηση Σ/Λ στο Τετράδιο Μαθητή (κεφ. 8, σελ.81) αναφέρεται:

'Κάθε εντολή ΑΝ πρέπει να έχει την αντίστοιχη εντολή ΤΕΛΟΣ_ΑΝ.'

Το παραπάνω είναι ψευδές μόνο για ψευδογλώσσα;
 
Σε αρκετές εκφωνήσεις έχει υπάρξει ΑΝ χωρίς την αντίστοιχη ΤΕΛΟΣ_ΑΝ, αλλά απ'ότι κατάλαβα η ΓΛΩΣΣΟΜΑΘΕΙΑ δεν δέχεται κάτι τέτοιο.
Άρα το δεχόμαστε ως Σ ή Λ;

Sergio:
Η πρόταση είναι ΣΩΣΤΗ στη ΓΛΩΣΣΑ, όπως ορίζεται στο κεφάλαιο 8, και ΛΑΘΟΣ στην Ψευδογλώσσα (Κεφ.2)

petrosp13:
Ανούσια πρόταση..

Obelix:
Όντως...ευχαριστώ!

Sergio:

--- Παράθεση από: petrosp13 στις 16 Μαΐ 2017, 09:48:33 μμ ---Ανούσια πρόταση..

--- Τέλος παράθεσης ---

Στο κεφάλαιο 2 επιχειρείται μια εισαγωγή των μαθητών στην αλγοριθμική σκέψη, με τρόπο λιγότερο τυπικό αλλά χωρίς να δημιουργεί εμφανή εμπόδια στην "επόμενη" φάση διδασκαλίας, αυτή του "δομημένου προγραμματισμού" με ΓΛΩΣΣΑ.  Όπως το αντιλαμβάνομαι, οι συγγραφείς επέλεξαν να δώσουν (σε αυτό το κεφάλαιο) ΚΑΙ τη μορφή την απλής ΑΝ (χωρίς τελος_αν) για λόγους :
- απλότητας στη σκέψη,
- συνέχειας από προηγούμενες τάξεις ,
- (ίσως) ομοιότητας με κάποιες γλώσσες που μπορεί ήδη να έχουν ασχοληθεί.

Στο κεφάλαιο 8 απ' την άλλη, η ύπαρξη του ΤΕΛΟΣ_ΑΝ σε ΚΑΘΕ εντολή επανάληψης, επιχειρεί να υποστηρίξει το "χαρακτηριστικό" που αναφέρεται για το δομημένο προγραμματισμό "κάθε ενότητα προγράμματος έχει μια είσοδο και μια έξοδο" (που με "κακή" διατύπωση ουσιαστικά εννοεί "ένα ΣΗΜΕΙΟ εισόδου και ένα ΣΗΜΕΙΟ εξόδου")

Επομένως, δεν θεωρώ την πρόταση που συζητάμε ανούσια.

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση