Γενικό Λύκειο > Συναρτήσεις

Άθροισμα κατά γραμμές και κατά στήλες σε πίνακα με Συναρτηση

(1/6) > >>

nikolasmer:
Σπάω το κεφάλι εδώ και πολύ ώρα για να μπορέσω να βρω μια καλή λύση για τον υπολογισμό του αθροίσματος κατά γραμμές και κατά στήλες σε δισδιάστατο πίνακα καλώντας την ίδια Συνάρτηση.

--- Κώδικας: ---ΣΥΝΑΡΤΗΣΗ ΑΘΡ(Π, I): ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: I, J, S, Π[4, 4]
ΑΡΧΗ
  S <- 0
  ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 4
    S <- S + Π[I, J]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΘΡ <- S
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

--- Τέλος κώδικα ---
 

Στον κώδικα υπάρχει ένας πίνακας Π[4,4] και θα ήθελα με διαφορετική κλήση να υπολογίσω το άθροισμα κατά γραμμές και το άθροισμα κατά στήλες. Ή η λύση είναι μπροστά στα μάτια μου ή ....
Παίζει κάτι με καμία αντιμετάθεση παραμέτρων ή κάτι παρόμοιο στη ΓΛΩΣΣΑ; ???

petrosp13:
Αν βάλεις ανάποδα τους δείκτες μέσα στην αγκύλη;

nikolasmer:

--- Παράθεση από: petrosp13 στις 15 Απρ 2019, 10:34:14 μμ ---Αν βάλεις ανάποδα τους δείκτες μέσα στην αγκύλη;

--- Τέλος παράθεσης ---
Δεν είναι αυτό που ήθελα.  Η ΙΔΙΑ συνάρτηση (ή διαδικασία ) , διαφορετική όμως κλήση

Λαμπράκης Μανώλης:
Νίκο καλησπέρα

Αν προσθέσεις μια παράμετρο στην συνάρτηση;;
Συνάρτηση Φ( Α, κ, λ) :ακεραια
......
Αρχη
  Αθρ<--0
  Αν λ=1 τότε
     Για μ από 1 μέχρι 4
         Αθρ<-- Αθρ+ Α[κ, μ]
     Τελος_Επαναληψης
  Αλλιώς
    Για μ από 1 μέχρι 4
       Αθρ<--Αθρ+Α[μ, κ]
     Τελος_Επαναληψης
   Τέλος_αν
   Φ<-- Αθρ
Τελος_Συναρτησης
     

nikolasmer:

--- Παράθεση από: Λαμπράκης Μανώλης στις 15 Απρ 2019, 11:28:07 μμ ---Νίκο καλησπέρα

Αν προσθέσεις μια παράμετρο στην συνάρτηση;;
Συνάρτηση Φ( Α, κ, λ) :ακεραια
......
Αρχη
  Αθρ<--0
  Αν λ=1 τότε
     Για μ από 1 μέχρι 4
         Αθρ<-- Αθρ+ Α[κ, μ]
     Τελος_Επαναληψης
  Αλλιώς
    Για μ από 1 μέχρι 4
       Αθρ<--Αθρ+Α[μ, κ]
     Τελος_Επαναληψης
   Τέλος_αν
   Φ<-- Αθρ
Τελος_Συναρτησης
     

--- Τέλος παράθεσης ---
Μανώλη ευχαριστώ για την απάντηση.
Ξέρω γίνομαι εκνευριστικος. Αλλά στο μυαλό μου είχα την παραπάνω συνάρτηση (στο πρώτο μου post) αλλά με διαφορετική κλήση . Μια για τις γραμμές και μια για τις στήλες. Με μια επανάληψη μέσα στο σώμα της.
Σε κάποια φάση σκέφτηκα καμιά αντιμετάθεση τιμών παραμέτρων αλλά αυτή δεν θα ήταν πάρα μόνο αυτό ...μια αντιμετάθεση τιμών . Όχι μεταβλητών. Χαχα.
Τέλος πάντων .  Μάλλον δε γίνεται στη ΓΛΩΣΣΑ .

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση