Γενικό Λύκειο > Αναζήτηση

ΑΝΑΖΗΤΗΣΗ ΣΕ ΔΙΣΔΙΑΣΤΑΤΟ ΠΙΝΑΚΑ

(1/3) > >>

giannhs555:
ΚΑΛΗΣΠΕΡΑ ΣΑΣ. ΕΧΩ ΝΑ ΘΕΣΩ ΜΙΑ ΑΠΟΡΙΑ ΜΟΥ.

ΠΩΣ ΜΠΟΡΩ ΝΑ ΚΑΝΩ ΣΕΙΡΙΑΚΗ ΑΝΑΖΗΤΗΣΗ ΣΕ ΔΙΣΔΙΑΣΤΑΤΟ ΠΙΝΑΚΑ? ΜΕ ΤΗΝ ΕΝΤΟΛΗ ΓΙΑ? ΑΝ ΘΕΛΩ ΟΠΩΣ ΣΤΟ ΜΟΝΟΔΙΑΣΤΑΤΟ ΟΙ ΕΠΑΝΑΛΗΨΕΙΣ ΝΑ ΣΤΑΜΑΤΟΥΝ ΟΤΑΝ ΤΟ ΣΤΟΙΧΕΙΟ ΒΡΕΘΕΙ ΠΩΣ ΘΑ ΤΟ ΚΑΝΩ?

ΕΥΧΑΡΙΣΤΩ.

toufeki:
Καλησπέρα και σε σένα Γιάννη.
Έχεις προσπαθήσει καθόλου να σκεφτείς μια λογική που θα μπορούσε να σε βοηθήσει να βρεις τη λύση;

Υπάρχει κάποιος λόγος που πρέπει οπωσδήποτε να χρησιμοποιηθεί η δομή ΓΙΑ;

Laertis:
Με διπλό Όσο αντί το Για :
.......
i <-- 1
Όσο done=ψευδής και i <=n επανάλαβε
    j <-- 1
    Όσο done=ψευδής και j <=m επανάλαβε
       Αν table[i,j]=key τότε
             done<--αληθής
              γραμμή <-- i
              στήλη <--  j
        αλλιώς
             j <--  j+1
         Τέλος_αν
       Τέλος_επανάληψης
     i <-- i +1
Τέλος_επανάληψης

michaeljohn:
Έστω ο ΝxΜ πίνακας Α,  και Key το αναζητούμενο

…….
Found <-- Ψευδής
i <-- 1
j <-- 1
Όσο i <= N και Found = Ψευδής επανάλαβε
   Αν Α[i,j] = key τότε
      Found <-- Αληθής
      Εμφάνισε "βρέθηκε στην", i, "η γραμμή και ", j,"η στήλη"
   Αλλιώς
      j <-- j + 1
      Αν j > M τότε
         i <-- i + 1
         j <-- 1
      Τέλος_αν
   Τέλος_αν 
Τέλος_επανάληψης
……..


Αφιερωμένο στους μαθητές που αγωνίζονται !

toufeki:
...μήπως πρέπει να μπει και κάτι άλλο στο παιχνίδι; Ίσως κάποιος ακόμα βοηθητικός μετρητής;
Μήπως το όσο θα έπρεπε να τρέξει το πολύ ΝΧΜ φορές;

Αν και ο αλγόριθμος φαίνεται να δουλεύει εντούτοις είναι φοβερό μπερδεμα για έναν μαθητή.

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση