Αποστολέας Θέμα: θεμα 2Γ - κι αν το τρέξουμε για α να ειναι 10;  (Αναγνώστηκε 2396 φορές)

allege

  • Νέος
  • *
  • Μηνύματα: 2
θεμα 2Γ - κι αν το τρέξουμε για α να ειναι 10;
« στις: 02 Ιουν 2009, 10:48:07 πμ »
Γεια σας συνάδελφοι. Παρατηρώ τοσο καιρό τα σχόλια για τα θέματα καθώς και τις λύσεις που κυκλοφόρησαν απο φροντιστήρια και υπόλοιπο κόσμο και μου κάνει εντύπωση μια κατ εμέ παράλειψη στο θέμα 2Γ.

Αν το α είναι 10 τότε το αmod10 προκύπτει 0.
Κατά συνέπεια στο βρόχο

Για δ από amod10 μέχρι 1 με_βήμα -1
  γ<-γ+β
Τέλος_επανάληψης

υπάρχει πρόβλημα διότι η τιμή από πρέπει να είναι μεγαλύτερη από τη τιμή μέχρι για να έχω βήμα -1.

Στο βρόχο της εκφώνησης αν το α τύχει να είναι 10 τότε δεν θα εκτελεστεί καμία φορά ο βρόχος και απλώς θα προχωρήσει στις όποιες παρακάτω εντολές μετά το τέλος_επανάληψης.
Άρα, θα έπρεπε για μένα, αν θα θέλαμε το παιδί να είναι απολύτως σωστό, να προβλέψει την περίπτωση που το α είναι 10 (και άρα το δ βγαίνει 0), όπως ακριβώς προβλέπεται και από το κομμάτι της εκφώνησης και να γράψει κάτι σαν αυτό:

δ<-αmod10
Aν d>0 τότε
  Για δ από amod10 μέχρι 1 με_βήμα -1
    γ<-γ+β
  Τέλος_επανάληψης
Τέλος_αν

Θα ήθελα να ακούσω τις απόψεις σας στο συγκεκριμένο.
Thanks.

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3320
    • P.Tsiotakis
Απ: θεμα 2Γ - κι αν το τρέξουμε για α να ειναι 10;
« Απάντηση #1 στις: 02 Ιουν 2009, 11:27:51 πμ »
Αν δεν κάνει καμμία επανάληψη δεν είναι λανθασμένος, απλά δεν κάνει καμμία επανάληψη, το  γ  δεν αυξάνεται και διατηρεί την τιμή του.

ΛΑνθασμένος είναι, μόνο αν είναι ατέρμων, αν το βλήμα δηλαδή είναι 0, που δε συμβαίνει στην περίπτωσή μας.

allege

  • Νέος
  • *
  • Μηνύματα: 2
Απ: θεμα 2Γ - κι αν το τρέξουμε για α να ειναι 10;
« Απάντηση #2 στις: 02 Ιουν 2009, 12:33:09 μμ »
Η τιμή αmod10 θα μπορούσε να είναι 0 (αφού δεν ελέγχεται πρωτύτερα). Τότε όμως το από του βρόχου Για θα ήταν μικρότερο από το μέχρι κάτι που απαγορεύεται ξεκάθαρα (όπως αναφέρεται και στο σχολικό βιβλίο ) στο βρόχο Για με βήμα να έχει αρνητική τιμή.

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3320
    • P.Tsiotakis
Απ: θεμα 2Γ - κι αν το τρέξουμε για α να ειναι 10;
« Απάντηση #3 στις: 02 Ιουν 2009, 12:55:50 μμ »
Ο βρόχος

Για i απο 1 μέχρι 0

είναι μια χαρά βρόχος με καμμία επανάληψη, δεν είναι λάθος

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2843
  • Πύργος Ηλείας
Απ: θεμα 2Γ - κι αν το τρέξουμε για α να ειναι 10;
« Απάντηση #4 στις: 02 Ιουν 2009, 01:26:25 μμ »
Η τιμή αmod10 θα μπορούσε να είναι 0 (αφού δεν ελέγχεται πρωτύτερα). Τότε όμως το από του βρόχου Για θα ήταν μικρότερο από το μέχρι κάτι που απαγορεύεται ξεκάθαρα (όπως αναφέρεται και στο σχολικό βιβλίο ) στο βρόχο Για με βήμα να έχει αρνητική τιμή.

Το βιβλίο δεν γράφει ότι "απαγορεύεται"... Εννοεί απλά ότι σε τέτοια περίπτωση τότε δεν έχουμε επαναλήψεις...

klitos

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 133
Απ: θεμα 2Γ - κι αν το τρέξουμε για α να ειναι 10;
« Απάντηση #5 στις: 03 Ιουν 2009, 01:32:12 μμ »
Αν το αmod10 ειναι ισο με 0 δεν υπαρχει κανενα απολυτως προβλημα . Απλα η επαναληψη δεν εκτελειται , και ορθως κανει.
Για να κανω λιγο το δικηγορο του διαβολου θα πω οτι προβλημα θα ειχαμε αν το το αmod10 ειναι ισο με 1 ....
Στο σχολικο αναφερει οτι οταν το βημα ειναι αρνητικο τοτε αρκει το απο να ειναι μεγαλυτερο του μεχρι.
Δηλαδη η επαναληψη
Για ι απο 5 μεχρι 5 με_βημα -1     δεν εκτελειται ...(καποιοι ισχυριζονται οτι εκτελειται μια φορά - μαλλον αυθαιρετα)
Αρα η μετατροπη του Οσο του Θ2Γ εχει μια ατελεια...
Μια μαθητρια μου το μετετρεψε σε
Για δ απο αmod10 μεχρι 0.5 με_βημα -1
Περιμενω τις αποψεις σας γιατι οσο ναναι ειναι και ηταν ενα θεμα που εκανε τζιζ...


κλητος χατζηγεωργιου

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3320
    • P.Tsiotakis
Απ: θεμα 2Γ - κι αν το τρέξουμε για α να ειναι 10;
« Απάντηση #6 στις: 03 Ιουν 2009, 02:14:42 μμ »
Δηλαδη η επαναληψη
Για ι απο 5 μεχρι 5 με_βημα -1     δεν εκτελειται ...(καποιοι ισχυριζονται οτι εκτελειται μια φορά - μαλλον αυθαιρετα)

Δεν ξέρω αν είναι δόκιμο να ανακυκλώνεται η συζήτηση, αλλά στη σελίδα 44 είναι σαφές οτι
Για ι απο 5 μεχρι 5 με_βημα 1
εκτελεί μια επανάληψη καθώς η μετατροπή είναι
ι <-- 5
Όσο ι <= 5 επανάλαβε

όμοια και το   Για ι απο 5 μεχρι 5 με_βημα -1
εκτελεί μια επανάληψη καθώς η μετατροπή είναι
ι <-- 5
Όσο ι >= 5 επανάλαβε

Δε βλέπω καμια αυθαιρεσία

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3609
  • to Iterate is human to Recurse divine
Απ: θεμα 2Γ - κι αν το τρέξουμε για α να ειναι 10;
« Απάντηση #7 στις: 03 Ιουν 2009, 02:17:58 μμ »
 Αν το amod10 είναι ίσο με 1 τότε είναι που δεν υπάρχει κανένα απολύτως πρόβλημα αφού θα εκτελεστεί σιγουρα μια φορά και αυτό δεν είναι καθόλου αυθαίρετο. Προκύπτει αν μετατρέψεις τη Για σε Όσο αφού ανεξάρτητα αν έχεις >= 'η <= θα έχεις πάντα το = και θα δουλέψει. Αυτό δεν είναι αυθαίρετο αλλά ορίζεται ξεκάθαρα στο βιβλίο καθηγητή.
   Και να μην οριζόταν όμως με βάση το σκεπτικό που προτείνεις η παρακάτω επανάληψη έπρεπε να εκτελεστεί 1 και όχι 2 φορές

  Για ι από 5 μέχρι 4 με βήμα -1

γιατί μόλις το ι γίνει 4 δεν θα κάνει άλλη μια επανάληψη αλλά θα βγει έξω, πράγμα που δεν ισχύει

Όσον αφορά την απάντηση της μαθήτριάς σου είναι ολόσωστη πέρα από κάθε αμφιβολία

edit: Με πρόλαβε ο Παναγιώτης
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr