Γενικό Λύκειο > Εξετάσεις 2016-2017

ΘΕΜΑ Δ

(1/10) > >>

Καρκαμάνης Γεώργιος:
Εδώ σχολιάζουμε το θέμα Δ

Λαμπράκης Μανώλης:
Παιδιά πάμε καλά ??? 3 υποπρογράμματα ??????

ΜΑΚΡΙΔΑΚΗ ΣΤΕΛΛΑ:
Μπορει να εχει 3 υποπρογραμματα ομως ειναι ξεκαθαρο τι τους ζητειται μονο που δεν τους το λυνει.

Λαμπράκης Μανώλης:
Είναι δύσκολο το δ παιδιά ... ειδική η τελευυαία συνάρτηση είναι αρκετά...καλά το γ θεωρώ είναι το πιο δύσκολο θέμα εβερ

pstasinos:
ΔΙΑΔΙΚΑΣΙΑ ΕΙΣ(ΚΩΔ[50],ΑΠ[50,6])
ΜΕΤΑΒΛΗΤΕΣ
.........
ΑΡΧΗ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 50
   ΔΙΑΒΑΣΕ κωδ
   ΚΩΔ [ i ]  <-  κωδ
   ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 6
      ΔΙΑΒΑΣΕ απ
      ΑΠ[i,j] <- απ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΣΥΝΑΡΤΗΣΗ ΑΝΑΖ(κωδ,ΚΩΔ[50]) : ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
........
ΑΡΧΗ
θέση <- 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 50
   ΑΝ ΚΩΔ [ i ]=κωδ ΤΟΤΕ
      θέση <- i
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΑΝΑΖ <- θέση
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΣΥΝΑΡΤΗΣΗ ΣΥΝΑΠ(i,ΑΠ[50,6],ατ) : ΑΚΕΡΑΙΑ
ΜΕΤΑΒΛΗΤΕΣ
.........
ΑΡΧΗ
s <- 0
ΓΙΑ j ΑΠΟ ατ ΜΕΧΡΙ ατ+2
   s <- s + ΑΠ [ i , ατ ]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΣΥΝΑΠ <- s
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΔ
ΜΕΤΑΒΛΗΤΕΣ
..........
ΑΡΧΗ

ΚΑΛΕΣΕ ΕΙΣ(ΚΩΔ[50],ΑΠ[50,6])

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 50
   σα1τ <- ΣΥΝΑΠ( i , Α[50,60] , 1)
   ΑΠΤΡ[i,1] <- σα1τ
   σα2τ <- ΣΥΝΑΠ( i , Α[50,60] , 4)
   ΑΠΤΡ[i,1] <- σα2τ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΔΙΑΒΑΣΕ key
ΟΣΟ key<>'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ
   απ <- ΑΝΑΖ(key,ΚΩΔ[50])
   ΑΝ απ=0 ΤΟΤΕ
      ΓΡΑΨΕ 'ΔΒ'
   ΑΛΛΙΩΣ_ΑΝ ΑΠΤΡ[απ,1]<10 και ΑΠΤΡ[απ,2]<10 ΤΟΤΕ
      ΓΡΑΨΕ 'ΔΣ'
   ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΟΔΣ'
   ΤΕΛΟΣ_ΑΝ
   ΔΙΑΒΑΣΕ key
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ



για τυχόν διορθώσεις , θα το κοιτάξω άμεσα

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση