Αποστολέας Θέμα: θέμα 2(Γ)&θέμα 3  (Αναγνώστηκε 22529 φορές)

summer

  • Θαμώνας
  • ***
  • Μηνύματα: 31
θέμα 2(Γ)&θέμα 3
« στις: 27 Μαΐ 2009, 03:42:09 μμ »
Καλησπέρα και καλά αποτελέσματα σε όλους

Στο θέμα 2Γ ένας μαθηταράς μου έγραψε
δ<--α mod 10
Για δ απο δ μέχρι 1 με_βήμα -1
γ<--γ+β
Τέλος_Επανάληψης

Σωστό δεν είναι;
και κάτι ακόμα ...
στο θέμα 3 που λέει να ζητάει από το χρήστη να δώσει....πρέπει να τυπώσουν και μήνυμα προς το χρήστη ή ένα σκέτο Διάβασε αρκεί;Θα κόψουν κάτι αν δεν το κάνουν; Στις λύσεις πάντως που δημοσιεύει η Καθημερινή δεν έχει μήνυμα

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 988
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #1 στις: 27 Μαΐ 2009, 04:14:11 μμ »
Αν και ασυνήθιστο είναι σωστό.
Κατά την αρχικοποίηση της μεταβλητής που ελέγχει την για (δ) εκχωρείται η τιμή του δ.
Επίσης δεν κολλάει και πουθενά η μετατροπή σε όσο.

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #2 στις: 27 Μαΐ 2009, 04:29:41 μμ »
αλλάζει την αρχική τιμή (δ) εντός του βρόχου όμως!!

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 176
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #3 στις: 27 Μαΐ 2009, 04:32:27 μμ »
σε εμένα μια μαθήτρια έκανε

δ<-α mod 10
Για i απο δ μέχρι 1 με_βήμα -1
γ<-γ+β
Τέλος_επανάληψης

πόσο λέτε ότι θα την κόψουν;
VR in Computing

summer

  • Θαμώνας
  • ***
  • Μηνύματα: 31
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #4 στις: 27 Μαΐ 2009, 04:37:14 μμ »
σε εμένα μια μαθήτρια έκανε

δ<-α mod 10
Για i απο δ μέχρι 1 με_βήμα -1
γ<-γ+β
Τέλος_επανάληψης

πόσο λέτε ότι θα την κόψουν;
και εμένα μου το έκανε αυτό μια μαθήτρια.  Το πρόβλημα είναι ότι λέει να μην χρησιμοποιηθούν άλλες μεταβλητές,πραγματικά δεν ξέρω αν θα την κόψουν όλη

summer

  • Θαμώνας
  • ***
  • Μηνύματα: 31
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #5 στις: 27 Μαΐ 2009, 04:37:59 μμ »
αλλάζει την αρχική τιμή (δ) εντός του βρόχου όμως!!
ναι, αυτό με προβληματίζει και εμένα,τί να πώ δεν ξέρω...πάντως στη Γλωσσομάθεια που το δοκίμασα λειτουργεί

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2366
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #6 στις: 27 Μαΐ 2009, 04:39:13 μμ »
Το να μετατραπεί μια δομή σε μια άλλη δομή που παράγει τα ίδια αποτελέσματα έχοντας την ελευθερία των μεταβλητών είναι μάλλον κάτι πολύ απλό και γι'αυτό έπρεπε να τονιστεί ότι θα χρησιμοποιηθούν μόνο οι δοσμένες μεταβλητές
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #7 στις: 27 Μαΐ 2009, 04:50:16 μμ »
Παιδιά είναι σωστό, το ξέρω ότι φαίνεται περίεργο όμως η αρχική τιμή υπολογίζεται μόνο μια φορά κατά την πρώτη είσοδο στον βρόχο και μετά δεν ξαναυπολογίζεται οπότε είναι σωστό.
Δείτε και έτσι. Δεν είναι ισοδύναμα?

Κώδικας: [Επιλογή]
δ<--α mod 10
δ <- δ
Όσο δ >= 1 Επανάλαβε
γ<--γ+β
δ <- δ - 1
Τέλος_Επανάληψης

αλλάζει την αρχική τιμή (δ) εντός του βρόχου όμως!!
ναι, αυτό με προβληματίζει και εμένα,τί να πώ δεν ξέρω...πάντως στη Γλωσσομάθεια που το δοκίμασα λειτουργεί
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #8 στις: 27 Μαΐ 2009, 04:57:06 μμ »
Ευρυπίδη, μάλλον να μην αναφέρω τη σελίδα απο το τετράδιο μαθητή που αναφέρει να μην τροποποιούνται .... :D

γιατι θα φάω ξύλο στο τέλος, ε?   ;D

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #9 στις: 27 Μαΐ 2009, 04:59:15 μμ »
Διάλογος μαθητών ενώ έβγαιναν από την αίθουσα

Μ1: Πως πήγες;
Μ2: Δεν ξέρω ρε τι θέματα, ήταν αυτά?
Μ1: Ναι ρε τι ήταν, δύσκολα
Μ2: Όχι δύσκολα αλλά άκυρα ρε, μιλάμε πολύ άκυρα, αλλά ευτυχώς έκανα το τελευταίο θέμα
Μ1: Έλα ρε μπράβο, δεν ήταν δύσκολο?
Μ2 : Όχι ρε τι δύσκολο, μια κλιμακωτή ήταν, πανεύκολο
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

summer

  • Θαμώνας
  • ***
  • Μηνύματα: 31
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #10 στις: 27 Μαΐ 2009, 05:01:05 μμ »
Διάλογος μαθητών ενώ έβγαιναν από την αίθουσα

Μ1: Πως πήγες;
Μ2: Δεν ξέρω ρε τι θέματα, ήταν αυτά?
Μ1: Ναι ρε τι ήταν, δύσκολα
Μ2: Όχι δύσκολα αλλά άκυρα ρε, μιλάμε πολύ άκυρα, αλλά ευτυχώς έκανα το τελευταίο θέμα
Μ1: Έλα ρε μπράβο, δεν ήταν δύσκολο?
Μ2 : Όχι ρε τι δύσκολο, μια κλιμακωτή ήταν, πανεύκολο

καλο! ;D

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #11 στις: 27 Μαΐ 2009, 05:04:39 μμ »
Ρε αθεόφοβε άσε το τετράδιο του μαθητή στην ησυχία του. Και να σου πω κάτι? Γιατί να μην τροποποιείται η αρχική τιμή? Το παραπάνω παράδειγμα που έδωσα δεν είναι ισοδύναμο? Αλλά εγώ θα πω το άλλο. Σου πάει ρε η καρδιά να κόψεις από έναν μαθητή για μια τέτοια λύση? Αφού ουσιαστικά και επιστημονικά είναι σωστή. Ο μόνος που διαφωνεί είναι αυτός που έγραψε το τετράδιο του μαθητή. Αν εμείς όλοι συμφωνήσουμε είναι οκ, τον τρώμε, είμαστε πλειοψηφία.

  Η τιμή που δεν πρέπει να τροποποιείται είναι η τιμή στο μέχρι και το βήμα. Αυτά ναι, αλλά η αρχική γιατί? Αλλά να σου πω τι έγινε? Θα είπε ο συγγράφεας: Να κάτσω τώρα και να κάνω ειδική περίπτωση για την αρχική τιμή ότι δεν πρέπει να τροποποιείται? άστο μωρέ, βάλτη και αυτή μέσα.
   

Ευρυπίδη, μάλλον να μην αναφέρω τη σελίδα απο το τετράδιο μαθητή που αναφέρει να μην τροποποιούνται .... :D

γιατι θα φάω ξύλο στο τέλος, ε?   ;D
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 988
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #12 στις: 27 Μαΐ 2009, 05:25:04 μμ »
Το από δεν ανήκει στις εντολές που εκτελούνται μέσα στον βρόχο. Η αρχικοποίηση γίνεται πριν ξεκινήσουν οι επαναλήψεις.

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #13 στις: 27 Μαΐ 2009, 05:40:07 μμ »
Πάντως, ξέρετε τι γράφει το τετράδιο μαθητή, οπότε δεν το επαναναφέρω γιατί δεν είμαι αθεόφοβος αλλά θεοσεβούμενος



Διάλογος μαθητών εν
ώ έβγαιναν από την αίθουσα

Μ1: Πως πήγες;
Μ2: Δεν ξέρω ρε τι θέματα, ήταν αυτά?
Μ1: Ναι ρε τι ήταν, δύσκολα
Μ2: Όχι δύσκολα αλλά άκυρα ρε, μιλάμε πολύ άκυρα, αλλά ευτυχώς έκανα το τελευταίο θέμα
Μ1: Έλα ρε μπράβο, δεν ήταν δύσκολο?
Μ2 : Όχι ρε τι δύσκολο, μια κλιμακωτή ήταν, πανεύκολο
;D :D ;D ;D ;D :D ;D ;D :o

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #14 στις: 27 Μαΐ 2009, 05:41:00 μμ »
Τα Μ1, Μ2 στο διάλογο είναι οι παράγοντες του πολλαπλασιασμού αλα ρωσικά?

Thanasis Daskaloudis

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #15 στις: 27 Μαΐ 2009, 05:56:59 μμ »
Αν κάποιος μαθητής γράψει στο 2Γ:

Για δ απο 1 μέχρι  (α mod 10)
γ<-γ+β
Τέλος_επανάληψης

πρέπει να είναι σωστό. Χρησιμοποιεί μόνο τις α,β,γ,δ  βγάζει το ίδιο αποτέλεσμα γ.
Τι λέτε;

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #16 στις: 27 Μαΐ 2009, 06:02:56 μμ »
αφου δε χρησιμοποιείται το δ εντός τους βρόχου, σωστό μου φαίνεται

nikosx

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 375
  • ___
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #17 στις: 27 Μαΐ 2009, 06:05:50 μμ »
Για δ απο amod10 μέχρι 0 με_βήμα -1
  Αν δ>0 τότε
    γ <-- γ + β
  Τέλος_αν
Τέλος_επανάληψης

Για αυτή τη λύση ποια είναι η γνώμη σας;
Νίκος Ξένος
Καθηγητής Πληροφορικής
nxenos@sch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #18 στις: 27 Μαΐ 2009, 06:07:38 μμ »
πάλι, νομιζω οτι η τελικη τιμη του γ, είναι η σωστή σε κάθε περίπτωση

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2837
  • Πύργος Ηλείας
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #19 στις: 27 Μαΐ 2009, 06:08:13 μμ »
Για δ απο amod10 μέχρι 0 με_βήμα -1
  Αν δ>0 τότε
    γ <-- γ + β
  Τέλος_αν
Τέλος_επανάληψης

Για αυτή τη λύση ποια είναι η γνώμη σας;

Θα συμφωνήσω...

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #20 στις: 27 Μαΐ 2009, 06:26:30 μμ »
Και εγώ συμφωνώ σωστό είναι. Μάλλον σε αυτό το θέμα θα δούμε αρκετές διαφορετικές λύσεις και πρέπει να είμαστε πολύ προσεκτικοί.
Ξαναδίνω κάτω μια άλλη λύση που πόσταρα όταν δεν υπήρχε ακόμα το συγκεκριμένο thread. Νομίζω είναι η πιο σύντομη

Κώδικας: [Επιλογή]
Για δ από 0 μέχρι 0   
    γ <- γ + β*(α mod 10)
       Τέλος_Επανάληψης
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 988
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #21 στις: 27 Μαΐ 2009, 06:33:59 μμ »
Βέβαια το νόημα του αλγορίθμου είναι ο πολλαπλασιασμός χωρίς τον τελεστή * .

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #22 στις: 27 Μαΐ 2009, 06:35:09 μμ »
Α , μη μου το χαλάς τώρα δεν έλεγαν πουθενά ότι δεν μπορώ να χρησιμοποιήσω * στην μετατροπή.
Ας πρόσεχαν ;)

Βέβαια το νόημα του αλγορίθμου είναι ο πολλαπλασιασμός χωρίς τον τελεστή * .
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1150
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #23 στις: 28 Μαΐ 2009, 01:35:20 πμ »
Και μια άλλη λύση που σκέφτηκαν τα παιδιά

α<--α mod 10
Για δ απο α μέχρι 1 με_βήμα -1
γ<--γ+β
Τέλος_Επανάληψης

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 610
    • Ανάπτυξη Εφαρμογών
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #24 στις: 28 Μαΐ 2009, 02:50:34 πμ »
Όταν δίνουμε μία μετατροπή της όσο στη για νομίζω ότι είναι χρήσιμο να ταυτίζεται και η τελική τιμή του δ κάτι που σε πολλές λύσεις που ειπώθηκαν δεν ταυτίζεται. Το δ μετά το τέλος επανάληψης της όσο μπορεί να παίζει μεγάλη σημασία στην εξέλιξη του αλγόριθμου την οποία βέβαια δεν γνωρίζουμε.

Συνάδελφοι καλημέρα
« Τελευταία τροποποίηση: 28 Μαΐ 2009, 03:01:03 πμ από ntzios kostas »
Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

elf

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 312
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #25 στις: 28 Μαΐ 2009, 04:26:47 μμ »
Συμφωνώ, αλλά σε ό,τι αφορά τη βαθμολόγηση δεν νομίζω ότι είναι σωστό να κοπούν μονάδες, αν το αποτέλεσμα είναι το ίδιο. Να τι έδωσε ένας μαθητής μου:

ΓΙΑ δ ΑΠΟ 1 ΜΕΧΡΙ α MOD 10
      γ <- γ+β
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Βέβαια η τιμή του δ δεν είναι η ίδια, αλλά τότε το:

Για δ από (α mod 10)-1 ΅έχρι 0 ΅ε_βή΅α -1
γ←γ+β
Τέλος_επανάληψης

που προτείνουν συνάδελφοι (γιατί η δ<-δ-1 δεν είναι η τελευταία εντολή του βρόγχου αλλά η πρώτη) πρέπει να είναι επίσης λάθος...

Όταν δίνουμε μία μετατροπή της όσο στη για νομίζω ότι είναι χρήσιμο να ταυτίζεται και η τελική τιμή του δ κάτι που σε πολλές λύσεις που ειπώθηκαν δεν ταυτίζεται. Το δ μετά το τέλος επανάληψης της όσο μπορεί να παίζει μεγάλη σημασία στην εξέλιξη του αλγόριθμου την οποία βέβαια δεν γνωρίζουμε.

Συνάδελφοι καλημέρα

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #26 στις: 28 Μαΐ 2009, 04:32:46 μμ »
Κώστα, έχεις δίκιο και είναι ωραία παρατήρηση.

Στον συγκεκριμένο αλγόριθμο, το δ αρχικοποιείται σε νέα επανάληψη, οπ΄τε είναι το ίδιο.

Άλλωστε η εκφώνηση λέει:"Να γράψετε τμήμα αλγορίθμου, που θα έχει το ίδιο αποτέλεσμα με το παρακάτω τμήμα"



Να τι έδωσε ένας μαθητής μου:

ΓΙΑ δ ΑΠΟ 1 ΜΕΧΡΙ α MOD 10
      γ <- γ+β
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

για κάθε τιμή του α ως είσοδο, θα δίνει τα ίδια αποτελέσματα;

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #27 στις: 28 Μαΐ 2009, 04:58:02 μμ »
Οι 2 περιπτώσεις που εξετάζεις δεν είναι το ίδιο. Στην πρώτη περίπτωση έχεις λάθος τελικό αποτελέσμα. Το δ δεν γίνεται μηδέν. Στην 2η περίπτωση η σειρά με την οποία γίνονται οι υπολογισμοί αλλάζει. Εδώ τώρα χωράει πολύ κουβέντα για το αν είναι ολόσωστο, αλλά είναι σίγουρα πιο σωστό από το παραπάνω. Βγάζει τα ίδια σωστά αποτελέσματα.
   Σε συτό πάντως που λες για το δ <- δ -1 ότι αλλάζει σειρά έχεις κάποιο δίκιο, αλλά τα έχουμε ξανασυζητήσει. Όταν δεν ορίζεται με αυστηρότητα η ισοδυναμία αλγορίθμων τότε έχουμε τέτοια προβληματάκια, και αυτό που μας ενδιαφέρει σε πρώτη φάση (και εξετάζουμε) είναι να βγάζει τουλάχιστον το ίδιο αποτέλεσμα

Συμφωνώ, αλλά σε ό,τι αφορά τη βαθμολόγηση δεν νομίζω ότι είναι σωστό να κοπούν μονάδες, αν το αποτέλεσμα είναι το ίδιο. Να τι έδωσε ένας μαθητής μου:

ΓΙΑ δ ΑΠΟ 1 ΜΕΧΡΙ α MOD 10
      γ <- γ+β
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Βέβαια η τιμή του δ δεν είναι η ίδια, αλλά τότε το:
Για δ από (α mod 10)-1 ΅έχρι 0 ΅ε_βή΅α -1
γ←γ+β
Τέλος_επανάληψης
που προτείνουν συνάδελφοι (γιατί η δ<-δ-1 δεν είναι η τελευταία εντολή του βρόγχου αλλά η πρώτη) πρέπει να είναι επίσης λάθος...
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #28 στις: 28 Μαΐ 2009, 05:10:12 μμ »
Άλλωστε η εκφώνηση λέει:"Να γράψετε τμήμα αλγορίθμου, που θα έχει το ίδιο αποτέλεσμα με το παρακάτω τμήμα"

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 610
    • Ανάπτυξη Εφαρμογών
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #29 στις: 28 Μαΐ 2009, 05:44:40 μμ »

Βέβαια η τιμή του δ δεν είναι η ίδια, αλλά τότε το:

Για δ από (α mod 10)-1 ΅έχρι 0 ΅ε_βή΅α -1
γ←γ+β
Τέλος_επανάληψης

που προτείνουν συνάδελφοι (γιατί η δ<-δ-1 δεν είναι η τελευταία εντολή του βρόγχου αλλά η πρώτη) πρέπει να είναι επίσης λάθος...


Νομίζω ότι είναι λάθος και πρέπει να κοπεί κάποιο μόριο και από την απάντηση αυτή.

Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2366
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #30 στις: 28 Μαΐ 2009, 07:13:58 μμ »

Βέβαια η τιμή του δ δεν είναι η ίδια, αλλά τότε το:

Για δ από (α mod 10)-1 ΅έχρι 0 ΅ε_βή΅α -1
γ←γ+β
Τέλος_επανάληψης

που προτείνουν συνάδελφοι (γιατί η δ<-δ-1 δεν είναι η τελευταία εντολή του βρόγχου αλλά η πρώτη) πρέπει να είναι επίσης λάθος...


Νομίζω ότι είναι λάθος και πρέπει να κοπεί κάποιο μόριο και από την απάντηση αυτή.

Ίσα ίσα, η πιο τυπικά σωστή απάντηση είναι αυτή αφού οι επαναλήψεις ξεκινάνε από amod10 -1 και όχι από amod10 και τελειώνουν στο 0 και όχι στο 1.
Νομίζω ότι θα θεωρηθούν σωστές και οι 2 απαντήσεις και θα πρέπει να δοθεί τέτοια οδηγία
Όποιος έχει πρόσβαση σε διόρθωση γραπτών, ας αναφέρει τις περιπτώσεις
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

vassilisB

  • Επισκέπτης
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #31 στις: 28 Μαΐ 2009, 07:49:26 μμ »
petros_p θα συμφωνήσω απόλυτα μαζί σου. Η πλέον σωστή απάντηση είναι από a mod 10 -1 μέχρι 0. Δηλαδή αν υπήρχε εντολή μέσα στην Όσο που περιείχε το δ (π.χ. γ <-- γ + δ), τότε δεν θα συμφωνούσαμε όλοι στον παραπάνω τρόπο μετατροπής? Τι αλλάζει στη συγκεκριμένη περίπτωση?

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 610
    • Ανάπτυξη Εφαρμογών
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #32 στις: 28 Μαΐ 2009, 08:54:19 μμ »
Ας υποθέσουμε ότι έχουμε το ακόλουθο τμήμα:

διάβασε α
δ<- α
όσο δ>0 επανάλαβε
   δ<-δ-1
   γ<-γ+δ
τέλος_επανάηψης
κάλεσε Διαδ(δ,α,γ)

Οι δύο βασικές προτάσεις μετατροπής είναι:

πρώτη πρόταση:

διάβασε α
για δ από α-1 μέχρι 0 με_βήμα -1
γ<-γ+δ
τέλος_επανάληψης
κάλεσε Διαδ(δ,α,γ)

δεύτερη πρόταση:

διάβασε α
για δ από α μέχρι 1 με βήμα -1
γ<-γ +(δ-1)
τέλος_επανάληψης
κάλεσε Διαδ(δ,α,γ)

αν στον αρχικό αλγόριθμο δοθεί ως α το -5, τότε η διαδικασία θα έχει ως πρώτη παράμετρο (δ) το -5.

ο πρώτος τρόπος θα έχει ως πρώτη παράμετρο το -6, άρα είναι διαφορετικό τμήμα.

ο δεύτερο τρόπος με το για θα έχει ως δ το -5.

Άρα η πρώτη μετατροπή που περιέγραψα είναι λάθος. Νομίζω τα πράγματα είναι πλέον φανερά. 





« Τελευταία τροποποίηση: 28 Μαΐ 2009, 09:05:08 μμ από ntzios kostas »
Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2366
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #33 στις: 28 Μαΐ 2009, 08:59:05 μμ »
Ναι αλλά το δεύτερο τμήμα προσθέτει στο γ την αρχική τιμή του δ που ειναι α;
Είναι όμως α;
Δεν είναι
Η πρώτη τιμή που προστίθεται στο γ είναι η α-1 και φαίνεται από την αρχική δομή Όσο

Μην το αναλύσουμε άλλο, δεν υπάρχει σωστή και λάθος λύση
Η μια λύση κάνει λάθος στις πράξεις εντός επανάληψης και η άλλη κάνει λάθος στην τελική τιμή της μεταβλητής
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 610
    • Ανάπτυξη Εφαρμογών
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #34 στις: 28 Μαΐ 2009, 09:09:02 μμ »
Κάτι ξέχασα στη δεύτερη μετατροπή. Είχα στο μυαλό μου το γ<-γ+β, αλλά έγραψα το γ<-γ+δ. Οκ το διόρθωσα.

Πέτρο έχει σημασία, γιατί θα κόβονται  μόρια εκεί που πρέπει και θα τα δίνουμε εκεί που δεν πρέπει.
Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #35 στις: 28 Μαΐ 2009, 09:10:04 μμ »
Κώστα, γενικά έχεις δίκιο (το είπα και πρωτύτερα)

ωστόσο,

1. στη συγκεκριμένη κωδιοκοποίηση το δ, αρχικοποιείται εκ νέου σε κάθε επανάληψη, έτσι δεν έχει σημασία η τιμή του, μετά το πέρας του εσωτερικού βρόχου.
2. η εκφώνηση μιλά για το συγκεκριμένο τμήμα μόνο και επιπρόσθετα ζητά το παραγόμενο τμήμα εντολών να έχει το ίδιο αποτέλεσμα, πρακτικά τις αλλαγές στη μεταβλητή γ

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #36 στις: 28 Μαΐ 2009, 09:16:03 μμ »
όταν λέει το ίδιο αποτελέσμα εγώ καταλαβαίνω να έχουν όλες  οι μεταβλητές τις ίδιες ακριβώς τιμές μετά το πέρας και των 2 επαναλήψεων, άρα και η δ. Νομίζω ότι πρέπει η δ στο τέλος να έχει την τιμή 0. Σε αντίθετη περίπτωση πρέπει να κοπεί μια μονάδα (από τις 5)
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #37 στις: 28 Μαΐ 2009, 09:20:43 μμ »
Η τιμή του μετρητή του ΓΙΑ, μετά το βρόχο μας νοιάζει τελικά;

Είπατε στο βαθμολογικό οτι θα κοπεί ή είναι προσωπική εκτίμηση;

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #38 στις: 28 Μαΐ 2009, 09:25:28 μμ »
Υπήρχαν διχογνωμίες και δεν είδα ξεκάθαρη στάση. Αύριο που τα βαθμολογικά θα συντονιστούν θα ξέρουμε με σιγουριά ποια είναι η κατάσταση
Η τιμή του μετρητή του ΓΙΑ, μετά το βρόχο μας νοιάζει τελικά;

Είπατε στο βαθμολογικό οτι θα κοπεί ή είναι προσωπική εκτίμηση;
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

akaie

  • Νέος
  • *
  • Μηνύματα: 1
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #39 στις: 28 Μαΐ 2009, 09:35:53 μμ »
Στο συγκεκριμένο θέμα εχω γράψει το εξής

Αν δ<>0 τότε
    Για α απο δ μέχρι 1 με βήμα -1
         γ<--γ + β
    Τέλος_επανάληψης
Τέλος_αν

Μπορεί να μου καποιος αν είναι σωστό;

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #40 στις: 28 Μαΐ 2009, 09:52:54 μμ »
Στο
Κώδικας: [Επιλογή]
     δ ← α mod 10
     Όσο δ > 0 επανάλαβε
       δ ← δ − 1
       γ ← γ + β
     Τέλος_επανάληψης

Η τελική τιμή του δ μετά το βρόχο είναι 0

ΣΤΟ
Κώδικας: [Επιλογή]
Για δ από (α mod 10) μέχρι 1 με_βήμα -1
    γ ← γ + β
Τέλος_επανάληψης

η ίδια δεν είναι ;

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #41 στις: 28 Μαΐ 2009, 09:57:03 μμ »
Στο
Κώδικας: [Επιλογή]
Για δ από (α mod 10 - 1) μέχρι 0 με_βήμα -1
  γ ← γ + β
Τέλος_επανάληψης

Η τελική τιμή του δ είναι το -1, άρα αυτό είναι "λάθος"

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #42 στις: 28 Μαΐ 2009, 10:36:08 μμ »
Παιδιά, απορία

Πολλοί μαθητές έχουν δώσει τη λανθασμένη λύση:

δ ← α mod 10
Για i από δ μέχρι 1 με_βήμα -1
    γ ← γ + β
Τέλος_επανάληψης


Η

δ ← α mod 10
Για i από 1 μέχρι δ
    γ ← γ + β
Τέλος_επανάληψης


Πόσες μονάδες απο τις 5 παίρνουν; 2-3;;

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2837
  • Πύργος Ηλείας
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #43 στις: 28 Μαΐ 2009, 11:44:20 μμ »
Η μια λύση κάνει λάθος στις πράξεις εντός επανάληψης και η άλλη κάνει λάθος στην τελική τιμή της μεταβλητής

ΔΕΝ είναι έτσι τα πράγματα... αλλά έτσι:

Στο
Κώδικας: [Επιλογή]
Για δ από (α mod 10 - 1) μέχρι 0 με_βήμα -1
  γ ← γ + β
Τέλος_επανάληψης

Η τελική τιμή του δ είναι το -1, άρα αυτό είναι "λάθος"

Συγκεντρώνω και αναλύω (βγήκε λίγο μεγάλο !!!! ):


Στο:
Κώδικας: [Επιλογή]
Για δ από (α mod 10 - 1) μέχρι 0 με_βήμα -1
  γ ← γ + β
Τέλος_επανάληψης

- Στην πρώτη επανάληψη το δ θα έχει τιμή α mod 10 - 1.
- Στην τελευταία θα έχει τιμή 0.
- Μετά το τέλος των επαναλήψεων θα έχει την τιμή -1.


Στο:
Κώδικας: [Επιλογή]
Για δ από (α mod 10) μέχρι 1 με_βήμα -1
  γ ← γ + β
Τέλος_επανάληψης

- Στην πρώτη επανάληψη το δ θα έχει τιμή α mod 10.
- Στην τελευταία θα έχει τιμή 1.
- Μετά το τέλος των επαναλήψεων θα έχει την τιμή 0.


Στο:
Κώδικας: [Επιλογή]
δ <-α mod 10
Όσο δ>0 επανάλαβε
   δ<-δ-1
   γ<-γ+β
Τέλος_επανάληψης

- Στην πρώτη επανάληψη το δ θα έχει τιμή α mod 10.
- Στην τελευταία θα έχει τιμή 1.
- Μετά το τέλος των επαναλήψεων θα έχει την τιμή 0.

Δηλαδή ταυτίζεται με το προηγούμενο!



Προφανώς αν η εκφώνηση ήταν:

Κώδικας: [Επιλογή]
δ <-α mod 10
Όσο δ>0 επανάλαβε
   δ<-δ-1
   γ<- (κάτι γενικώς που να χρησιμοποιεί το δ)
Τέλος_επανάληψης

...τότε τα πράγματα θα ζόριζαν!!!
Όμως η εκφώνηση είναι αυτή που είναι (  :angel: ) και είναι ισοδύναμη με την:

Κώδικας: [Επιλογή]
δ <-α mod 10
Όσο δ>0 επανάλαβε
   γ<-γ+β
   δ<-δ-1
Τέλος_επανάληψης

Άρα δεν καταλαβαίνω προς τι ο προβληματισμός!!!



Για το θέμα των μετατροπών έχω καταγράψει κάποια πράγματα στο http://dide.ilei.sch.gr/keplinet/education/aepp_for.php

... και είναι το θέμα με το οποίο έκανα την παρθενική μου προσγείωση στο Στέκι:
https://alkisg.mysch.gr/steki/index.php?topic=1797.msg12871  :)

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2837
  • Πύργος Ηλείας
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #44 στις: 28 Μαΐ 2009, 11:47:38 μμ »
Με την ευκαιρία να σημειώσω ότι το να δίνουν Όσο για να μετατραπεί σε Για , όπου στη συνθήκη η ανισότητα δεν έχει και το ίσο ( = ), έχει ξαναπέσει στις Επαναληπτικές του 2007 (Θέμα 1 - Β2)

(βλ. στο http://dide.ilei.sch.gr/keplinet/education/docs/them_plir_c_kat_hmer_epan_070704.pdf
Θυμίζω ήταν τα θέματα που στο Θ2 είχε πίνακα τιμών με παρόμοια (αλλά αντίστροφη) λογική με τον φετινό πίνακα τιμών, το Θ3 ήταν το "Πέτρα-Ψαλίδι-Χαρτί", και το Θ4 το φοβερό με τα "αυγά και τα κοτόπουλα"... )

Παραθέτω το σχετικό κομμάτι από το http://dide.ilei.sch.gr/keplinet/education/aepp_for.php :

Θέμα 1 - Β2

Δίνεται το παρακάτω τμήμα αλγορίθμου:

Κώδικας: [Επιλογή]
I <- 1
Όσο Ι < 10 επανάλαβε
  Εμφάνισε Ι
  Ι <- Ι + 3
Τέλος_επανάληψης

Να ξαναγράψετε το παραπάνω τμήμα αλγορίθμου χρησιμοποιώντας την εντολή ΓΙΑ αντί της ΟΣΟ.

Λύση

Κώδικας: [Επιλογή]
Για Ι από 1 μέχρι 7 με_βήμα 3
  Εμφάνισε Ι
Τέλος_επανάληψης

Σε αυτήν αρκετοί μαθητές δίνουν: Για Ι από 1 μέχρι 10, που όμως θα ήταν σωστό μόνο αν η συνθήκη στην αρχική δομή επανάληψης ήταν Ι <= 10.

vistrian

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 176
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #45 στις: 29 Μαΐ 2009, 12:06:24 πμ »
Παιδιά, απορία

Πολλοί μαθητές έχουν δώσει τη λανθασμένη λύση:

δ ← α mod 10
Για i από δ μέχρι 1 με_βήμα -1
    γ ← γ + β
Τέλος_επανάληψης


Η

δ ← α mod 10
Για i από 1 μέχρι δ
    γ ← γ + β
Τέλος_επανάληψης


Πόσες μονάδες απο τις 5 παίρνουν; 2-3;;

Θα χάσουν 1 μόριο από τα 5
VR in Computing

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1150
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #46 στις: 29 Μαΐ 2009, 12:47:31 πμ »
Σε αυτήν την μετατροπή πρέπει να καταλάβουμε τι σημαίνει αυτό που ορίζει η εκφώνηση της άσκησης "...που θα έχει το ίδιο αποτέλεσμα με το παρακάτω τμήμα"

Το "ίδιο αποτέλεσμα" αναφέρεται σε
ι)Να εκτελείται ο ίδιος αριθμός επαναλήψεων;

ιι) ¨Όλες οι μεταβλητές που συμμετέχουν στην μετατροπή θα πρέπει μετά την εκτέλεση να έχουν τις ίδιες τιμές με τις αντίστοιχες μεταβλητές του αρχικού τμήματος αλγορίθμου;

ιιι) Η μεταβλητή γ να έχει την ίδια τελική τιμή;

Νομίζω πως αν ξεκαθαρίσουμε τι σημαίνει "το ίδιο αποτέλεσμα", τότε μπορούμε πολύ εύκολα να καταλάβουμε ποιες απαντήσεις θα λάβουμε ως σωστές.

petrosp13

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 2366
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #47 στις: 29 Μαΐ 2009, 12:50:30 πμ »


Στο:
Κώδικας: [Επιλογή]
δ <-α mod 10
Όσο δ>0 επανάλαβε
   δ<-δ-1
   γ<-γ+β
Τέλος_επανάληψης

- Στην πρώτη επανάληψη το δ θα έχει τιμή α mod 10.
- Στην τελευταία θα έχει τιμή 1.
- Μετά το τέλος των επαναλήψεων θα έχει την τιμή 0.

Δηλαδή ταυτίζεται με το προηγούμενο!


Άρα δεν καταλαβαίνω προς τι ο προβληματισμός!!!


Εδώ είναι το πρόβλημα
Στην Για, επανάληψη μετράει όταν εκτελείται το γ<--γ+β
Η πρώτη τιμή για την οποία εκτελείται είναι δ=αmod10-1
Η τελευταία τιμή για την οποία εκτελείται είναι δ=0

Η λύση που προτείνω έχει σωστότατες τιμές μέσα στην επανάληψη, αλλά λάθος τιμή εξόδου
Η λύση που προτείνετε έχει λάθος αρχική και τελική τιμή, αλλά σωστή τιμή εξόδου
Δεν υπάρχει λόγος να το συνεχίσουμε
Δεν μπορεί να μετατραπεί με άλλο τρόπο σε Για που να είναι απολύτως σωστός, άρα και τα δύο είναι εξίσου σωστά
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

vassilisB

  • Επισκέπτης
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #48 στις: 29 Μαΐ 2009, 06:26:38 πμ »
Συγγνώμη, αλλά από τις συζητήσεις που έχω παρακολουθήσει εδώ μέσα, δεν δεχόμαστε ότι η τελική τιμή του μετρητή της ΓΙΑ μετά την επανάληψη είναι απροσδιόριστη και ΔΕΝ μπορεί να χρησιμοποιηθεί?? Άρα σην περίπτωση που η μετατροπή γίνει ως εξής :

Για δ από (α mod 10 - 1) μέχρι 0 με_βήμα -1
  γ ← γ + β
Τέλος_επανάληψης

ο μετρητής της Για (το δ δηλαδή) παίρνει μέσα στην επανάληψη ακριβώς τις ίδιες τιμές που παίρνει και ο μετρητής της Όσο σε κάθε περίπτωση.

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #49 στις: 29 Μαΐ 2009, 06:29:39 πμ »
Στην αρχική κωδικοποίηση σε Όσο, το δ ξεκινά με την τιμή    a mod 10  και στη συνέχεια μειώνεται κατά 1
Όπως είπε ο Πέτρος και τα 2 είναι σωστά, πάμε για άλλα

vassilisB

  • Επισκέπτης
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #50 στις: 29 Μαΐ 2009, 06:39:45 πμ »
κ. Τσιωτάκη συμφωνώ ότι και οι 2 λύσεις πρέπει να πιαστούν σωστές. Ελπίζω μόνο να σκέφτονται με τον ίδιο τρόπο και οι βαθμολογητές, ώστε να μην χάσουν τζάμπα μόρια τα παιδιά που το έκαναν είτε έτσι είτε αλλιώς  :)

Wizard

  • Επισκέπτης
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #51 στις: 29 Μαΐ 2009, 08:26:06 πμ »
Στο θέμα 3Γ, υπήρχε μια λύση ως εξής:
Για κ από 1 μέχρι 19
    ΑΕ[κ] <- 0
    Για j από 1 μέχρι κ
        ΑΕ[κ] <- ΑΕ[κ] + ΕΠΙΒ[j] - ΑΠΟΒ[j]
    Τέλος_επανάληψης
Τέλος_επανάληψης

Παρόλο που γίνονται πολλές επαναλήψεις, δεν πρέπει να κοπεί καμία μονάδα, σωστά;

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2837
  • Πύργος Ηλείας
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #52 στις: 29 Μαΐ 2009, 09:49:53 πμ »
ο μετρητής της Για (το δ δηλαδή) παίρνει μέσα στην επανάληψη ακριβώς τις ίδιες τιμές που παίρνει και ο μετρητής της Όσο σε κάθε περίπτωση.

Το μέσα είναι σχετικό...

{
αρχή
μέση
τέλος
}

Μέσα προς την αρχή, μέσα αλλά στη μέση, μέσα αλλά προς το τέλος...   :D
Ποιο να είναι το καλύτερο σημείο αναφοράς;

Η γνώμη μου είναι πως ο καλύτερος τρόπος σύγκρισης μεταξύ των δύο δομών (Όσο και Για) είναι η αντιπαραβολή των τιμών όλων των μεταβλητών στο τέλος κάθε επανάληψης. Γι' αυτό και είμαι περισσότερο υπέρ της λύσης που από την αρχή είχα προτείνει...

Παρόλα αυτά, κι εγώ θα έλεγα ότι είναι σωστά και τα δύο αφού:
α) το πλήθος των επαναλήψεων είναι ίδιο
β) το γ δεν επηρεάζεται
γ) δεν μας ενδιαφέρει το δ μετά την επανάληψη (είτε αν έχει συγκεκριμένη τιμή είτε αν θεωρούμε ότι είναι απροσδιόριστο!!) αφού ο συνολικός αλγόριθμος του θέματος 2 ξέρουμε ότι δεν επηρεάζεται από αυτήν

summer

  • Θαμώνας
  • ***
  • Μηνύματα: 31
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #53 στις: 29 Μαΐ 2009, 10:12:43 πμ »
Παιδιά, απορία

Πολλοί μαθητές έχουν δώσει τη λανθασμένη λύση:

δ ← α mod 10
Για i από δ μέχρι 1 με_βήμα -1
    γ ← γ + β
Τέλος_επανάληψης


Η

δ ← α mod 10
Για i από 1 μέχρι δ
    γ ← γ + β
Τέλος_επανάληψης


Πόσες μονάδες απο τις 5 παίρνουν; 2-3;;

Θα χάσουν 1 μόριο από τα 5


Αλήθεια πιστεύεις ότι ενώ τους λέει να μην χρησιμοποιήσουν άλλες μεταβλητές από την απάντηση με i θα κοπεί μόνο 1 μόριο;

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2466
  • I 'm not young enough to know everything
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #54 στις: 29 Μαΐ 2009, 10:14:46 πμ »
Νίκο να σου θυμήσω μια κουβέντα που είχαμε παλιά για τις μετατροπές
https://alkisg.mysch.gr/steki/index.php?topic=1142.msg10687#msg10687
Δες από το σημεία που στέλνω και κάτω.

Βέβαια μια τέτοια συζήτηση είναι κατά πολύ γενικότερη από το συγκεγκριμένο θέμα εξετάσεων και κάποια στιγμή θα πρέπει να δοθεί ορισμός που θα μας εξηγεί πότε μετατρέπψαμε κάτι και πότε όχι.

Αλλά αυτά δεν αφορούν το συγκεκριμένο θέμα. Εδώ προφανώς απλά ζητάμε να εκτελεί το ίδιο πλήθος επαναλήψεων και να έχει το γ την ίδια τελική τιμή. Το δ δε μας ενδιαφέρει. Αν αρχίσουμε και μιλάμε και για το δ τότε μπαίνει στο παιχνίδι η συζήτηση στην οποία σε περαπέμπω γιατί εμφανίζονται ένα σωρό περίεργα θέματα.

vassilisB

  • Επισκέπτης
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #55 στις: 29 Μαΐ 2009, 10:53:26 πμ »
Συζήτηση για τις μετατροπές έχει γίνει πολλές φορές μέσα στο Στέκι (μπορεί να μην συμμετείχα, αλλά τις παρακολουθώ ανελλειπώς  ;D )
Εφόσον μέσα στο σχολικό βιβλίο υπάρχουν αρκετά σκοτεινά σημεία για την εντολή Για (ένα από αυτά είναι και η τελική τιμή του μετρητή μετά την επανάληψη καθώς και κατά πόσο αυτή μπορεί να χρησιμοποιηθεί) θεωρώ ότι θα ήταν τουλάχιστον άδικο να χάσει μαθητής μόρια είτε τον πρώτο τρόπο ακολούθησε είτε το δεύτερο.
Αλλώστε ακόμα και στις προτεινόμενες λύσεις από την Alfavita οι δύο προτείονουν από a mod 10 μέχρι 1 και ο τρίτος από
a mod 10 -1 μέχρι 0  :D
Στην τελική, εδώ δεν μπορούμε να συμφωνήσουμε μεταξύ μας!!!!

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2837
  • Πύργος Ηλείας
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #56 στις: 29 Μαΐ 2009, 10:55:23 πμ »
Οκ. Δε βλέπω να διαφωνούμε... Παραθέτω κι ένα απόσπασμα από τα λεγόμενά σου:

....
Επίσης είναι λάθος να ζητάμε μετατροπή της Όσο και της Μέχρις_ότου με τελεστή < ή >  σε Για (Νίκος: στην Μέχρις_ότου ισχύει το αντίθετο... Δεν θα βάζαμε =) αφού τελικά στη συνθήκη της Για γίνεται έλεγχος με τελεστή <= ή >=.
Επίσης είναι λάθος να ζητάμε μετατροπή από Όσο ή μέχρις_ότου με αλλαγή μετρητή στη μέση σε Για, αφού αλλάζουμε τη σχετική σειρά των εντολών.
...

Όντως με τις παραπάνω προϋποθέσεις τα πράγματα θα ήταν ξεκάθαρα...

Και το συμπέρασμά σου...

Αλλά αυτά δεν αφορούν το συγκεκριμένο θέμα. Εδώ προφανώς απλά ζητάμε να εκτελεί το ίδιο πλήθος επαναλήψεων και να έχει το γ την ίδια τελική τιμή. Το δ δε μας ενδιαφέρει. Αν αρχίσουμε και μιλάμε και για το δ τότε μπαίνει στο παιχνίδι η συζήτηση στην οποία σε περαπέμπω γιατί εμφανίζονται ένα σωρό περίεργα θέματα.

...όπως έγραψα κι εγώ παραπάνω με βρίσκει σύμφωνο. Αν δηλαδή ο evry πάρει την τομή όλων των posts (  :D  ) καταλήγουμε στο ότι πρέπει να θεωρηθούν σωστές και οι 2 λύσεις, και νομίζω το πνεύμα του θέματος της επιτροπής δεν είχε άλλο σκοπό!

Υ.Γ. Μην ανησυχείς vassilisB, μου φαίνεται πως δε θα υπάρχει πρόβλημα...  :)

vassilisB

  • Επισκέπτης
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #57 στις: 29 Μαΐ 2009, 11:01:39 πμ »
Έτσι θέλω να πιστεύω κι εγώ  ;)

Ακριβή

  • Βετεράνος
  • ****
  • Μηνύματα: 61
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #58 στις: 29 Μαΐ 2009, 11:03:39 πμ »
όταν λέει το ίδιο αποτελέσμα εγώ καταλαβαίνω να έχουν όλες  οι μεταβλητές τις ίδιες ακριβώς τιμές μετά το πέρας και των 2 επαναλήψεων, άρα και η δ. Νομίζω ότι πρέπει η δ στο τέλος να έχει την τιμή 0. Σε αντίθετη περίπτωση πρέπει να κοπεί μια μονάδα (από τις 5)

Καλημέρα,

στο βαθμολογικό συμφωνήσαμε ακριβώς αυτό.  Όλες οι μεταβλητές πρέπει να έχουν ακριβώς τις ίδιες τιμές αλλιώς το αποτέλεσμα δεν είναι ακριβώς το ίδιο.  Αν δεν συμβαίνει αυτό κόβονται μονάδες.

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2837
  • Πύργος Ηλείας
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #59 στις: 29 Μαΐ 2009, 11:17:27 πμ »
στο βαθμολογικό συμφωνήσαμε ακριβώς αυτό.  Όλες οι μεταβλητές πρέπει να έχουν ακριβώς τις ίδιες τιμές αλλιώς το αποτέλεσμα δεν είναι ακριβώς το ίδιο.  Αν δεν συμβαίνει αυτό κόβονται μονάδες.

Τις ίδιες τιμές σε ποιο σημείο του βρόχου (αρχή, μέση τέλος);;;. Αν θέλουμε τις ίδιες ακριβώς τιμές και αυτό να συμβαίνει συνεχώς τότε δεν υπάρχει σωστή λύση!!! Αν θέλουμε στην αρχή τότε είναι σωστή η μία λύση, αν θέλουμε στο τέλος τότε είναι σωστή η άλλη (ποια είναι η μία και ποια η άλλη;;; ).

Δηλαδή εσείς τελικά ποια θα θεωρήσετε σωστή; Μου φαίνεται τελικά ότι αυτό θα πρέπει να διευκρινιστεί σε κεντρικό επίπεδο...

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2466
  • I 'm not young enough to know everything
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #60 στις: 29 Μαΐ 2009, 11:21:55 πμ »
Προς Ακριβή:
Αν βάλει κάποιος μια σωστή Για (ως προς την τιμή του γ) που όμως αφήνει το δ με τιμή 1 και στο τέλος προσθέσει μια δ<-0 θα θεωρηθεί σωστό;

Άλλη ερώτηση:
Αν βάλει
Για δ από 10 μέχρι 1000 ! ή οτιδήποτε άλλο
! άδειο
Τέλος_επανάληψης
γ<-γ+β*δ
δ<-0

Είναι σωστό επειδή οι μεταβλητές έχουν τελικά τις ίδιες τιμές;

ʼλλο ζήτημα:
Γιατί να μιλήσουμε μόνο για ισότητα μεταβλητών και όχι για τις συνθήκες; Η Για κάνει έλεγχο με τελεστή >= ενώ η συγκεκριμένη Όσο έχει > 

Ξεφεύγουμε... Το να θέλεις ακριβώς τις ίδιες τιμές σε όλες τις μεταβλητές θέτει διάφορα ζητήματα. Το πάμε για αυστηρότητα αλλά τελικά το αφήνουμε στη μέση.

vassilisB

  • Επισκέπτης
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #61 στις: 29 Μαΐ 2009, 11:30:34 πμ »
Μα προφανώς και πρέπει να δοθεί απάντηση σε κεντρικό επίπεδο. Δε νοείται οι μισοί μαθητές να βαθμολογηθούν έτσι και οι άλλοι μισοί κοτέτσι!!

Wizard

  • Επισκέπτης
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #62 στις: 29 Μαΐ 2009, 11:32:32 πμ »
Νομίζω ότι έχουμε μπλεχτεί λίγο. Να πω κι εγώ τη γνώμη μου:
Έχουμε ένα συγκεκριμένο τμήμα αλγορίθμου και ζητάμε μετατροπή για να δίνει το ίδιο αποτέλεσμα. Για μένα, αυτό σημαίνει ότι όλες οι μεταβλητές στο τέλος να έχουν τις ίδιες τιμές με το αρχικό τμήμα (όχι μόνο η γ, αφού δεν ξέρουμε τί γίνεται παραπέρα γιατί έχουμε τμήμα αλγορίθμου).

Έχουμε λοιπόν:
δ <-α mod 10
Όσο δ>0 επανάλαβε
   δ<-δ-1
   γ<-γ+β
Τέλος_επανάληψης

Θεωρώ λάθος την Για δ από α mod 10 - 1 μέχρι 0 με_βήμα -1, γιατί στο τέλος η δ γίνεται -1.
Θεωρώ σωστή την Για δ από α mod 10 μέχρι 1 με_βήμα -1, γιατί στο τέλος η δ γίνεται 0.
Κάποιος όμως θα πει ότι σε αυτό που θεωρώ σωστό ο βρόχος εκτελείται για λανθασμένες τιμές της δ, αφού πρώτα γίνεται το δ<-δ-1, όμως στο συγκεκριμένο παράδειγμα το δ<-δ-1 δεν επηρεάζει το γ<-γ+β, άρα δεν υπάρχει πρόβλημα, δηλαδή εδώ δεν μας νοιάζει η εσωτερική τιμή του δ.
Αν όμως είχαμε κάτι σαν:
δ <-α mod 10
Όσο δ>0 επανάλαβε
   δ<-δ-1
   γ<-γ+δ
Τέλος_επανάληψης

τότε η σωστή απάντηση θα ήταν:
Για δ από α mod 10 μέχρι 1 με_βήμα -1
    γ<-γ+(δ-1)
Τέλος_επανάληψης

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2837
  • Πύργος Ηλείας
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #63 στις: 29 Μαΐ 2009, 11:33:19 πμ »
...αλλιώς το αποτέλεσμα δεν είναι ακριβώς το ίδιο.  Αν δεν συμβαίνει αυτό κόβονται μονάδες.

Προφανώς η Ακριβή μάς μετέφερε το τι ειπώθηκε... Δε σημαίνει απαραίτητα ότι συμφωνεί ή διαφωνεί στα παραπάνω...

Στην περίπτωση και των δύο λύσεων το αποτέλεσμα είναι το γ και είναι ακριβώς το ίδιο...

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2837
  • Πύργος Ηλείας
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #64 στις: 29 Μαΐ 2009, 11:37:00 πμ »
...Για μένα, αυτό σημαίνει ότι όλες οι μεταβλητές στο τέλος να έχουν τις ίδιες τιμές με το αρχικό τμήμα (όχι μόνο η γ, αφού δεν ξέρουμε τί γίνεται παραπέρα γιατί έχουμε τμήμα αλγορίθμου).
...

Ευτυχώς ξέρουμε τι γίνεται και πιο πριν και τι γίνεται πιο παραπέρα... Έχουμε τον αλγόριθμο του θέματος 2... ο οποίος δεν ανήκει ούτε στο Α, ούτε στο Β, ούτε στο Γ ερώτημα. Τον έχει πριν από όλα τα ερωτήματα...

Αυτό σώζει και την Επιτροπή αυτή τη φορά, σε σύγκριση με παλιότερες εξετάσεις, από το να δεχθεί τα πυρά...  >:D

Wizard

  • Επισκέπτης
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #65 στις: 29 Μαΐ 2009, 11:43:48 πμ »
Νομίζω ότι έχεις δίκιο, δεν είχα δει καλά ότι όλα τα ερωτήματα του 2ου θέματος αναφέρονται στον αρχικό αλγόριθμο, άρα πρέπει και το Για δ από α mod 10 -1 μέχρι 0 με_βήμα -1 να πιαστεί σωστό  :)

Ακριβή

  • Βετεράνος
  • ****
  • Μηνύματα: 61
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #66 στις: 29 Μαΐ 2009, 11:46:15 πμ »
Δεν κατάλαβα τι εννοείς.  Οι κώδικες:

Α.
δ<- α mod 10
Όσο δ>0 επανάλαβε
    δ <- δ -1
    γ <- γ + β
Τέλος_επανάληψης

και
Β.

Για δ από α mod 10 μέχρι 1 με_βήμα -1
   γ <- γ + β
Τέλος_επανάληψης

παράγουν ακριβώς τα ίδια αποτελέσματα.  Κάνω κάπου λάθος;
Συμφωνώ ότι πρέπει να δοθούν οδηγίες

Wizard

  • Επισκέπτης
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #67 στις: 29 Μαΐ 2009, 11:54:18 πμ »
Εννοεί για παράδειγμα:
Για δ από α mod 10 -1 μέχρι 0 με_βήμα -1
    γ <- γ + β
Τέλος_επανάληψης
δ <- 0

ή και αυτό:
Για δ από 1000 μέχρι α mod 10 + 1000
    γ <- γ + β
Τέλος_επανάληψης
δ <- 0

vassilisB

  • Επισκέπτης
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #68 στις: 29 Μαΐ 2009, 11:58:45 πμ »
Αντιγράφω από 2 σημεία του σχολικού βιβλίου.

1) Κεφ. 2ο - Σελ. 43

Αλγόριθμος Παράδειγμα_10
Sum <-- 0
Για i από 1 μέχρι 100
Sum <-- Sum + i
Τέλος_επανάληψης
Eκτύπωσε Sum
Τέλος Παράδειγμα_10

Οπως γίνεται φανερό, η εντολή Για...από...μέχρι περιλαμβάνει όλα τα απαιτούμενα στοιχεία για την επανάληψη, δηλαδή αρχική τιμή της μεταβλητής i (=1) και τελική τιμή (=100).

2) Κεφάλαιο 8 - Σελ. 178
Η τιμή της μεταβλητής συγκρίνεται με την τελική τιμή και εφόσον είναι μικρότερη από αυτή, τότε εκτελούνται οι εντολές που βρίσκονται στο βρόχο (ανάμεσα στις εντολές ΓΙΑ και  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ). Στη συνέχεια η μεταβλητή ελέγχου αυξάνεται κατά την τιμή που ορίζει το ΒΗΜΑ. Αν η νέα τιμή είναι μικρότερη της τελικής, τότε ο βρόχος εκτελείται ξανά. Η διαδικασία αυτή επαναλαμβάνεται συνεχώς, έως ότου η τιμή ελέγχου γίνει μεγαλύτερη της τελικής τιμής, οπότε η τερματίζεται η επανάληψη

Απορία 1: Ποιο από τα 2 ισχύει? Δηλαδή, ποια είναι η τελική τιμή του μετρητή της Για μετά την επανάληψη?
Απορία 2: Δηλαδή προτείνει κάποιος στους μαθητές του να χρησιμοποιούν τον μετρητή της Για και έξω από την επανάληψη (μετά το τέλος της δηλαδή), θεωρόντας ότι έχει κάποια συγκεκριμένη τιμή (αν ναι, ποια είναι αυτή?). Προσωπικά τους λέω να το αποφεύγουν όπως ο διάολος το λιβάνι  :D ακριβώς επειδή δεν είναι σαφώς ορισμένο στο σχολικό βιβλίο.

Παράκληση : με αφορμή την απάντηση της Ακριβή θα παρακαλούσα τους βαθμολογητές να μην περάσουν αψήφιστα το συγκεκριμένο σημείο επιλέγοντας να κόψουν μονάδες στη μία ή στην άλλη περίπτωση, αλλά να ζητήσουν οδηγίες, γνωστοποιώντας αν είναι δυνατόν ΚΑΙ τους προβληματισμούς που διατυπώνονται σε αυτό το thread...



Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2837
  • Πύργος Ηλείας
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #69 στις: 29 Μαΐ 2009, 12:02:33 μμ »
Στο κάτω κάτω, αν ένας μαθητής σκεφτεί αυτό:

Κώδικας: [Επιλογή]
Για δ από α mod 10 -1 μέχρι 0 με_βήμα -1
αντί για αυτό (που θεωρώ ότι είναι πιο πιθανό να το σκεφτεί κάποιος):

Κώδικας: [Επιλογή]
Για δ από α mod 10 μέχρι 1 με_βήμα -1
...τότε μπράβο του! Πιο πολύ κούρασε το μυαλό του για να βρει το 1ο από ότι το 2ο. Σημαίνει ότι σκέφτηκε και σε επόμενο επίπεδο, σκέφτηκε και άλλες παραμέτρους του ζητήματος...

Εγώ στις αρχικές προβλέψεις μου κατέγραψα ότι πολλοί μαθητές θα έδιναν τη λάθος λύση:

Κώδικας: [Επιλογή]
Για δ από α mod 10 μέχρι 0 με_βήμα -1
(δεν θα παρατηρούσαν την έλλειψη του = από τη συνθήκη). Αυτή η λύση τώρα τι αποτελεί; Την τομή ή την ένωση των δύο άλλων;;;  :D   Evry;

Ακριβή

  • Βετεράνος
  • ****
  • Μηνύματα: 61
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #70 στις: 29 Μαΐ 2009, 12:04:01 μμ »
Εννοεί για παράδειγμα:
Για δ από α mod 10 -1 μέχρι 0 με_βήμα -1
    γ <- γ + β
Τέλος_επανάληψης
δ <- 0

Δεν συζητήσαμε κάθε λύση που ενδεχομένως θα απαντήσει κάποιος μαθητής.  Εξετάσαμε εάν είναι σωστός ο κώδικας:

Για δ από (α mod 10) - 1 μέχρι 0 με_βήμα -1

και είπαμε ότι πρέπει να κοπούν μονάδες.  Το σκεπτικό ήταν αυτό που σας είπα.  Ότι δηλαδή όταν λέμε ίδιο αποτέλεσμα εννούμε ότι εάν πάμε να χρησιμοποιήσουμε οποιαδήποτε μεταβλητή σε επόμενο τμήμα του αλγορίθμου πρέπει να έχει την ίδια τιμή.  Έγινε μεγάλη συζήτηση επί του θέματος. 
Εν τέλει μια διεύκρίνηση από την επιτροπή τι σημαίνει ίδιο αποτέλεσμα θα επιλύσει την όποια διαφωνία.
 

vassilisB

  • Επισκέπτης
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #71 στις: 29 Μαΐ 2009, 12:04:50 μμ »
Αυτή η λύση τώρα τι αποτελεί; Την τομή ή την ένωση των δύο άλλων;;; 

Χαχαχαχα!! Τέλειο!!  ;D

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1084
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #72 στις: 29 Μαΐ 2009, 12:18:36 μμ »
Καλημέρα σας.
Στο ΒΚ που βρίσκομαι (μη με ρωτάτε όμως πού;)  :
Ποσοστό αναβαθμολόγησης ΒΚ                 : 2%
  >>                                 πανελλήνιο    : 5.5%
Άρα σε κάποια                                       :  7-8%

Το σημαντικό όμως είναι το παρακάτω  :

το είχαμε ζητήσει (ως σώμα βαθμολογητών) από πέρυσι  να εφαρμοστεί .

Διεπίστωσα ότι από φέτος υφίσταται (δειλά - δειλά) ένα δίκτυο ΒΚ. Δλδ προσπαθούμε να βρεθούμε  σ' ένα κοινό επίπεδο επικοινωνίας. Για να μην παρατηρείται το φαινόμενο το Χ ΒΚ αυστηρό ενώ το Ψ ΒΚ απλόχερο.  Ενιαία στάση σε επίπεδο ΒΚ. ʼρα και σε εθνικό.

Για το  Θ2.Γ

Για δ από (α mod 10)  μέχρι  1 με_βήμα -1
   γ <- γ+β
Τέλος_επανάληψης

Παραλλαγές (αποδεκτές)

1.
Για δ από (α mod 10)-1  μέχρι  0 με_βήμα -1
   γ <- γ+β
Τέλος_επανάληψης

2.
Για  δ  από (α mod 10)  μέχρι  0 με_βήμα -1
  Αν δ>0 τότε
      γ <- γ+β
  Τέλος_αν
Τέλος_επανάληψης

3.
δ <- α mod 10
Για δ από δ  μέχρι  1 με_βήμα -1
   γ <- γ+β
Τέλος_επανάληψης

4.
Για δ από 0 μέχρι  0
   γ <- γ+β*(α mod 10)
Τέλος_επανάληψης

Υ.Γ. Για το τελευταίο θα συνεκτιμηθεί η γενική εικόνα του γραπτού.
      Εδώ που τα λέμε μαθητής που το σκέφτηκε αυτό σίγουρα δεν είναι τυχαίος...
Και κάτι τελευταίο για εκείνους που έξω από το χορό κάνουν κριτική ανέξοδη.


Σταματήστε να πυροβολείτε τους διορθωτές-βαθμολογητές.

Δε βαθμολογούμε για το καθηλωμένο (από το 96) 1.59  ανά τετράδιο αλλά με κριτήριο καθαρά συνειδησιακό (μπορεί να είναι το παιδί μου, ο μαθητής μου) και φιλότιμο.

gpapargi

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2466
  • I 'm not young enough to know everything
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #73 στις: 29 Μαΐ 2009, 12:24:36 μμ »
Εξετάσαμε εάν είναι σωστός ο κώδικας:

Για δ από (α mod 10) - 1 μέχρι 0 με_βήμα -1

και είπαμε ότι πρέπει να κοπούν μονάδες.  Το σκεπτικό ήταν αυτό που σας είπα.  Ότι δηλαδή όταν λέμε ίδιο αποτέλεσμα εννούμε ότι εάν πάμε να χρησιμοποιήσουμε οποιαδήποτε μεταβλητή σε επόμενο τμήμα του αλγορίθμου πρέπει να έχει την ίδια τιμή.  Έγινε μεγάλη συζήτηση επί του θέματος. 
Εν τέλει μια διεύκρίνηση από την επιτροπή τι σημαίνει ίδιο αποτέλεσμα θα επιλύσει την όποια διαφωνία.

Σύμφωνα με αυτό που συμφωνήσατε στην αίθουσα Ακριβή θα πρέπει να πάρετε σωστό το σκέτο (εννοώ χωρίς εντολή επανάληψης Για)
γ<-γ+β*δ
δ<-0

Αν θέλεις και μια Για (λόγω του ότι το λέει η εκφώνηση) μπορείτε να βάλετε πιο πριν και μια άδεια Για. Πχ

Για δ από 1 μέχρι 10
Τέλος επανάληψης
γ<-γ+β*δ
δ<-0

Αυτό θα το πιάσετε σωστό λόγω του ότι τα γ και δ έχουν τελικά τις ίδιες τιμές; Εϊναι προφανές ότι δεν μετέτρεψα τίποτα.

Το θέμα είναι λεπτό: Για τις συγκεκριμένες εξετάσεις πρέπει να πιαστεί σωστό οτιδήποτε δίνει στο γ την ίδια τιμή.
Αν θέλουμε να το πάμε αυστηρά και να μιλάμε και για τελικές τιμές σε όλες τις μεταβλητές 2 αλγόριθμοι είηαι ισοδύναμοι όταν κάνουν ακριβώς τα ίδια βήματα (και συνθήκες) με την ίδια ακριβώς σειρά. Οτιδήποτε άλλο μπορεί να μας οδηγήσει σε ασυνέπειες. 

tsakmaki

  • Οπαδός
  • **
  • Μηνύματα: 12
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #74 στις: 29 Μαΐ 2009, 12:48:17 μμ »
 Συμφωνώ με την ενιαία στάση στα βαθμολογικά και με την πρόταση και το σκεπτικό του Ανδρέα.  Άλλωστε το μάθημα έχει μαθηματική σκέψη και δεν του ταιριάζει η διύλιση του κώνωπα. Το ζήτημα δεν είναι να βρούμε από που θα κοπούν μονάδες αλλά να μην υπάρχουν μαθητές που θα αδικηθούν. Σε θέματα που διαφωνούμε μεταξύ μας φαντάζεστε τι έχει ειπωθεί στις τάξεις και τι έχει ακούσει ο μαθητής ( αν πρόλαβε ο καθηγητής να διδάξει και αυτό στις δύο αξιοθρήνητες ώρες που έχουμε στη διάθεσή μας και από τις οποίες χάνονται πολλές!)

Επί του θέματος τώρα ο σκοπός του βρόχου (ως μέρος Αλγορίθμου του θέματος 2 αλλά και γενικότερα) είναι προφανώς ο υπολογισμός του γ, και οποιαδήποτε μετατροπή το επιτυγχάνει πρέπει να θεωρηθεί σωστή.

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 988
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #75 στις: 29 Μαΐ 2009, 01:00:31 μμ »
+1 και από μένα. Από την στιγμή που έχεις τον αλγόριθμο τότε οποιαδήποτε μετατροπή δίνει σωστά αποτελέσματα πρέπει κατά την γνώμη μου να ληφθεί σωστή.
Αλλιώς τι νόημα έχει το συγκεκριμένο υποερώτημα ως μέρος ενός ευρύτερου αλγορίθμου;

bagelis

  • Ομάδα διαγωνισμάτων 2009
  • *
  • Μηνύματα: 568
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #76 στις: 29 Μαΐ 2009, 01:53:29 μμ »
Συμφωνώ και εγώ για τον πολύ απλό λόγο ότι η ίδια η εκφώνηση του προβλήματος ζητά να μετατραπεί δίνοντας το ίδιο αποτέλεσμα, άρα οποιαδήποτε λύση δίνει ίδιο αποτέλεσμα είναι σωστή...

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #77 στις: 29 Μαΐ 2009, 04:06:10 μμ »
Οκ, και τα δυο θα έπρεπε να θεωρηθούν σωστά.

Στην πράξη: όπως και αν βαθμολογηθεί (θα ήθελα να ξέρω πως), θα είναι ομοιογενής η βαθμολόγηση; Για ΟΛΟΥΣ το ΙΔΙΟ;

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2837
  • Πύργος Ηλείας
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #78 στις: 29 Μαΐ 2009, 04:24:08 μμ »
Διεπίστωσα ότι από φέτος υφίσταται (δειλά - δειλά) ένα δίκτυο ΒΚ. Δλδ προσπαθούμε να βρεθούμε  σ' ένα κοινό επίπεδο επικοινωνίας. Για να μην παρατηρείται το φαινόμενο το Χ ΒΚ αυστηρό ενώ το Ψ ΒΚ απλόχερο.  Ενιαία στάση σε επίπεδο ΒΚ. Άρα και σε εθνικό.

Είχε γίνει και παλιότερα... Είχε παρουσιαστεί στο http://dide.ilei.sch.gr/keplinet/education/docs/syn_syrou2007_kanidis.pdf

Σταματήστε να πυροβολείτε τους διορθωτές-βαθμολογητές.

Δε βαθμολογούμε για το καθηλωμένο (από το 96) 1.59  ανά τετράδιο αλλά με κριτήριο καθαρά συνειδησιακό (μπορεί να είναι το παιδί μου, ο μαθητής μου) και φιλότιμο.

Ανδρέα δε νομίζω ότι κατηγόρησε - πυροβόλησε κανένας! Πρόκειται για πολύ καλό διάλογο που πιστεύουμε ότι συμβάλλει κι αυτός στο ποσοστό που του αναλογεί... Συνεχίστε το έργο σας και καλή δύναμη!!!

Juan

  • Θαμώνας
  • ***
  • Μηνύματα: 26
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #79 στις: 29 Μαΐ 2009, 07:08:57 μμ »
Εννοεί για παράδειγμα:
Για δ από α mod 10 -1 μέχρι 0 με_βήμα -1
    γ <- γ + β
Τέλος_επανάληψης
δ <- 0

Δεν συζητήσαμε κάθε λύση που ενδεχομένως θα απαντήσει κάποιος μαθητής.  Εξετάσαμε εάν είναι σωστός ο κώδικας:

Για δ από (α mod 10) - 1 μέχρι 0 με_βήμα -1

και είπαμε ότι πρέπει να κοπούν μονάδες.  Το σκεπτικό ήταν αυτό που σας είπα.  Ότι δηλαδή όταν λέμε ίδιο αποτέλεσμα εννούμε ότι εάν πάμε να χρησιμοποιήσουμε οποιαδήποτε μεταβλητή σε επόμενο τμήμα του αλγορίθμου πρέπει να έχει την ίδια τιμή.  Έγινε μεγάλη συζήτηση επί του θέματος. 
Εν τέλει μια διεύκρίνηση από την επιτροπή τι σημαίνει ίδιο αποτέλεσμα θα επιλύσει την όποια διαφωνία.

η φράση "πρέπει να κοπούν μονάδες" με τρομάζει. Δηλαδή υπάρχει περίπτωση να κοπεί πάνω από ΜΙΑ μονάδα γι'αυτό; Γνώμη μου είναι ότι ακόμα και μία μονάδα να κοπεί είναι υπερβολικό. Γενικά παρατηρώ για μικρά λάθη - που στο κάτω κάτω και πολλοί από εμάς (καθηγητές) κάνουμε ενίοτε - να προτείνετε πολλοί από εσάς να κοπεί ακόμα και το μισό ερώτημα. Ας μην είμαστε υπερβολικοί

karaberis

  • Βετεράνος
  • ****
  • Μηνύματα: 96
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #80 στις: 29 Μαΐ 2009, 10:17:59 μμ »
Λοιπόν,

για να δω αν κατάλαβα καλά...

Αφού πρώτοι-πρώτοι οι καημένοι οι μαθητές και μετά οι διάφοροι συνάδελφοι που ψάχνονται για το θέμα, γιατί υπάρχουν και οι "άλλοι", αναζήτησαν πιθανές "σωστές" απαντήσεις, επιστρατεύοντας τη φαντασία, την ευρηματικότητα, τις γνώσεις τους και όποιο άλλο μέσο είχαν στη διάθεσή τους (μάντες, χαρτορίχτρες, καφετζούδες κλπ) καταλήξανε σε κάποιες "αποδεκτές" λύσεις.

Για το σκοπό αυτό, επιστρατέφτηκαν οι συνάδελφοι που διδάσκουν το μάθημα, οι υπεύθυνοι ΠΛΗΝΕΤ, οι πρόεδροι των Βαθμολογικών Κέντρων, οι σύμβουλοι πληροφορικής και δεν ξέρω και γω ποιοί άλλοι, που μέσω των βαθμολογικών κέντρων, και των "δικτύων ΒΚ", (αααρε πληροφορική αθάνατη, ακόμα και δίκτυο ΒΚ φτιάξαμε), προσπάθησαν να μεταφέρουν στην επιτροπή των θεμάτων, το πρόβλημα που δημιούργησαν με το συγκεκριμένο θέμα. Τελικά, η επιτροπή έστειλε κάποιες "αποδεκτές" απαντήσεις και απότι φαίνεται όλα τακτοποιήθηκαν.

Εμένα αυτό μου θυμίζει τη νοικοκυρά που όταν σκουπίζει, ρίχνει τα σκουπίδια κάτω από το χαλί του σαλονιού της.

Η όλη διαδικασία θα έπρεπε να είναι ακριβώς αντίστροφή.

ΑΛΓΟΡΙΘΜΟΣ θεματοδότηση
α) Η επιτροπή σκέφτεται ένα πιθανό θέμα-ερώτημα εξετάσεων.
β) Λύνουν το θέμα ΟΛΟΙ οι θεματοδότες.
γ) Η επιτροπή εξετάζει όλες τις δυνατές λύσεις από κάθε δυνατή πλευρά και καταγράφει όσο το δυνατό περισσότερες  παρενέργειες ή προβλήματα.
δ) Διορθώνει το προτεινόμενο θέμα μετά από τις διαπιστώσεις που προέκυψαν στο προηγούμενο βήμα γ.
ε) Επαναλαμβάνει τη διαδικασία των βημάτων α-δ μέχρις ότου θεωρειθεί οτι δεν υπάρχουν πιθανές παρερμηνείς και προβλήματα στο προτεινόμενο θέμα.
στ) Καθορίζει σύμφωνα με το θέμα τις μονάδες που αντιστοιχούν σε κάθε υποερώτημα

και ενώ θα περίμενε κανείς οτι κάπου εδώ θα τελείωνε ο ΑΛΓΟΡΙΘΜΟΣ Θεματοδότηση, δυστυχώς έχει και άλλα βήματα:

ζ) Η επιτροπή εκδίδει, ΟΧΙ ενδεικτικές λύσεις, αλλά ΠΛΗΡΕΙΣ (με όλες τι παραλλαγές) ΚΑΙ ΑΝΑΛΥΤΙΚΕΣ λύσεις (με αιτιολόγηση του σκεπτικού της επιτροπής για το τι προσπαθεί να βαθμολογήσει με το συγκεκριμένο ερώτημα) στις οποίες θα περιλαμβάνεται για κάθε γραμμή ζητούμενης απάντησης τα μόρια που θα ΠΡΕΠΕΙ να δωθούν.
η) Οι λύσεις αυτές ΠΡΕΠΕΙ να είναι ΔΕΣΜΕΥΤΙΚΕΣ από τα ΒΚ και τους βαθμολογητές και όχι προαιρετικές, γεγονός που σημαίνει οτι τα βαθμολογικά κέντρα και οι βαθμολογητές πρέπει να τις τηρούν ΚΑΤΑ ΓΡΑΜΜΑ.
θ) Επίσης δίνει και πόσα μόρια πρέπει να ΚΟΒΟΝΤΑΙ ΥΠΟΧΡΕΩΤΙΚΑ στα λάθη που μπορεί να υπάρχουν στα γραπτά.
 
Όλα τα άλλα εμένα μου φαίνονται κάπως...

Τέλος πρέπει να πω, πως αυτές οι σκέψεις που μοιάζουν με "εικονική πραγματικότητα" για την Ελλάδα, δεν αφορούν, ευτυχώς αλλά και δυστυχώς, μόνο το μάθημα ΑΕΠΠ, αλλά ΟΛΑ τα μαθήματα.

Αντί αυτών, οι αδρά αμοιβόμενοι θεματοδότες, κάνουν δουλειά του ποδαριού και το ελλειπές έργο τους καλούνται να συμπληρώσουν με φιλότιμο οι τελευταίοι τροχοί της αμάξης (οι βαθμολογητές). Φυσικά, αυτό θα με ενοχλούσε πολύ λιγότερο, αλλά δυστυχώς με αυτή τη διαδικασία ΑΞΙΟΛΟΓΟΥΝΤΑΙ και ΚΡΙΝΟΝΤΑΙ υποψήφιοι μαθητές και καθορίζονται οι ΖΩΕΣ τους και το ΜΕΛΛΟΝ τους.

Φιλικά

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #81 στις: 29 Μαΐ 2009, 11:04:32 μμ »

 Δεν νομίζω ότι κάποιος μαθητής που θα χρησιμοποιήσει το i θα πρέπει να του κοπεί ένα μόριο. Κατά τη γνώμη μου πρέπει να του κοπούν 2 με 3 και εξηγώ το σκεπτικό μου. Γιατί ο μαθητής χρησιμοποίησε τον μετρητή i ενώ η εκφώνηση του έλεγε ρητά να μην την χρησιμοποιήσει? Μήπως επειδή δεν μπορούσε να το λύσει διαφορετικά? Και αυτοί που το έλυσαν χωρίς το i τι πρέπει να πάρουν? 1 μονάδα κόβουμε αν έχει λάθος κάποιο από τα άκρα. Από τη στιγμή που χρησιμοποιεί άλλες μεταβλητές 1 μονάδα είναι πάρα πολύ λίγο.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #82 στις: 29 Μαΐ 2009, 11:21:11 μμ »
ΑΛΓΟΡΙΘΜΟΣ θεματοδότηση
α) Η επιτροπή σκέφτεται ένα πιθανό θέμα-ερώτημα εξετάσεων.
β) Λύνουν το θέμα ΟΛΟΙ οι θεματοδότες.
γ) Η επιτροπή εξετάζει όλες τις δυνατές λύσεις από κάθε δυνατή πλευρά και καταγράφει όσο το δυνατό περισσότερες  παρενέργειες ή προβλήματα.
δ) Διορθώνει το προτεινόμενο θέμα μετά από τις διαπιστώσεις που προέκυψαν στο προηγούμενο βήμα γ.
ε) Επαναλαμβάνει τη διαδικασία των βημάτων α-δ μέχρις ότου θεωρειθεί οτι δεν υπάρχουν πιθανές παρερμηνείς και προβλήματα στο προτεινόμενο θέμα.
στ) Καθορίζει σύμφωνα με το θέμα τις μονάδες που αντιστοιχούν σε κάθε υποερώτημα
Πέρυσι από το στέκι είχαμε ασκήσει πολύ σκληρή κριτική στην επιτροπή, αλλά με κάποιο σκεπτικό. Η κριτική εκ των υστέρων/ εκ τους ασφαλούς όταν δεν υπάρχει ουσιαστικό πρόβλημα πιστεύω ότι είναι άδικη. Αν έχω άδικο τότε φαντάζομαι ότι εσύ μπορείς να κάνει τα βήματα α) --> στ) μέσα σε ένα βράδυ και να βγάλεις και πρωτότυπα θέματα. Αν δεν το έχεις κάνει θα σου πρότεινα να το δοκιμάσεις για να δεις πόσο δύσκολο είναι

What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

karaberis

  • Βετεράνος
  • ****
  • Μηνύματα: 96
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #83 στις: 29 Μαΐ 2009, 11:40:45 μμ »
Πρώτα από όλα, ευχαριστώ για το σχολιασμό των σκέψεών μου.

Τώρα ως προς αυτό που αναφέρεις...

Παράθεση
Πέρυσι από το στέκι είχαμε ασκήσει πολύ σκληρή κριτική στην επιτροπή, αλλά με κάποιο σκεπτικό. Η κριτική εκ των υστέρων/ εκ τους ασφαλούς όταν δεν υπάρχει ουσιαστικό πρόβλημα πιστεύω ότι είναι άδικη. Αν έχω άδικο τότε φαντάζομαι ότι εσύ μπορείς να κάνει τα βήματα α) --> στ) μέσα σε ένα βράδυ και να βγάλεις και πρωτότυπα θέματα. Αν δεν το έχεις κάνει θα σου πρότεινα να το δοκιμάσεις για να δεις πόσο δύσκολο είναι

1) Δεν ισχυρίστηκα πουθενά οτι η θεματοδότηση είναι εύκολη δουλειά ή οτι εγώ θα την έκανα καλύτερα. Αυτό νομίζω οτι φάνηκε από τον αλγόριθμο (που το πιό πιθανό είναι οτι χρειάζεται πολύ βελτίωση). Με άλλα λόγια συμφωνούμε.

2) ΚΑΙ εγώ πιστεύω οτι τα φετεινά θέματα είναι προς τη σωστή κατεύθυνση.

3) Απλά, αυτά τα διφορούμενα και "γκρίζα" υποερωτήματα είναι που χαλάνε τη συνταγή. Γιατί δηλαδή θα πρέπει να αφίνεται στη φιλοτιμία και την υπευθυνότητα των βαθμολογητών (που στο κάτω-κάτω μπορεί να μην είναι ΟΛΟΙ και οι πιό έμπειροι) και να δημιουργείται πρόβλημα ΑΞΙΟΠΙΣΤΙΑΣ στο σύστημα των εξετάσεων.

4) Εγώ προσωπικά δε συμφωνώ με αυτόν τον τρόπο αξιολόγησης των μαθητών, αλλά εφόσον αυτόν έχουμε, πρέπει τουλάχιστον να είναι ΑΝΤΙΚΕΙΜΕΝΙΚΟΣ και ΑΞΙΟΠΙΣΤΟΣ. Θα μπορούσα να το πω και λίγο διαφορετικά αστειευόμενος. Όταν τα δεδομένα (οι απαντήσεις ενός μαθητή) είναι τα ίδια πρέπει ο αλγόριθμος (βαθμολογητής) να βγάζει το ίδιο αποτέλεσμα (βαθμολογία).

Ελπίζοντας οτι φάνηκε καλύτερα τι ήθελα να πώ

Φιλικά

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #84 στις: 30 Μαΐ 2009, 12:00:28 πμ »

 Σε γενικές γραμμές πιστεύω ότι υπάρχει αξιοπιστία και αντικειμενικότητα. Πάντα θα υπάρχουν 2-3 μονάδες που μπορεί να συνδεθούν με γκρίζα σημεία του βιβλίου. Τα σημεία αυτά όμως είναι πολλά. Οπότε λογικό είναι σε κάποιες περιπτώσεις να υπάρξουν προβληματάκια. Όταν αποφασίσεις να κάνεις την αλλαγή και βάλεις θέματα που θέλουν σκέψη και είναι και πρωτότυπα σίγουρα θα αντιμετωπίσεις τέτοια πρόβληματα. Άλλωστε αυτός είναι και ο λόγος που η επιτροπή προτιμά (προτιμούσε) τις αυτούσιες φράσεις από το βιβλίο.

 Και θα σου πω και κάτι άλλο, όσον αφορά τους βαθμολογητές. Είμαι σίγουρος για ένα πράγμα. Δώσε σε έναν βαθμολογητή ένα γραπτό που έχει απαντήσει σε όλα τα ερωτήματα και είναι λίγο στρυφνό. Αφού ο βαθμολογητής βαθμολογήσει καμιά 200αριά γραπτά, δώστου πάλι το ίδιο. Το πιθανότερο είναι ότι θα του βάλει άλλο βαθμό.
  Έτσι δουλεύει το σύστημα και από τη στιγμή που δεν μπορούμε να φτιάξουμε κάτι καλύτερο (στην Ελλάδα) θα πρέπει να το στηρίξουμε γιατί είναι το μόνο (σε γενικές γραμμές) αξιοκρατικό σύστημα σε αυτήτη χώρα.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1150
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #85 στις: 30 Μαΐ 2009, 02:09:47 πμ »
Παράθεση
Διεπίστωσα ότι από φέτος υφίσταται (δειλά - δειλά) ένα δίκτυο ΒΚ. Δλδ προσπαθούμε να βρεθούμε  σ' ένα κοινό επίπεδο επικοινωνίας. Για να μην παρατηρείται το φαινόμενο το Χ ΒΚ αυστηρό ενώ το Ψ ΒΚ απλόχερο.  Ενιαία στάση σε επίπεδο ΒΚ. Άρα και σε εθνικό.

Το πρόβλημα επικοινωνίας μεταξύ βαθμολογητών το είχα αναφέρει και πέρυσι. Δεν νοείται το κάθε ένα βαθμολογικό να έχει δική του γραμμή στην βαθμολόγηση κάτι πρέπει να γίνει. Αυτό που αναφέρεις γίνεται μόνο μέσω αυτού του forum και όχι επίσημα όπως σωστά θα έπρεπε.

Μέχρι να έρθει κάτι επίσημο πάντα θα υπάρχουν διαφορές και μεταξύ μας αλλά και μεταξύ των βαθμολογητών. Απορίας άξιων είναι το πως κανείς δεν ρώτησε την επιτροπή "Τι εννοεί το ίδιο αποτέλεσμα" ώστε να δοθεί μια διευκρίνηση προς τα βαθμολογικά

Ακριβή

  • Βετεράνος
  • ****
  • Μηνύματα: 61
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #86 στις: 30 Μαΐ 2009, 07:49:45 πμ »
Καθόμασταν την Πέμπτη το απόγευμα 3,5 ώρες να προσπαθούμε να μαντέψουμε τι θέλει να πει η επιτροπή με τον όρο "ίδιο αποτέλεσμα".  Συμφωνώ με το συνάδελφο που είπε ότι η επιτροπή δεν πρέπει να δίνει μια ενδεικτική λύση αλλά πολλές πιθανές.  Δεν είναι δυνατόν να καλείται ένας βαθμολογητής να πείσει τους συναδέλφους του για την ορθότητα μιας λύσης ή να αγωνιά ότι σε άλλο βαθμολογικό το ίδιο γραπτό θα έπαιρνε όλες τις μονάδες. 

Τέλος πάντων, ζητήσαμε διευκρίνηση από την επιτροπή. 

1 μονάδα είπαμε ότι θα κόβαμε εάν όλες οι μεταβλητές δεν είχαν το ίδιο αποτέλεσμα μετά το τέλος του βρόγχου. 

Πάντως οι μετατροπές και τι σημαίνει μετατρέπω μια Όσο σε ισοδύναμη Για πρέπει να συζητηθεί διεξοδικά (όχι τώρα αλλά μετά το τέλος των πανελλαδικών).

Να πω και κάτι τελευταίο που πιστεύω ότι το γνωρίζετε ήδη.  Δεν είναι καθόλου εύκολο να βαθμολογήσεις τα παιδιά. Οι συνάδελφοι, οι περισσότεροι τουλάχιστον, είναι ευσυνείδητοι, το παιδεύουν το γραπτό. 

Γειά χαρά

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #87 στις: 30 Μαΐ 2009, 08:23:50 πμ »
Πιστεύω ότι θα πρέπει να εκτιμήσεις την συνολική εικόνα του γραπτού και το λάθος που έχει κάνει. Ίσως να μην του κόψεις και τίποτα. Εδώ φαίνεται η κρίση του βαθμολογητή. Δεν βαθμολογούμε μετρημένα κουκιά αλλά τη συνολική φιλοσοφία του μαθητή.
   Πάντως επειδή βλέπω τη διαδικασία βαθμολόγησης σε άλλες ειδικότητες (φιλόλογοι, μαθηματικοί, φυσικοί) πιστεύω ότι είμαστε από τις πιο υπεύθυνες ειδικότητες όσον αφορά τη βαθμολόγηση, δεδομένουν κιόλας ότι είμαστε ένας ανομοιογενής κλάδος. Έχει τύχει πολλές φορές να συζητήσω με συναδέλφους και να χάσουμε χρόνο μόνο για ένα γραπτό. Σε γενικές γραμμές υπάρχει υπευθυνότητα και το σύστημα πραγματικά λειτουργεί. Για τις παραφωνίες που είναι λογικό να υπάρχουν έχουν το νου τους οι συντονιστές.
   

Καθόμασταν την Πέμπτη το απόγευμα 3,5 ώρες να προσπαθούμε να μαντέψουμε τι θέλει να πει η επιτροπή με τον όρο "ίδιο αποτέλεσμα".  Συμφωνώ με το συνάδελφο που είπε ότι η επιτροπή δεν πρέπει να δίνει μια ενδεικτική λύση αλλά πολλές πιθανές.  Δεν είναι δυνατόν να καλείται ένας βαθμολογητής να πείσει τους συναδέλφους του για την ορθότητα μιας λύσης ή να αγωνιά ότι σε άλλο βαθμολογικό το ίδιο γραπτό θα έπαιρνε όλες τις μονάδες. 

Τέλος πάντων, ζητήσαμε διευκρίνηση από την επιτροπή. 

1 μονάδα είπαμε ότι θα κόβαμε εάν όλες οι μεταβλητές δεν είχαν το ίδιο αποτέλεσμα μετά το τέλος του βρόγχου. 

Πάντως οι μετατροπές και τι σημαίνει μετατρέπω μια Όσο σε ισοδύναμη Για πρέπει να συζητηθεί διεξοδικά (όχι τώρα αλλά μετά το τέλος των πανελλαδικών).

Να πω και κάτι τελευταίο που πιστεύω ότι το γνωρίζετε ήδη.  Δεν είναι καθόλου εύκολο να βαθμολογήσεις τα παιδιά. Οι συνάδελφοι, οι περισσότεροι τουλάχιστον, είναι ευσυνείδητοι, το παιδεύουν το γραπτό. 

Γειά χαρά
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Thanasis Daskaloudis

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #88 στις: 30 Μαΐ 2009, 10:09:36 μμ »
Και εκεί που πιστεύουμε ότι έχουμε εξαντλήσει όλες τις πιθανές λύσεις κοιτάξτε τι λύση έδωσε μαθητής στο Θέμα3-Γ.

Παράθεση
αθρ1[1] <-- ΕΠΙΒ[1]
αθρ2[1] <-- 0

Για Ι από 1 μέχρι 18
    αθρ1[Ι+1] <-- αθρ1[Ι] + ΕΠΙΒ[Ι+1]
    αθρ2[Ι+1] <-- αθρ2[Ι] + ΑΠΟΒ[Ι+1]
τέλος_επανάληψης

Για Ι από 1 μέχρι 19
  ΑΕ[Ι] <-- αθρ1[Ι]-αθρ2[Ι]
τέλος_επανάληψης

Μας έστειλε  :D :D

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #89 στις: 30 Μαΐ 2009, 11:01:59 μμ »
την λύση με τους 2 αθροιστές την έχουν κάναι αρκετοί, αλλά τη λύση που είδα σήμερα δεν ξέρω αν την έχει πετύχει κανείς άλλος

Εκεί που διόρθωνα λοιπόν βλέπω το παρακάτω
Κώδικας: [Επιλογή]
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 19
    Σ[Ι] <-- ΕΠΙΒ[Ι] - ΑΠΟΒ[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
και λέω, άλλος ένας που την πάτησε και ξέχασε να προσθέσει τους προηγούμενους επιβάτες.
Γυρνώντας σελίδα όμως βλέπω το παρακάτω
Κώδικας: [Επιλογή]
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 19
    AE[I] <-- 0
    ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ I
           AE[Ι] <-- AE[I] + Σ[J]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Εκεί τα χαρίζεις όλα και τελειώνει η ιστορία
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3319
    • P.Tsiotakis
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #90 στις: 31 Μαΐ 2009, 09:58:12 πμ »
Πάντως, πρέπει να σημειώσουμε οτι τα παιδιά ΔΕ σκέφτονται απλά, δεν προσπαθούν να λύσουν οτ πρόβλημα με πρόχειρά δεδομένα (όπως επίμονα πάντα τους συμβουλεύουμε) καθώς σε αυτήν την περίπτωση δε θα έμπαιναν σε τέτοιες λύσεις...

pfan

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 119
  • ...
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #91 στις: 31 Μαΐ 2009, 02:07:18 μμ »
Παράθεση
Διεπίστωσα ότι από φέτος υφίσταται (δειλά - δειλά) ένα δίκτυο ΒΚ. Δλδ προσπαθούμε να βρεθούμε  σ' ένα κοινό επίπεδο επικοινωνίας. Για να μην παρατηρείται το φαινόμενο το Χ ΒΚ αυστηρό ενώ το Ψ ΒΚ απλόχερο.  Ενιαία στάση σε επίπεδο ΒΚ. Άρα και σε εθνικό.

Το πρόβλημα επικοινωνίας μεταξύ βαθμολογητών το είχα αναφέρει και πέρυσι. Δεν νοείται το κάθε ένα βαθμολογικό να έχει δική του γραμμή στην βαθμολόγηση κάτι πρέπει να γίνει. Αυτό που αναφέρεις γίνεται μόνο μέσω αυτού του forum και όχι επίσημα όπως σωστά θα έπρεπε.

Μέχρι να έρθει κάτι επίσημο πάντα θα υπάρχουν διαφορές και μεταξύ μας αλλά και μεταξύ των βαθμολογητών. Απορίας άξιων είναι το πως κανείς δεν ρώτησε την επιτροπή "Τι εννοεί το ίδιο αποτέλεσμα" ώστε να δοθεί μια διευκρίνηση προς τα βαθμολογικά

Θα έλεγα ότι γίνεται επίσημα και όχι μόνο από αυτό το forum. Οι συντονιστές (από ένα μεγάλο ποσοστό) από τα βαθμολογικά κέντρα της χώρας, με την βοήθεια ενός κλειστού forum στο ΠΣΔ, έχουν ανταλλάξει σκέψεις και έχουν συγκλίνει τις απόψεις τους σε ένα μεγάλο βαθμό. Αυτή η προσπάθεια έχει γίνει και σε άλλα τρία μαθήματα (Μαθηματικά Γενικής, Αρχαία ΚΑΤ, Λατινικά ΚΑΤ) αλλά στο δικό μας είχε μεγαλύτερη συμμετοχή. Ελπίζω ότι του χρόνου θα είναι καλύτερη η προσπάθεια.
Πύρζα Φανή
Καθηγήτρια Πληροφορικής

Obelix

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 120
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #92 στις: 01 Ιουν 2009, 07:55:51 μμ »
Ερώτηση: Στην "κλασσική" λανθασμένη απάντηση του 3ου θέματος:

ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 19
   ΑΕ[Ι] <- ΕΠΙΒ[Ι] - ΑΠΟΒ[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

έχω δύο απορίες:
α) Θα δοθεί κάποια μονάδα από τις 7 στο μαθητή?
β) Θα πρέπει να δοθεί?

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1084
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #93 στις: 01 Ιουν 2009, 08:33:22 μμ »
2-3/7

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #94 στις: 01 Ιουν 2009, 10:09:25 μμ »
Θα πάρει 3 μονάδες
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

VAIOS

  • Βετεράνος
  • ****
  • Μηνύματα: 64
  • Γράψτε το προσωπικό σας σλόγκαν!
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #95 στις: 02 Ιουν 2009, 12:44:14 πμ »
Εμείς συμφωνήσαμε να δίνουμε 2 μονάδες.  ??? ???

karaberis

  • Βετεράνος
  • ****
  • Μηνύματα: 96
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #96 στις: 02 Ιουν 2009, 01:23:20 πμ »
Συγνώμη που επανέρχομαι και ίσως πλέον είμαστε εκτός θέματος (με αφορμή το θέμα 2Γ έχουμε ξεστρατήσει στο γενικότερο και σημαντικότερο θέμα της θεματοδότησης και της βαθμολόγησης).

Είχα γράψει σε προηγούμενο μήνυμα μεταξύ άλλων τα εξής:

Παράθεση
ζ) Η επιτροπή εκδίδει, ΟΧΙ ενδεικτικές λύσεις, αλλά ΠΛΗΡΕΙΣ (με όλες τι παραλλαγές) ΚΑΙ ΑΝΑΛΥΤΙΚΕΣ λύσεις (με αιτιολόγηση του σκεπτικού της επιτροπής για το τι προσπαθεί να βαθμολογήσει με το συγκεκριμένο ερώτημα) στις οποίες θα περιλαμβάνεται για κάθε γραμμή ζητούμενης απάντησης τα μόρια που θα ΠΡΕΠΕΙ να δωθούν.
η) Οι λύσεις αυτές ΠΡΕΠΕΙ να είναι ΔΕΣΜΕΥΤΙΚΕΣ από τα ΒΚ και τους βαθμολογητές και όχι προαιρετικές, γεγονός που σημαίνει οτι τα βαθμολογικά κέντρα και οι βαθμολογητές πρέπει να τις τηρούν ΚΑΤΑ ΓΡΑΜΜΑ.
θ) Επίσης δίνει και πόσα μόρια πρέπει να ΚΟΒΟΝΤΑΙ ΥΠΟΧΡΕΩΤΙΚΑ στα λάθη που μπορεί να υπάρχουν στα γραπτά.

και όπως φαίνεται τα προηγούμενα δυο-τρία μηνύματα,  αναδεικνύουν αυτό το πρόβλημα σε όλο του το μεγαλείο. Βέβαια θα πει κανείς, σιγά ρε φίλε, μιλάς για διαφορά 1-2 μονάδων. Όμως, αν το ίδιο φαινόμενο παρατηρηθεί σε περισσότερα υποερωτήματα ή θέματα, και από ΒΚ σε ΒΚ, το πρόβλημα μπορεί να πάρει ανησυχητικές διαστάσεις και να υπάρχουν σημαντικές αποκλείσεις στις βαθμολογήσεις.

Να επαναλάβω ακόμα για να μην παρεξηγηθώ οτι:
1. Θεωρώ οτι γενικά τα θέματα ήταν καλά
2. Ίσως πρέπει η κουβέντα αυτή να μεταφερθεί σε άλλο κατάλληλο topic
3. Τα ίδια και ίσως χειρότερα φαινόμενα παρατηρούνται και στα υπόλοιπα μαθήματα, όπου απλά όλα αυτά δεν συζητιούνται, αλλά "σκεπάζονται" επιμελώς από όλους τους εμπλεκόμενους.
4. Την κουβέντα αυτή την συνεχίζω μόνο εξαιτίας της "αγωνίας" μου για την αντικειμενικότητα της βαθμολόγησης.

Φιλικά

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #97 στις: 02 Ιουν 2009, 09:33:12 πμ »
ζ) Η επιτροπή εκδίδει, ΟΧΙ ενδεικτικές λύσεις, αλλά ΠΛΗΡΕΙΣ (με όλες τι παραλλαγές) ΚΑΙ ΑΝΑΛΥΤΙΚΕΣ λύσεις (με αιτιολόγηση του σκεπτικού της επιτροπής για το τι προσπαθεί να βαθμολογήσει με το συγκεκριμένο ερώτημα)
Ένα πρόβλημα μπορεί να έχει ακόμα και διψήφιο αριθμό απαντήσεων. Αυτή είναι μια ιδιαιτερότητα του μαθήματος. Θα πρέπει η επιτροπή να εκδόσει όλες τις απαντήσεις?

Παράθεση
στις οποίες θα περιλαμβάνεται για κάθε γραμμή ζητούμενης απάντησης τα μόρια που θα ΠΡΕΠΕΙ να δωθούν.
Υποθέτω ότι δεν έχεις εμπλακεί σε βαθμολόγηση γιατί θα ήξερες ότι κάθε βαθμολογικό μοιράζει ένα τέτοιο φύλλο στο οποίο μοιράζει τα μόρια ανάλογα. Γιατί αυτό όμως είναι ενδεικτικό και όχι δεσμευτικό? Υπάρχει σκεπτικό για αυτό.
Το θέμα είναι να πάμε μπροστά και όχι να γυρίσουμε πίσω. Το μάθημα δεν είναι ιστορία να βαθμολογούμε κόμματα και τελείες. Έχει σχέση με τον προγραμματισμό και την σχεδίαση (έστω και απλών) αλγορίθμων. Αυτού του είδους τη βαθμολόγηση την έκαναν πολλά χρόνια πριν καθηγητές χωρίς καν βασικό πτυχίο πληροφορικής που "έτυχε" να διοριστούν στην εκπαίδευση με διάφορα σεμινάρια και δεν είχαν ιδέα από αλγορίθμους. Έτσι ήθελαν ένα τυφλοσούρτη για να βαθμολογούν κάθε γραμμή. Μία για το Αν μια για το Για κλπ. Η φιλοσοφία της λύσης του μαθητή πήγαινε περίπατο!!! Θα πρέπει να γίνει κατανοητό ότι μεγαλύτερη σημασία έχει η φιλοσοφία της λύσης του μαθητή παρά το πλήθος των γραμμών του κώδικά του.

Παράθεση
η) Οι λύσεις αυτές ΠΡΕΠΕΙ να είναι ΔΕΣΜΕΥΤΙΚΕΣ από τα ΒΚ και τους βαθμολογητές και όχι προαιρετικές,
η) Οι λύσεις αυτές ΔΕΝ ΠΡΕΠΕΙ να είναι ΔΕΣΜΕΥΤΙΚΕΣ από τα ΒΚ και τους βαθμολογητές
Ο βαθμολογητής είναι καθηγητής με κρίση και κρίνει κάθε φορά από τη συνολική εικόνα του γραπτού.

Παράθεση
γεγονός που σημαίνει οτι τα βαθμολογικά κέντρα και οι βαθμολογητές πρέπει να τις τηρούν ΚΑΤΑ ΓΡΑΜΜΑ.
Αν η βαθμολόγηση γίνεται έτσι όπως το περιγράφεις τότε οι καθηγητές πληροφορικής δεν είναι απαραίτητοι, η θέση είναι καθαρά διοικητικού προσωπικού. Μια γραμματέας θα έκανε μια χαρά τη δουλειά.

Παράθεση
θ) Επίσης δίνει και πόσα μόρια πρέπει να ΚΟΒΟΝΤΑΙ ΥΠΟΧΡΕΩΤΙΚΑ στα λάθη που μπορεί να υπάρχουν στα γραπτά.
Μα είναι δυνατόν να προβλέψει η επιτροπή όλα τα πιθανά λάθη που μπορεί να κάνει ένας μαθητής??? Μιλάμε για διατύπωση αλγορίθμων σε ψευδογλώσσα ή σε πρόγραμμα. Ξέρετε πόσα λάθη μπορεί να εμφανιστούν?

  Η βαθμολόγηση του μαθήματος δεν είναι μετρημένα κουκιά και δίνω ένα παράδειγμα παρακάτω από λύση που είδα στο 3ο θέμα.

Κώδικας: [Επιλογή]
ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ 20
    ΓΙΑ J ΑΠΟ 20 ΜΕΧΡΙ Ι ΜΕ ΒΗΜΑ -1
        Α[Ι] <- ΕΠΙΒ[Ι] - ΑΠΟΒ[Ι]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Αλήθεια πόσες μονάδες πρέπει να πάρει ο μαθητής? έχει μερικές γραμμές σωστές. Να του βάλουμε κάτι.
Άλλη λύση παρακάτω στο θέμα 4)β

Κώδικας: [Επιλογή]
ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 25
        ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 7
            ΔΙΑΒΑΣΕ ΚΑΤ[25,7]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΜΕΧΡΙΣ_ΟΤΟΥ KAT[I,J] = "K" ή KAT[I,J] = "Δ"
και παρακάτω
Κώδικας: [Επιλογή]
    ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 25
        Σ[Ι] <- 0
        ΓΙΑ J ΑΠΟ 20 ΜΕΧΡΙ 7
            Σ[Ι] <- Σ[Ι] + ΚΑΤ[Ι,J]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Τι πρέπει να πάρει ο παραπάνω μαθητής που έχεις τις πρώτες γραμμές σωστά (απλά σε ελαφρά διαφορετική σειρά) και στη συνέχεια αποκαλύπτεται ότι δεν έχει καταλάβει πως οι χαρακτήρες δεν έχουν άθροισμα? Πάντως τις Για και το Διάβασε τις έχει βάλει.

Λοιπόν μην βιαζόμαστε να κρίνουμε και να πούμε ότι επειδή υπάρχει διαφορά 1-2 μονάδων ξαφνικά η βαθμολόγηση δεν είναι αντικειμενική. Ας σκεφτούμε ο κάθε ένας από εμάς το εξής. Αν μας δώσουν 2 φορές ένα γραπτό θα του βάλουμε ακριβώς τον ίδιο βαθμό? Μπορεί ναι αλλά μπορεί να ειμαστε και +/- 2 μονάδες διαφορά. Το μάθημά μας έχει ελάχιστες αναβαθμολογήσεις και αυτό δείχνει αντικειμενικότητα και καλή συνεργασία των βαθμολογικών.
   Θα πρέπει όμως να αντιληφθούμε ότι η ελευθερία του βαθμολογητή-καθηγητή είναι μια από τις βασικές αιτίες της αντικειμενικότητας του συστήματος. Είναι ένας από τους λόγους που το σύστημα αυτό δουλεύει.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1532
  • Sky's the limit
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #98 στις: 02 Ιουν 2009, 07:08:17 μμ »
Ερώτηση: Στην "κλασσική" λανθασμένη απάντηση του 3ου θέματος:

ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 19
   ΑΕ[Ι] <- ΕΠΙΒ[Ι] - ΑΠΟΒ[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

έχω δύο απορίες:
α) Θα δοθεί κάποια μονάδα από τις 7 στο μαθητή?
β) Θα πρέπει να δοθεί?
Θα πάρει 3 μονάδες

Ευριπίδη θεωρώ τις 3 μονάδες πολλές.
Πως κατανέμονται οι 7 μονάδες του ερωτήματος ; 4 μονάδες στο σωστό υπολογισμό μέσα στην επανάληψη και 3 για την επαναληπτική δομή ;
Στο βαθμολογικό συμφωνήθηκε να δίνονται 2 μονάδες τις οποίες επίσης θεωρώ χάρισμα.
Πείτε με υπερβολικά αυστηρό αλλά άποψή μου είναι ότι πρέπει να δοθεί μία (1) μονάδα.
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #99 στις: 02 Ιουν 2009, 07:15:31 μμ »
Έχεις δίκιο, αλλά αυτό συμφωνήθηκε όχι αυστηρά στις τρεις μονάδες, αλλά 2-3 μονάδες, ανάλογα με την εικόνα του γραπτού. Για παράδειγμα κάποιοι πριν την επανάληψη αυτή διαβάζουν τον πίνακα ΑΕ. Αυτοί σίγουρα δεν θα πάρουν τρεις μονάδες , μπορεί και τίποτα, έχει να κάνει με την εικόνα του γραπτού.
   
Ευριπίδη θεωρώ τις 3 μονάδες πολλές.
Πως κατανέμονται οι 7 μονάδες του ερωτήματος ; 4 μονάδες στο σωστό υπολογισμό μέσα στην επανάληψη και 3 για την επαναληπτική δομή ;
Στο βαθμολογικό συμφωνήθηκε να δίνονται 2 μονάδες τις οποίες επίσης θεωρώ χάρισμα.
Πείτε με υπερβολικά αυστηρό αλλά άποψή μου είναι ότι πρέπει να δοθεί μία (1) μονάδα.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Laertis

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 1532
  • Sky's the limit
    • ΑΣΚΗΣΕΙΣ-ΘΕΜΑΤΑ ΑΕΠΠ
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #100 στις: 02 Ιουν 2009, 07:18:48 μμ »
Οκ εφόσον δόθηκε με χαλαρή εφαρμογή ... :police:
Νικολακάκης Γιώργος
Μηχανικός Η/Υ Συστημάτων
Καθηγητής Πληροφορικής
http://users.sch.gr/gnikola

Obelix

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 120
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #101 στις: 02 Ιουν 2009, 07:31:11 μμ »
Παράθεση
Θα πρέπει να γίνει κατανοητό ότι μεγαλύτερη σημασία έχει η φιλοσοφία της λύσης του μαθητή παρά το πλήθος των γραμμών του κώδικά του.

Παράθεση
Παράθεση

    γεγονός που σημαίνει οτι τα βαθμολογικά κέντρα και οι βαθμολογητές πρέπει να τις τηρούν ΚΑΤΑ ΓΡΑΜΜΑ.

Αν η βαθμολόγηση γίνεται έτσι όπως το περιγράφεις τότε οι καθηγητές πληροφορικής δεν είναι απαραίτητοι, η θέση είναι καθαρά διοικητικού προσωπικού. Μια γραμματέας θα έκανε μια χαρά τη δουλειά.

Παράθεση
Μα είναι δυνατόν να προβλέψει η επιτροπή όλα τα πιθανά λάθη που μπορεί να κάνει ένας μαθητής??? Μιλάμε για διατύπωση αλγορίθμων σε ψευδογλώσσα ή σε πρόγραμμα. Ξέρετε πόσα λάθη μπορεί να εμφανιστούν?

Παράθεση
Λοιπόν μην βιαζόμαστε να κρίνουμε και να πούμε ότι επειδή υπάρχει διαφορά 1-2 μονάδων ξαφνικά η βαθμολόγηση δεν είναι αντικειμενική. Ας σκεφτούμε ο κάθε ένας από εμάς το εξής. Αν μας δώσουν 2 φορές ένα γραπτό θα του βάλουμε ακριβώς τον ίδιο βαθμό? Μπορεί ναι αλλά μπορεί να ειμαστε και +/- 2 μονάδες διαφορά. Το μάθημά μας έχει ελάχιστες αναβαθμολογήσεις και αυτό δείχνει αντικειμενικότητα και καλή συνεργασία των βαθμολογικών.
   Θα πρέπει όμως να αντιληφθούμε ότι η ελευθερία του βαθμολογητή-καθηγητή είναι μια από τις βασικές αιτίες της αντικειμενικότητας του συστήματος. Είναι ένας από τους λόγους που το σύστημα αυτό δουλεύει.

Καταρχήν συμφωνώ απόλυτα με τα παραπάνω.evry πιστεύω κάλυψες το ζήτημα πλήρως...

Όσο για την "κλασσική" λανθασμένη απάντηση, συμφωνώ κι εγώ ότι 3 μονάδες είναι πολλές.Έως 2, ανάλογα με τη συνολική εικόνα του γραπτού και της συγκεκριμένης άσκησης, είναι κατά τη γνώμη μου το σωστό.
« Τελευταία τροποποίηση: 02 Ιουν 2009, 09:36:48 μμ από Obelix »

andreas_p

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1084
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #102 στις: 02 Ιουν 2009, 09:06:11 μμ »
Θ3.Γ.

ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 19
   ΑΕ[Ι] <- ΕΠΙΒ[Ι] - ΑΠΟΒ[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Έχω απαντήσει πιο πάνω.

Θα πάρει 2 το πολύ 3 (ανάλογα με την εικόνα του γραπτού) / 7.
Γιώργο Ν. το 1 μον. είναι λίγο αυστηρό.
Εκτός ... και αν είναι πολύχρωμος, φαντεζί παπαγάλος.

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3606
  • to Iterate is human to Recurse divine
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #103 στις: 02 Ιουν 2009, 09:17:17 μμ »
Στο συγκεκριμένο θέμα κάποιοι μαθητές έχουν τον παρακάτω κώδικα για το δ) ερώτημα

Παράθεση
Διάβασε key (ή σταθμός)
done <- Ψευδής
pos <- 0
i <- 1
Όσο done = Ψευδής .....
......

και μετά εμφανίζουν το pos.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

Καρκαμάνης Γεώργιος

  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 1150
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #104 στις: 03 Ιουν 2009, 01:13:05 πμ »
Παράθεση
Ερώτηση: Στην "κλασσική" λανθασμένη απάντηση του 3ου θέματος:

ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 19
   ΑΕ[Ι] <- ΕΠΙΒ[Ι] - ΑΠΟΒ[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

έχω δύο απορίες:
α) Θα δοθεί κάποια μονάδα από τις 7 στο μαθητή?
β) Θα πρέπει να δοθεί?

Εμείς αποφασίσαμε να δίνουμε 2 μονάδες

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2837
  • Πύργος Ηλείας
Απ: θέμα 2(Γ)&θέμα 3
« Απάντηση #105 στις: 03 Ιουν 2009, 06:55:35 πμ »
Θ3.Γ.

ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 19
   ΑΕ[Ι] <- ΕΠΙΒ[Ι] - ΑΠΟΒ[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

Έχω απαντήσει πιο πάνω.

Θα πάρει 2 το πολύ 3 (ανάλογα με την εικόνα του γραπτού) / 7.
Γιώργο Ν. το 1 μον. είναι λίγο αυστηρό.
Εκτός ... και αν είναι πολύχρωμος, φαντεζί παπαγάλος.

Συμφωνώ...