Γενικό Λύκειο > Β΄ Λυκείου

Ερώτηση σε ασκηση

<< < (2/3) > >>

theoni:
Έχω κολλήσει δεν με βοηθάει αυτό να καταλάβω

Λαμπράκης Μανώλης:
υποθέτω αυτό που λέει  ο Ευρυπίδης είναι πως η τελευταία "έγκυρη ώρα" είναι το 23:59 ...  επίσης το χ-12 νομίζω δεν είναι σωστό, αν δώσεις πχ 0550 θα δώσει αρνητικό αποτέλεσμα... θα πρέπει να βάλεις επιπλέον δομή επιλογής για να το τσεκάρεις αυτό .. για το πμ και μμ επίσης δομή επιλογής ... πχ μέχρι τις 11 είναι πμ και μετά είναι μμ  (αν έχω καταλάβει σωστά τα δεδομένα)

theoni:
Μήπως μπορώ να έχω κι ενδεικτική απάντηση???

Λαμπράκης Μανώλης:
Διάβασε κ
Αν κ>=0001 και κ<=2359 τότε
    ώρες<--κdiv100
    λεπτά<-- κmod100
    Αν ώρες<=11 τότε
       Γράψε ώρες, ':', λεπτά , 'πμ'
    Αλλιώς 
       Αν ώρες = 12 τότε ! επειδή το 12 δεν θέλει -12 αλλά είναι μμ
               Γράψε ώρες, ':', λεπτά , 'μμ'
       Αλλιώς
               ΓΡΑΨΕ ώρες-12, ':', λεπτά , 'μμ'
       Τέλος_αν
     Τέλος_αν
Αλλιώς
  γράψε 'λάθος ώρα'
τέλος_αν

κάπως έτσι, ετοιμάζομαι για το Ιωνικός - ΑΡΗΣ (Αριανάρα μάχη παραμονής ) και το γράφω στο πόδι   :angel: >:D :laugh: :police:

Λαμπράκης Μανώλης:
Βασικά μπορείς να βάλεις και ένα αν κ=0000 τότε γράψε '00:00'

 :angel: >:D :laugh: :police:

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

[*] Προηγούμενη σελίδα

Μετάβαση στην πλήρη έκδοση