Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γενικά => Μήνυμα ξεκίνησε από: xyresh96 στις 22 Δεκ 2019, 01:06:13 πμ

Τίτλος: δεν εχω καμια θεση εδω περα αλλα απλα εχω μια ερωτηση
Αποστολή από: xyresh96 στις 22 Δεκ 2019, 01:06:13 πμ
]υπαρχει καποιου ειδους εντολη για να κανεις break σε μια λουπα η επαναληψη με βαση λογικου τελεστη αν

πχ δοκιμασα να φτιαξω την εξης λουπα

οσο αληθης επανελαβε
 //καποιες εντολες
 αν (//κατι ειναι αληθες λογω προηγουμενων) τοτε
    //εντολη που σταματαει την λουπα?????αν υπαρχει?????????
τελος επαναληψης

αν υπαρχει κατι αναλογο πειτε μου καθως κοιτωντας την πασκαλ που ειναι ιδια η ψευδογλωσσα αυτο υπαρχει......
Τίτλος: Απ: δεν εχω καμια θεση εδω περα αλλα απλα εχω μια ερωτηση
Αποστολή από: gthal στις 22 Δεκ 2019, 02:43:07 πμ
Δεν υπάρχει κάτι ανάλογο.
Αυτό που θέλεις, θα γίνει μάλλον με μια μεχρις_ότου :

Αρχή_επανάληψης
  //καποιες εντολες
μέχρις_ότου (//κατι ειναι αληθες λογω προηγουμενων)
Τίτλος: Απ: δεν εχω καμια θεση εδω περα αλλα απλα εχω μια ερωτηση
Αποστολή από: Νίκος Αδαμόπουλος στις 22 Δεκ 2019, 04:06:01 μμ
καθως κοιτωντας την πασκαλ που ειναι ιδια η ψευδογλωσσα αυτο υπαρχει......


Δεν την λες και ίδια!
Τίτλος: Απ: δεν εχω καμια θεση εδω περα αλλα απλα εχω μια ερωτηση
Αποστολή από: akalest0s στις 28 Δεκ 2019, 12:09:26 πμ
Κάτι που επιτρέπεται μεν, αλλά θεωρείται κακή τακτική αλγοριθμικά, και είναι βέβαια, είναι το να μεταβάλεις ρητά (explicitly) την μεταβλητή που ελέγχει την αρχική συνθήκη. Αντιπροτείνεται σε κάθε ευκαιρία από το διδακτικό πακέτο.

Δηλαδή, κάτι του τύπου:

Κώδικας: [Επιλογή]
ι <- 1
Όσο ι < 10 επανάλαβε
    εντολές
    ι <- ι+1
    Αν συνθήκη τότε
        ι <- 10
    Τέλος_Αν
Τέλος_επανάληψης
Τίτλος: Απ: δεν εχω καμια θεση εδω περα αλλα απλα εχω μια ερωτηση
Αποστολή από: gpapargi στις 29 Δεκ 2019, 01:42:15 μμ
Νομίζω πως το πιο κοντινό σε αυτό που γράφεις είναι το παρακάτω: (χρησιμοποίησα το δικό σου κείμενο κάνοντας μόνο προσθήκες)

λ<--αληθής
οσο λ=αληθης επανάλαβε
 //καποιες εντολες
 αν (//κατι ειναι αληθες λογω προηγουμενων) τοτε
    λ<--ψευδής
 Τέλος_αν
τελος επαναληψης

Τίτλος: Απ: δεν εχω καμια θεση εδω περα αλλα απλα εχω μια ερωτηση
Αποστολή από: Δημήτρης Γκίνης στις 30 Δεκ 2019, 12:21:17 μμ
Νομίζω πως το πιο κοντινό σε αυτό που γράφεις είναι το παρακάτω: (χρησιμοποίησα το δικό σου κείμενο κάνοντας μόνο προσθήκες)

λ<--αληθής
οσο λ=αληθης επανάλαβε
 //καποιες εντολες
 αν (//κατι ειναι αληθες λογω προηγουμενων) τοτε
    λ<--ψευδής
 Τέλος_αν
τελος επαναληψης


Τροποποιώντας  λιγακι το προηγούμενο :
λ<--αληθής
οσο λ=αληθης επανάλαβε
 //καποιες εντολες
 αν (//κατι ειναι αληθες λογω προηγουμενων) τοτε
    λ<--ψευδής
αλλιώς
//κάποιες άλλες εντολές που θα εκτελεστούν αφού βεβαιωθουμε ότι το λ είναι αληθές
 Τέλος_αν
τελος επαναληψης