Τελευταία μηνύματα

Σελίδες: [1] 2 3 4 ... 10
1
Εξετάσεις 2020-2021 / Απ: Θέματα Εξετάσεων 2020-2021 και σχολιασμός
« Τελευταίο μήνυμα από tsabatman στις Σήμερα στις 01:01:48 πμ »
Καλησπέρα σε όλους! Πάντως 2 χρόνια τώρα με το θέμα Γ έμαθα να λέω την λέξη εμπορευματοκιβώτια🤣🤣
2
Εξετάσεις 2020-2021 / Απ: Θέματα Εξετάσεων 2020-2021 και σχολιασμός
« Τελευταίο μήνυμα από kyriakos208 στις Σήμερα στις 12:43:52 πμ »
Καλησπέρα.  Στο δ4 αν μπήκε το αν διάφορο του μηδέν πριν την εμφάνιση θεωρείται λάθος? Εφόσον οι επιδόσεις είναι οι μη αρνητικοί αριθμοί
3
Εξετάσεις 2020-2021 / Απ: ΘΕΜΑ Α
« Τελευταίο μήνυμα από George Eco στις Σήμερα στις 12:30:31 πμ »
Βαθμολογικά θα πρέπει να μη κοπούν από καμία εκδοχή μονάδες και γενικά να αποφεύγονται όροι που δεν υπάρχουν στη διδακτέα ύλη. Έτσι νομίζω εγώ. Ισοδύναμο. Θυμήθηκα πάλι το 2018 Β2 και πως είχε διατυπωθεί. Δύσκολο πράγμα να θέτεις σωστά εκφωνήσεις τελικά.
4
Εξετάσεις 2020-2021 / Απ: ΘΕΜΑ Γ
« Τελευταίο μήνυμα από grdereken στις Χθες στις 11:55:29 μμ »
Μία λυση με Μεχρις_ότου και λογικη μεταβλητή
ΣΤΑΜΑΤΑ <- ΨΕΥΔΗΣ
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ Β, Ο
    ΑΝ Β <= ΜΒ ΚΑΙ Ο <= ΜΟ ΤΟΤΕ
      ΜΒ <- ΜΒ - Β
      ΜΟ <- ΜΟ - Ο
      ΠΛ <- ΠΛ + 1
      ΣΒ <- ΣΒ + Β
      ΑΝ Β > ΜΑΧ ΤΟΤΕ
        ΜΑΧ <- Β
        ΠΛ_ΜΑΧ <- 1
      ΑΛΛΙΩΣ_ΑΝ Β = ΜΑΧ ΤΟΤΕ
        ΠΛ_ΜΑΧ <- ΠΛ_ΜΑΧ + 1
      ΤΕΛΟΣ_ΑΝ
     ΑΛΛΙΩΣ
        ΣΤΑΜΑΤΑ <- ΑΛΗΘΗΣ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΣΤΑΜΑΤΑ = ΑΛΗΘΗΣ
5
Εξετάσεις 2020-2021 / Απ: ΘΕΜΑ Δ
« Τελευταίο μήνυμα από grdereken στις Χθες στις 11:46:39 μμ »
Λύση στο Δ4 με μεταφορά κάθε γραμμής σε μονοδιάστατο πίνακα αντί να γίνει ταξινόμηση πάνω στο δισδιάστατο
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
     ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 6 !μεταφορά γραμμής Ιης σε μονοδιάστατο
       ΕΠ[J] <- ΕΠΙΔ[Ι, J]
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΙΑ Κ ΑΠΟ 2 ΜΕΧΡΙ 6 !Ταξινόμηση Iης γραμμής
       ΓΙΑ J ΑΠΟ 6 ΜΕΧΡΙ K ME_BHMA -1
         ΑΝ ΕΠ[J] > ΕΠ[J-1] TOTE 
          T <- ΕΠ[J]
          ΕΠ[J] <- ΕΠ[J-1]
          ΕΠ[J-1] <- T
        ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

     ΓΡΑΨΕ ΟΝ[Ι]
     ΓΙΑ J ΑΠΟ 1 ΜΕΧΡΙ 6
      ΓΡΑΨΕ ΕΠ[j]
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
6
Εξετάσεις 2020-2021 / Απ: ΘΕΜΑ Β
« Τελευταίο μήνυμα από grdereken στις Χθες στις 11:43:26 μμ »
στο Β1 για το έλεγχο του τριψήφιου ακέραιου αριθμού μπορεί να χρησιμοποιηθεί και η συνθήκη
Χ DIV 100 >= 1 ΚΑΙ Χ DIV 100 <= 9
7
Εξετάσεις 2020-2021 / Απ: Θέματα Εξετάσεων 2020-2021 και σχολιασμός
« Τελευταίο μήνυμα από andreas_p στις Χθες στις 09:40:45 μμ »
Γιώργο να δώσουμε τη σκυτάλη στα νιάτα!
Αρκεί να ... αδράξουν !
8
Εξετάσεις 2020-2021 / Απ: ΘΕΜΑ Β
« Τελευταίο μήνυμα από andreas_p στις Χθες στις 09:38:25 μμ »
Καμία περικοπή.
9
Εξετάσεις 2020-2021 / Απ: Θέματα Εξετάσεων 2020-2021 και σχολιασμός
« Τελευταίο μήνυμα από evry στις Χθες στις 08:52:23 μμ »
Βλέπω στοίβα που έχει υλοποιηθεί με πίνακα και είναι κοντά στο stack overflow.
ή καλύτερα υλοποίηση κυκλικής ουράς όπου όταν ένας κόμβος αφαιρείται εισάγεται αμέσως στο άλλο άκρο.

Από τότε που η Ομάδα διαγωνισμάτων του Στεκιού σταμάτησε να βγάζει θέματα, οι ΚΕΕ έχουν τελματώσει στις φορτοεκφορτώσεις , στα ισοδύναμα και τις φυσαλίδες. Κοινώς, κυνηγάμε την ουρά μας (ή τη στοίβα μας ;) !
Καλό καλοκαίρι συνάδελφοι  :laugh:

Καλό καλοκαίρι Γιώργο
10
Εξετάσεις 2020-2021 / Απ: Θέματα Εξετάσεων 2020-2021 και σχολιασμός
« Τελευταίο μήνυμα από Laertis στις Χθες στις 08:43:11 μμ »
Μια ωραία πεταλούδα,
Μια ωραία πεταλούδα
σ’ένα κήπο μια φορά
καμαρώνει και απλώνει
τα γαλάζια της φτερά.

Από τότε που η Ομάδα διαγωνισμάτων του Στεκιού σταμάτησε να βγάζει θέματα, οι ΚΕΕ έχουν τελματώσει στις φορτοεκφορτώσεις , στα ισοδύναμα και τις φυσαλίδες. Κοινώς, κυνηγάμε την ουρά μας (ή τη στοίβα μας ;) !

Καλό καλοκαίρι συνάδελφοι  :laugh:
Σελίδες: [1] 2 3 4 ... 10