Το Στέκι των Πληροφορικών

Γενικά => Τεχνική υποστήριξη => Linux => Μήνυμα ξεκίνησε από: jim_katsar στις 09 Σεπ 2020, 11:56:38 ΠΜ

Τίτλος: Πρόβλημα με το AUTOLOGIN
Αποστολή από: jim_katsar στις 09 Σεπ 2020, 11:56:38 ΠΜ
Σε εργαστήριο με το νεο LTSP που στο αρχείο ltsp.conf έχουν γίνει οι κατάλληλες αλλαγές για autologin (εννοείται έχει τρέξει από τη Διαχείριση ΣΕΠΕΗΥ η ενέργεια "ltsp initrd" ) κάποια τερματικά (δεν είναι πάντα τα ίδια) δεν κάνουν login αλλά "κολλάνε"  στην κλασική αρχική εικόνα εισόδου των Ubuntu. Εκεί εμφανίζεται βελάκι που μπορείς να το πατήσεις χωρίς κωδικούς και να κάνεις login ή να πας στον χρήστη που έχεις ορίσει για το συγκεκριμένο pc στο autologin και πάλι να κάνεις κλικ στο βελάκι και κάνει login.
Έχω ορίσει ένα χρήστη ανά υπολογιστή.
Κώδικας [Επιλογή]
[f4:6d:04:ad:13:25]
HOSTNAME=pc01
AUTOLOGIN="pc01$/user1"

όπου ο χρήστης user1 θα κάνει login στο pc01 και έχει κωδικό user1

Παραθέτω το ltsp.conf και κάποια screenshots.
Γιατί να γίνεται αυτό; Φταίει το δίκτυο; Αναμένω switch Gigabit, αυτή τη στιγμή τρέχω σε 100αρι.
Τίτλος: Απ: Πρόβλημα με το AUTOLOGIN
Αποστολή από: alkisg στις 09 Σεπ 2020, 12:00:31 ΜΜ
Είναι bug του lightdm, το έχω αναφέρει αλλά δεν το έχουν λύσει ακόμα.
Εμφανίζεται σε αργά δίκτυα ή σε αργούς clients.
Λύνεται με ΜΙΑ από τις παρακάτω επιλογές στο ltsp.conf:

Κώδικας (Bash) [Επιλογή]

[clients]
# Αυτό κάνει άμεσα login, αλλά αν μετά γίνει logout, ΔΕΝ κάνει re-login
RELOGIN_TIMEOUT=0

# Αυτό κάνει login μετά από 5 δευτερόλεπτα. Το default είναι 2, και βγάζει πρόβλημα σε αργούς clients
RELOGIN_TIMEOUT=2