Αποστολέας Θέμα: Διερμηνευτής Ψευδογλώσσας  (Αναγνώστηκε 41694 φορές)

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3317
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Διερμηνευτής Ψευδογλώσσας
« Απάντηση #30 στις: 10 Ιουν 2009, 06:36:11 μμ »
Άρα αν αποθηκευτεί τοπικά το plug in θα ανοίγει offline απο browser ??

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 988
Απ: Διερμηνευτής Ψευδογλώσσας
« Απάντηση #31 στις: 10 Ιουν 2009, 06:37:00 μμ »
Ευχαριστώ και εσένα Παναγιώτη (pgrontas).

Μπορεί κάποιος να κάνει αποθήκευση της σελίδας τοπικά και να το τρέξει offline. Για την αποθήκευση του κώδικα όμως (όταν με το καλό υλοποιηθεί) θα πρέπει να έχει σύνδεση. Προς το παρόν δεν έχω σκοπό να φτιάξω και έκδοση που να λειτουργεί αυτόνομα τοπικά. Όποιος δεν έχει σύνδεση όμως  μπορεί να αποθηκεύει σε txt (π.χ. με το notepad) τα αρχεία και να τα φορτώνει με αντιγραφή επικόλληση.

Βέβαια καλό είναι να μη γίνει αυτό από κάποιον που έχει σύνδεση γιατί συνεχώς γίνονται προσθήκες και διορθώσεις στην εφαρμογή. Αυτός είναι και ο λόγος που κάθε φορά που επισκέπτεστε την σελίδα ξαναφορτώνει.

Όσον αφορά τον χρόνο που κάνει να φορτώσει : Όταν σταθεροποιηθεί κάπως η εφαρμογή τότε θα φορτώνει μόνο την πρώτη φορά που κάποιος θα μπαίνει και στην συνέχεια θα γίνεται φόρτωση από την λανθάνουσα μνήμη του φυλλομετρητή. Προς το παρόν, υπομονή :)

Η εξαγωγή σε ΓΛΩΣΣΑ, η καταγραφή εισόδου, το γέμισα πινάκων με τυχαίες τιμές, η εξαγωγή πίνακα τιμών, αλλά και άλλες υποστηρικτικές δυνατότητες (όπως δημιουργία ασκήσεων από τον διδάσκοντα, ομάδες μαθητών, ανακοινώσεις σχόλια , αξιολόγηση ασκήσεων, κατηγοριοποιήσεις ασκήσεων κτλ) είναι πράγματα τα οποία είχα στο μυαλό μου από την αρχή. Προφανώς δεν μπορούν να υλοποιηθούν όλα σε μια στιγμή (εκτός αν κάποιος άλλος θέλει να βοηθήσει :) . Σιγά σιγά όμως και εφόσον υπάρχει ενδιαφέρον αλλά και ΑΕΠΠ στο πρόγραμμα σπουδών έχω σκοπό να προσθέτω μία μία αυτές τις δυνατότητες . Όχι όμως άμεσα μιας και δεν έχω τόσο πολύ ελεύθερο χρόνο.

« Τελευταία τροποποίηση: 10 Ιουν 2009, 07:32:53 μμ από sstergou »

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3580
  • to Iterate is human to Recurse divine
Απ: Διερμηνευτής Ψευδογλώσσας
« Απάντηση #32 στις: 10 Ιουν 2009, 06:43:16 μμ »
Μια χαρά είναι και στην ταχύτητα, δοκίμασα για τους πρώτους από 1 εώς 100 και τους έβγαλε αμέσως. Μέχρι το 1000 φυσικά καθυστέρησε λίγο αλλά και πάλι τους έβγαλε.
   Φυσικά αυτό το οποίο με κέρδισε αμέσως είναι ότι μπορείς να αλλάξεις τον μετρητή i μέσα στη Για και έτσι γίνεται σίγουρα η καταλληλότερη δομή επανάληψης :D.

Κώδικας: ΓΛΩΣΣΑ
  1. Αλγόριθμος primes
  2. Εμφάνισε 'Δώσε έναν ακέραιο αριθμό'
  3. Διάβασε Ν
  4. ΓΙΑ  αριθμός  ΑΠΟ 2 ΜΕΧΡΙ Ν
  5.         ΓΙΑ i  ΑΠΟ 2 μέχρι αριθμός-1
  6.                 Αν αριθμός mod i = 0  τότε
  7.                         i <-  αριθμός+1
  8.                 Τέλος_Αν        
  9.         Τέλος_Επανάληψης
  10.         Αν i = αριθμός Τότε
  11.                 Εμφάνισε αριθμός
  12.         Τέλος_Αν
  13. Τέλος_Επανάληψης
  14. Τέλος primes
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3317
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Διερμηνευτής Ψευδογλώσσας
« Απάντηση #33 στις: 10 Ιουν 2009, 06:45:33 μμ »
Στάθη


P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3317
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Διερμηνευτής Ψευδογλώσσας
« Απάντηση #34 στις: 10 Ιουν 2009, 06:46:13 μμ »
Ευριπίδη, και ποιος πιστεύεις οτι είναι ο καταλληλότερος υπουργός;

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 988
Απ: Διερμηνευτής Ψευδογλώσσας
« Απάντηση #35 στις: 10 Ιουν 2009, 06:46:42 μμ »
Επίσης, αν θέλεις θα βρούμε και άλλες προσθήκες για να γεμίσεις και τον υπόλοιπο ελεύθερο χρόνο σου  :D

Παναγιώτη έχεις δίκιο, όσο κάθομαι και το σκέφτομαι, οι δυνατότητες που έχει είναι τεράστιες!!!
Για παράδειγμα θα μπορούσε να δημιουργηθεί κάτι σαν ηλεκτρονική τάξη:
Να μπαίνουν οι μαθητές να γράφουν τον κώδικα τους, να τον σώζουν στο site και μετά να μπαίνει ο καθηγητής να κάνει συγκεκριμένες διορθώσεις, οι οποίες να γίνονται tagged σε κάθε εντολή, ή σε ομάδες εντολών. Μετά να μπαίνουν οι μαθητές να τις βλέπουν κτλ. Μπορεί να κρατάει και ιστορικό κτλ. για κάθε μαθητή. Μπορούν να γίνουν παππάδες!

Και πάλι μπράβο, Στάθη.

Τα περισσότερα από αυτά που λες (και ιδιαίτερα η πλοήγηση σε αλγορίθμους και ασκήσεις με tags) αλλά και άλλα (περιορισμός πρόσβασης σε ασκήσεις και αλγορίθμους από τον ιδιοκτήτη τους) τα έχω λάβει υπόψη μου στον αρχικό σχεδιασμό. Δεν ξέρω όμως για τους λόγους που είπα πριν αν και πότε θα τα κάνω.

Αρκετοί από εσάς είχατε σκεφτεί κάτι τέτοιο πολύ πριν από μένα. Μάλιστα είχε συγκροτηθεί τότε και μια ομάδα. Αν πιστεύετε ότι έχετε το χρόνο και την διάθεση να συνεισφέρετε ακόμη και τώρα υπάρχουν πολλά που πρέπει να γίνουν. Ήδη έχετε σκεφτεί αρκετά!

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 988
Απ: Διερμηνευτής Ψευδογλώσσας
« Απάντηση #36 στις: 10 Ιουν 2009, 06:48:52 μμ »
Με δεξί κλικ μπορείτε να αντιγράψετε τον κώδικα ως HTML.


evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3580
  • to Iterate is human to Recurse divine
Απ: Διερμηνευτής Ψευδογλώσσας
« Απάντηση #38 στις: 11 Ιουν 2009, 01:32:51 πμ »

  Δεν θα πω όνομα, αλλά θα δώσω κάποια στοιχεία. Λοιπόν πρόκειται για πολιτικό εκπρόσωπο κόμματος στον διάλογο για την παιδεία, ο οποίος μάλιστα παντρεύεται και σύντομα. Δεν ξέρω τι θα κάνει με την πληροφορική αλλά σίγουρα θα αύξησει τις ώρες των αρχαίων ελληνικών στα σχολεία ;)

Ευριπίδη, και ποιος πιστεύεις οτι είναι ο καταλληλότερος υπουργός;
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

P.Tsiotakis

  • Ομάδα Νέου Λυκείου
  • *
  • Μηνύματα: 3317
  • agent romanoff you miss me?
    • P.Tsiotakis
Απ: Διερμηνευτής Ψευδογλώσσας
« Απάντηση #39 στις: 11 Ιουν 2009, 09:21:59 πμ »
Θα πω στο Λαζόπουλο που θα παει στο γάμο, να του πει καμια καλή κουβέντα...

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 988
Απ: Διερμηνευτής Ψευδογλώσσας
« Απάντηση #40 στις: 28 Αυγ 2009, 03:49:35 μμ »
Προστέθηκαν οι δυνατότητες εγγραφής χρηστών και δημιουργίας-διαχείρισης αλγορίθμων.

ntzios kostas

  • Καθηγητής Πληροφορικής
  • Ομάδα διαγωνισμάτων 2010
  • *
  • Μηνύματα: 609
    • Ανάπτυξη Εφαρμογών
Απ: Διερμηνευτής Ψευδογλώσσας
« Απάντηση #41 στις: 29 Αυγ 2009, 11:08:19 πμ »
Φίλε Στάθη έξοχη δουλεία. Μπράβο σου!!!!

Το μόνο που βρήκα ως παρατήρηση είναι ότι κατά βήμα προς βήμα εκτέλεσης της δομής ΓΙΑ,  ο μετρητής αλλάζει όταν η εκτέλεση μπαίνει σε μία επανάληψη δηλαδή όταν ξεπερνάει την πρώτη γραμμή του ΓΙΑ και όχι στο τέλος_επανάληψης.

Ευχαριστώ.

Το μάθημα Ανάπτυξη Εφαρμογών δεν έχει σαν στόχο την εκμάθηση κάποιου συγκεκριμένου προγραμματιστικού περιβάλλοντος ούτε την καλλιέργεια προγραμματιστικών δεξιοτήτων από τη μεριά των μαθητών. Δεν αποσκοπεί στη λεπτομερειακή εξέταση της δομής, του ρεπερτορίου και των συντακτικων κανόνων κάποιας γλώσσας...

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 988
Απ: Διερμηνευτής Ψευδογλώσσας
« Απάντηση #42 στις: 29 Αυγ 2009, 12:29:17 μμ »
Ευχαριστώ Κώστα!

Όσον αφορά την δομή Για, είναι εύκολο να γίνει μία τέτοια αλλαγή και η αλλαγή της τιμής της μεταβλητής ελέγχου να γίνεται στο τέλος_επανάληψης. Από την στιγμή όμως που η εντολή με_βήμα βρίσκεται στην πρώτη γραμμή της εντολής, έβαλα εκεί πέρα και αλλαγή της μεταβλητής ελέγχου (για λόγους κατανόησης).

Έτσι το τέλος_επανάληψης λειτουργεί όπως ακριβώς και στην όσο, μεταφέρει τη ροή εκτέλεσης στην αρχή της δομής επανάληψης.

Αν παρ' όλα αυτά οι περισσότεροι νομίζουν ότι η αλλαγή πρέπει να γίνεται στο τέλος, θα το αλλάξω.

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2833
  • Πύργος Ηλείας
Απ: Διερμηνευτής Ψευδογλώσσας
« Απάντηση #43 στις: 29 Αυγ 2009, 02:35:59 μμ »
Όσον αφορά την δομή Για, είναι εύκολο να γίνει μία τέτοια αλλαγή και η αλλαγή της τιμής της μεταβλητής ελέγχου να γίνεται στο τέλος_επανάληψης. Από την στιγμή όμως που η εντολή με_βήμα βρίσκεται στην πρώτη γραμμή της εντολής, έβαλα εκεί πέρα και αλλαγή της μεταβλητής ελέγχου (για λόγους κατανόησης).

Έτσι το τέλος_επανάληψης λειτουργεί όπως ακριβώς και στην όσο, μεταφέρει τη ροή εκτέλεσης στην αρχή της δομής επανάληψης.

Κι εγώ θα συμφωνήσω με τον Κώστα!

Για παράδειγμα στο:

Για i από 1 μέχρι 10 με_βήμα 2
   Εμφάνισε  i
Τέλος_επανάληψης

Η μετατροπή σε Όσο θα ήταν:

i<-1
Όσο i<=10 επανάλαβε
   Εμφάνισε  i
   i<-i+2
Τέλος_επανάληψης 

Δηλαδή θα περίμενε κάποιος όταν η εκτέλεση θα φτάνει στο Τέλος_επανάληψης κάθε φορά, να έχει αλλάξει ήδη η τιμή της μεταβλητής (ή να αλλάζει τη στιγμή εκείνη αφού η εντολή  i<-i+2 είναι αόρατη) - βλ. εικόνα. Αλλιώς μπορεί να δημιουργήσει σύγχυση ακριβώς σε αυτό: στον συσχετισμό με την Όσο...

sstergou

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 988
Απ: Διερμηνευτής Ψευδογλώσσας
« Απάντηση #44 στις: 29 Αυγ 2009, 03:38:35 μμ »
Έχετε δίκιο στο ότι μπορεί να μπερδέψει κάποιον που έχει στο μυαλό του την ισοδύναμη Όσο. Μιλάμε όμως για διαφορετική δομή.

Όπως και να χει, το αλλάζω.