Αποστολέας Θέμα: Απορία  (Αναγνώστηκε 691 φορές)

evry

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 3604
  • to Iterate is human to Recurse divine
Απ: Απορία
« Απάντηση #15 στις: 14 Ιουν 2021, 10:36:10 μμ »
Με το να καθόμαστε να σκεφτόμαστε ακραία ΣΛ σε ένα μάθημα με άπειρα γκρίζα σημεία μόνο καλό δεν κάνουμε.

Ο προβληματισμός μου αφορά κάποιο Σωστό  - Λάθος της μορφής:
<<Κατά την κλήση μιας διαδικασίας επιτρέπεται να υπάρχει σαν παράμετρος ένας αριθμός  >>.
Ελπίζω ότι δε θα δούμε κάτι τέτοιο.

Ξέρετε πόσα ΣΛ μπορούμε να βγάλουμε που να μην έχουν απάντηση?
π.χ.
Επιτρέπεται σε πραγματική μεταβλητή να εκχωρήσουμε ακέραια τιμή;
Σωστό ή Λάθος;
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

George Eco

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 449
Απ: Απορία
« Απάντηση #16 στις: 15 Ιουν 2021, 12:44:11 πμ »
Ο προβληματισμός μου αφορά κάποιο Σωστό  - Λάθος της μορφής:
<<Κατά την κλήση μιας διαδικασίας επιτρέπεται να υπάρχει σαν παράμετρος ένας αριθμός  >>.
Ελπίζω ότι δε θα δούμε κάτι τέτοιο.

Νομίζω πως η παράμετρος μια χαρά θα μπορούσε να είναι αριθμός. Σε αυτή τη περίπτωση δε δέχεται αλλαγές, ενώ αν "κουμπώσουμε" μεταβλητή, οι αλλαγές μεταφέρονται κανονικά. Προσωπικά δε με βασανίζει αυτό κι υποθέτω πως αυτή η Σ/Λ θα είχε απάντηση ΣΩΣΤΟ, μόνο και μόνο για τον εξής λόγο:

! ...
! Κάπου σε ένα πρόγραμμα...
ΚΑΛΕΣΕ ΑΑΑ(10)
!... κλπ...

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΑΑΑ(Χ)
  ΜΕΤΑΒΛΗΤΕΣ
     ΑΚΕΡΑΙΕΣ: Χ, Ι
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ Χ
     ΓΡΑΨΕ 'ΟΡΙΣΤΕ!'
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Δε βρίσκω λόγο να μη γίνεται αυτό.





Με το να καθόμαστε να σκεφτόμαστε ακραία ΣΛ σε ένα μάθημα με άπειρα γκρίζα σημεία μόνο καλό δεν κάνουμε.

Ξέρετε πόσα ΣΛ μπορούμε να βγάλουμε που να μην έχουν απάντηση?
π.χ.
Επιτρέπεται σε πραγματική μεταβλητή να εκχωρήσουμε ακέραια τιμή;
Σωστό ή Λάθος;

ΑΥΤΟ δε θα πέσει... ελπίζω... γιατί θα πρέπει by the book να πούμε ΛΑΘΟΣ κλαίγοντας.
Βέβαια evry τι θα κάνουμε με Χ πραγματική;
Χ <- 12 * 1.0
για να αναθέσουμε τιμή;  :D