Γενικό Λύκειο > Πολυδιάστατοι πίνακες

Δομες Δεδομενων

(1/2) > >>

Δημήτρης Μαχαίρας:
Μπορεί κάποιος να με βοηθήσει στην Άσκηση 45 ?

P.Tsiotakis:
έβαλα κατά λάθος εδώ απάντηση για το μαγικό τετράγωνο, και την μετάφερα εκεί που έπρεπε

Δημήτρης Μαχαίρας:
Ευχαριστώ!

tasospap:
ΠΡΟΓΡΑΜΜΑ ΔΟΜΕΣ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Ι, Π[30], Κ,Λ,Σ,Σ_ΜΑΧ,ΠΛ,ΠΛ_ΜΑΧ
ΑΡΧΗ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 30
    ΔΙΑΒΑΣΕ Π[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  Σ_ΜΑΧ <-- 0
  ΠΛ_ΜΑΧ <-- 0   
  ΓΙΑ Λ ΑΠΟ 1 ΜΕΧΡΙ 30
    Κ <-- 30
    ΑΝ Κ>Λ ΤΟΤΕ
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
        Σ <-- 0
        ΠΛ <-- 0
        ΓΙΑ Ι ΑΠΟ Λ ΜΕΧΡΙ Κ
          Σ <-- Σ+Π[Ι]
          ΠΛ <-- ΠΛ+1
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
        ΑΝ Σ>Σ_ΜΑΧ ΤΟΤΕ
          Σ_ΜΑΧ <-- Σ
          ΠΛ_ΜΑΧ <-- ΠΛ
        ΤΕΛΟΣ_ΑΝ
        Κ <-- Κ-1
      ΜΕΧΡΙΣ_ΟΤΟΥ Κ=Λ
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ 
  ΓΡΑΨΕ Σ_ΜΑΧ, ΠΛ_ΜΑΧ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Η λογική είναι η εξής:
Βρίσκω όλους τους πιθανούς συνδυασμούς αθροισμάτων που ξεκινούν με το Π[1].
π.χ. Π[1]+Π[2].....+Π[30]
       Π[1]+Π[2].....+Π[29]
       Π[1]+Π[2].....+Π[28]
......................................
       Π[1]+Π[2]+Π[3]
       Π[1]+Π[2]

στη συνέχεια κάνω το ίδιο για το Π[2] και κτλ.

       Π[2]+Π[3].....+Π[30]
       Π[2]+Π[3].....+Π[29]
       Π[2]+Π[3].....+Π[28]
......................................
       Π[2]+Π[3]+Π[4]
       Π[2]+Π[3]


Κάθε άθροισμα που βρίσκω το συγκρίνω με το Σ_ΜΑΧ και μετράω το πλήθος των όρων από το οποίο αποτελείται.




Δημήτρης Μαχαίρας:
Ευχαριστώ!

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση