Γενικό Λύκειο > Εξετάσεις 2006-2007

Συζήτηση για το 2ο θέμα

(1/7) > >>

Dem:
στο δευτερο θεμα ηθελε συγκεκριμενο τροπο που θα χρησιμοποιησει το προγραμμα το υποπρογραμμα???
θα χρησιμοποιησουμε μια τεταρτη μεταβλητη και θα εκχωρησουμε την τιμη απο τη διαδικασια πραξεις(η λυση που βλεπω στα site) η θα στειλουμε και τη μεταβλητη γ στο υποπρογραμμα και θα κανουμε την αν ετσι
αν α>=β τοτε
     γ<-2*α-β
αλλιως
     γ<-2*α+β
τελος_αν
?????????????????????????????????????

kLee:
ΘΕΜΑ 2ο:
α.
ΠΡΟΓΡΑΜΜΑ Υπολογισμοί
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:α, β, γ, αποτ 
ΑΡΧΗ
  ΔΙΑΒΑΣΕ α, β
  ΚΑΛΕΣΕ Πράξη(α, β, αποτ)
  γ <-- α + αποτ
  ΓΡΑΨΕ γ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Πράξη (χ, ψ, ζ)
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: χ, ψ, ζ
ΑΡΧΗ
  ΑΝ χ>=ψ ΤΟΤΕ
    ζ <-- χ-ψ
  ΑΛΛΙΩΣ
    ζ <-- χ+ψ
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

β.
ΠΡΟΓΡΑΜΜΑ Υπολογισμοί
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ:α, β, γ, ζ
ΑΡΧΗ
  ΔΙΑΒΑΣΕ α, β
  ΑΝ α>=β ΤΟΤΕ
    ζ <-- α-β
  ΑΛΛΙΩΣ
    ζ <-- α+β
  ΤΕΛΟΣ_ΑΝ
  γ <-- α + ζ
  ΓΡΑΨΕ γ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Dem:
ευχαριστω για τις λυσεις αλλα θελω να μου πειτε αν ειναι σωστο αυτο που εκανα!!!!!!
η τελοσπαντων τι νομιζετε εσεις οτι ειναι............

Dem:
ΠΡΟΓΡΑΜΜΑ ΥΠΟΛΟΓΙΣΜΟΙ
ΜΕΤΑΒΛΗΤΕΣ
    ΠΡΑΓΜΑΤΙΚΕΣ:α,β,γ
ΑΡΧΗ
    ΔΙΑΒΑΣΕ α,β
    ΚΑΛΕΣΕ ΠΡΑΞΕΙΣ(α,β,γ)
    ΓΡΑΨΕ γ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ ΠΡΑΞΕΙΣ(α,β,γ)
ΜΕΤΑΒΛΗΤΕΣ
    ΠΡΑΓΜΑΤΙΚΕΣ:α,β,γ
ΑΡΧΗ
    ΑΝ α>=β τοτε
        γ<-2*α-β
    ΑΛΛΙΩΣ
        γ<-2*α+β
    ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ
??????

kLee:
"α. Να ξαναγράψετε το πρόγραμμα, ώστε να επιτελεί την ίδια λειτουργία χρησιμοποιώντας διαδικασία αντί συνάρτησης."

Δεν ορίζει ρητά να μετατρέψεις τη δεδομένη συνάρτηση σε ισοδύναμη διαδικασία και μετά να τη χρησιμοποιήσεις στο πρόγραμμα. Επιπλέον βγάζεις σωστά αποτελέσματα.

Εγώ θα το έπερνα σωστό, αλλά μάλλον εδώ θα πρέπει να τοποθετηθεί συνάδελφος που διορθώνει γραπτά...

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση