Γενικό Λύκειο > Εξετάσεις 2019-2020

Θέματα επαναληπτικών 2020

(1/2) > >>

peteglamgr:
Καλημέρα. Είδατε τα θέματα των επαναληπτικών;
https://www.minedu.gov.gr/publications/docs2020/EXETASEIS-2020-SEPTEMBRIOS/them_plhr_epan_NEO_200911.pdf
Το 4ο ήταν παρόμοιο (απλά με συνάρτηση) με αυτό των επαναληπτικών του 2018.
Το 3ο δεν ήταν άσχημο.

Λύσεις που έγραψα μόλις τώρα, αν δείτε λάθη πείτε, δεν τις έχω τσεκάρει από την αρχή.

--- Παράθεση ---
--- Κώδικας: ---ΠΡΟΓΡΑΜΜΑ Θ3_2020_ΕΠΑΝΑΛΗΠΤΙΚΕΣ
ΜΕΤΑΒΛΗΤΕΣ
   
ΑΡΧΗ

  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΔΙΑΒΑΣΕ ΤΙΜΗ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΤΙΜΗ>=0
  Ι<--0
  ΟΣΟ ΤΙΜΗ<>0 ΚΑΙ Ι<200 ΕΠΑΝΑΛΑΒΕ
    Ι<--Ι+1
    Τ[Ι]<--ΤΙΜΗ
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ ΤΙΜΗ
    ΜΕΧΡΙΣ_ΟΤΟΥ ΤΙΜΗ>=0
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  Κ<--Ι
  ΑΙΧΜΕΣ<--0
  ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ Κ-1
    ΑΝ ΤΙΜΗ[Ι]>ΤΙΜΗ[Ι-1] ΚΑΙ ΤΙΜΗ[Ι]>ΤΙΜΗ[Ι+1] ΤΟΤΕ
      ΑΙΜΕΣ<--ΑΙΧΜΕΣ+1
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ ΑΙΧΜΕΣ>0 ΤΟΤΕ
    ΓΡΑΨΕ ΑΙΧΜΕΣ
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ 'ΔΕ ΒΡΕΘΗΚΑΝ ΑΙΧΜΕΣ'
  ΤΕΛΟΣ_ΑΝ

  ΑΝ ΑΙΧΜΕΣ>=2 ΤΟΤΕ
    Π<--0
    ΓΙΑ Ι ΑΠΟ 2 ΜΕΧΡΙ Κ-1
      ΑΝ ΤΙΜΗ[Ι]>ΤΙΜΗ[Ι-1] ΚΑΙ ΤΙΜΗ[Ι]>ΤΙΜΗ[Ι+1] ΤΟΤΕ
        Π<--Π+1
        ΑΝ Π=1 Η Π=ΑΙΧΜΕΣ ΤΟΤΕ
          ΓΡΑΨΕ Ι
        ΤΕΛΟΣ_ΑΝ
       ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_4_2020_ΕΠΑΝΑΛΗΠΤΙΚΕΣ
ΜΕΤΑΒΛΗΤΕΣ


ΑΡΧΗ

  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΔΙΑΒΑΣΕ ΟΝ[Ι]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΓΙΑ Ξ ΑΠΟ Ι+1 ΜΕΧΡΙ 20
      ΔΙΑΒΑΣΕ ΑΠ[Ι,Ξ]
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

  ΔΙΑΒΑΣΕ ΠΟΛΗ1
  Σ<--0
  Π<--0
  ΟΣΟ ΠΟΛΗ1<>'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ
    ΔΙΑΒΑΣΕ ΠΟΛΗ2
    ΑΠ<--ΑΠΟΣΤΑΣΗ(ΠΟΛΗ1,ΠΟΛΗ2,ΑΠ,ΟΝ)   
    ΑΝ ΑΠ<>0 ΤΟΤΕ
      ΑΝ ΑΠ<=100 ΤΟΤΕ
        ΧΡΕΩΣΗ<--ΑΠ*0.5
      ΑΛΛΙΩΣ
        ΧΡΕΩΣΗ<--100*0.5+(ΑΠ-100)*0.3
      ΤΕΛΟΣ_ΑΝ
      Σ<--Σ+ΧΡΕΩΣΗ
      Π<--Π+1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΔΕ ΒΡΕΘΗΚΕ ΚΑΠΟΙΑ ΠΟΛΗ'
    ΤΕΛΟΣ_ΑΝ
    ΔΙΑΒΑΣΕ ΠΟΛΗ1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ Σ,Π

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ             

ΣΥΝΑΡΤΗΣΗ ΑΠΟΣΤΑΣΗ(ΟΝ1,ΟΝ2,ΑΠ,ΟΝ):ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΧΑΡΑΚΤΗΡΕΣ:ΟΝ1,ΟΝ2,ΟΝ
  ΠΡΑΓΜΑΤΙΚΕΣ:ΑΠ[20,20]
  ΑΚΕΡΑΙΕΣ:Θ1,Θ2,Ι
ΑΡΧΗ
  Θ1<--0
  Θ2<--0
  ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 20
    ΑΝ ΟΝ[Ι]=ΟΝ1 ΤΟΤΕ
      Θ1<--Ι
    ΑΛΛΙΩΣ_ΑΝ ΟΝ[Ι]=ΟΝ2 ΤΟΤΕ
      Θ2<--Ι
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΑΝ Θ1=0 Η Θ2=0 ΤΟΤΕ
    ΓΡΑΨΕ 'ΚΑΠΟΙΑ ΠΟΛΗ ΔΕ ΒΡΕΘΗΚΕ'
    ΑΠΟΣΤΑΣΗ<--0
  ΑΛΛΙΩΣ
    ΑΝ Θ1>Θ2 ΤΟΤΕ
      ΑΠΟΣΤΑΣΗ<--ΑΠ[Θ1,Θ2]
    ΑΛΛΙΩΣ
      ΑΠΟΣΤΑΣΗ<--ΑΠ[Θ2,Θ1]
    ΤΕΛΟΣ_ΑΝ
  ΤΕΛΟΣ_ΑΝ

ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
--- Τέλος κώδικα ---

--- Τέλος παράθεσης ---

Λαμπράκης Μανώλης:
Έχει ενδιαφέρον και το 2ρο ΣΛ, το είχαμε συζητήσει και εδώ, αλλά δεν ξέρω αν είχαμε καταλήξει κάπου..

evry:
Συνήθως τα θέματα των επαναληπτικών έχουν κάποια πρωτοτυπία, κάποιες νέες ιδέες. Αυτά δεν έχουν τίποτα.
Μάλιστα το απίστευτο που δεν νομίζω να έχει ξαναγίνει είναι ότι πήγαν και πήραν copy/paste το θέμα Β του 2010 και το έβαλαν αυτούσιο!

Λαμπράκης Μανώλης:
ΑΚΡΙΒΩΣ το ίδιο είναι Ευριπίδη ? έλεος...το είδα πως ήταν copy paste η εκφώνηση, αλλά θεώρησα πως άλλαξαν τα νούμερα ... μάλιστα ...

evry:
Οκ το παίρνω πίσω δεν είναι αυτούσιο.
Στο φετινό θέμα έχουν ανάποδα τις πρώτες δυο εκχωρήσεις (για ξεκάρφωμα?) :D
και προσπάθησαν να κάνουν με bold τις δεσμευμένες λέξεις αλλά επειδή κάτι δεν πήγε καλά έγιναν όλα με bold. :D
Α και το σημαντικότερο απ'όλα που δείχνει και την εξέλιξη του μαθήματος τα τελευταία χρόνια. Αντί για Εμφάνισε έβαλαν Γράψε.

Τα νούμερα δεν μπορεί να είναι οποιαδήποτε γιατί ο κώδικας αυτός παράγει τους αριθμούς Fibonacci.

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση