Γενικό Λύκειο > Εξετάσεις 2019-2020

Θέμα Γ

(1/3) > >>

evry:
Εδώ συζητάμε για το θέμα Γ των εξετάσεων 2019-2020

evry:
Από τα πιο εύκολα θέματα Γ που έχουν βάλει τα τελευταία 12 χρόνια.
Ωστόσο θέλει προσοχή η εκφώνηση.

mikezante:

--- Κώδικας: ---ΠΡΟΓΡΑΜΜΑ ΘΕΜΑ_Γ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: πλ, πλβ
  ΠΡΑΓΜΑΤΙΚΕΣ: οριο, βαρος, ωφελιμο, δεμα, χρ, Σ
  ΧΑΡΑΚΤΗΡΕΣ: απαντηση
ΑΡΧΗ
  πλ <- 0
  Σ <- 0
  πλβ <- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                                                                             !Γ2
    ΔΙΑΒΑΣΕ οριο, βαρος
    ΟΣΟ βαρος > οριο ΕΠΑΝΑΛΑΒΕ
      ΓΡΑΨΕ 'Δώσε πάλι το βάρος εντός ορίων:'
      ΔΙΑΒΑΣΕ βαρος
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
                                                                           !Γ3.α
    ωφελιμο <- οριο - βαρος
    ΓΡΑΨΕ 'Επιτρεπτό βάρος:', ωφελιμο
    ΓΡΑΨΕ 'Να φορτωθεί δέμα;(ΝΑΙ/ΟΧΙ)'
    ΔΙΑΒΑΣΕ απαντηση
                                                                           !Γ3.β
    ΑΝ απαντηση = 'ΝΑΙ' ΤΟΤΕ
      ΔΙΑΒΑΣΕ δεμα
      ΑΝ δεμα > ωφελιμο ΤΟΤΕ
        ΓΡΑΨΕ ' Το δέμα δεν χωράει'
        πλ <- πλ + 1
      ΑΛΛΙΩΣ
        ωφελιμο <- ωφελιμο - δεμα
        ΑΝ δεμα <= 500 ΤΟΤΕ
          χρ <- δεμα*0.5
        ΑΛΛΙΩΣ_ΑΝ δεμα <= 1500 ΤΟΤΕ
          χρ <- 500*0.5 + (δεμα - 500)*0.3
        ΑΛΛΙΩΣ
          χρ <- 500*0.5 + 1000*0.3 + (δεμα - 1500)*0.1
        ΤΕΛΟΣ_ΑΝ
        ΓΡΑΨΕ 'Χρέωση δέματος:', χρ
        ΑΝ δεμα > 1000 ΤΟΤΕ
          πλβ <- πλβ + 1
        ΤΕΛΟΣ_ΑΝ
        Σ <- Σ + χρ
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ απαντηση = 'ΟΧΙ'
!Γ4
  ΓΡΑΨΕ 'Πληθος δεμάτων που δεν φορτώθηκαν:', πλ
  ΓΡΑΨΕ 'Συνλικο ποσό:', Σ
  ΓΡΑΨΕ 'Πληθος δεμάτων ανω 1000kg:', πλβ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
--- Τέλος κώδικα ---

Λαμπράκης Μανώλης:
το ΟΣΟ δεν πρέπει να βγει εγω απο το Μέχρις_ότου ?? μία φορά δεν διαβάζουμε το αρχικό βάρος ??

andreas_p:
Γ2
Μια φορά ...
  Και το αρχικό βάρος ( ΑΒ )
  Και το όριο   (όριο)

Οπότε μέσα στη Μέχρις_ότου
    βάρος  που μπορεί ακόμα να φορτωθεί στο πλοίο ... ( Β)

     Β <-  όριο - ΑΒ

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση