Γενικό Λύκειο > Εξετάσεις 2014-2015

Θέμα Γ

<< < (2/13) > >>

Loco-3:
οι ΧΑ ΧΒ και ΜΕΓ δεν μπορούν να θεωρηθούν και πραγματικές ;

alpapanto:

--- Παράθεση από: Loco-3 στις 27 Μαΐ 2015, 01:04:08 μμ ---οι ΧΑ ΧΒ και ΜΕΓ δεν μπορούν να θεωρηθούν και πραγματικές ;

--- Τέλος παράθεσης ---
ναι, γιατί να μην μπορούν;

marvic:
Αν η διαδικασία γίνει με συνάρτηση αλλά τα εμφάνισε τα κάνει στο κυρίως πρόγραμμα θα χάσει πολλές μονάδες;

petrosp13:
Το θέμα μοιάζει εκ πρώτης όψεως εύκολο, αλλά παρατηρείται ότι αρκετά παιδιά έχουν κάνει λάθη στις συνθήκες, κυρίως στο πώς αποκλείει η μια περίπτωση την άλλη
Ωστόσο, 4 μονάδες για δήλωση μεταβλητών και μια εντολή Διάβασε;;;

theoL:
ΠΡΟΓΡΑΜΜΑ  ΘΕΜΑ_Γ
! Γ1α---------------------------------------------------------
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: Α,Β,ΜΕΓΕΘΟΣ_ΔΕΜΑΤΟΣ,ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α,ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Β,ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_ΕΚΤΟΣ
!β------------------------------------------------------------
ΑΡΧΗ
  ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α <-- 0
  ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Β <-- 0
  ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_ΕΚΤΟΣ <-- 0
  ΓΡΑΨΕ 'ΜΕΓΕΘΟΣ ΕΛΕΥΘΕΡΟΥ ΧΩΡΟΥ ΑΠΟΘΗΚΗΣ Α'
  ΔΙΑΒΑΣΕ Α
  ΓΡΑΨΕ 'ΜΕΓΕΘΟΣ ΕΛΕΥΘΕΡΟΥ ΧΩΡΟΥ ΑΠΟΘΗΚΗΣ Β'
  ΔΙΑΒΑΣΕ Β
!γ------------------------------------------------------------
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
    ΓΡΑΨΕ 'ΜΕΓΕΘΟΣ ΔΕΜΑΤΟΣ'
    ΔΙΑΒΑΣΕ ΜΕΓΕΘΟΣ_ΔΕΜΑΤΟΣ
    ΑΝ Α=Β ΤΟΤΕ
      ΓΡΑΨΕ 'ΘΑ ΤΟΠΟΘΕΤΗΘΕΙ ΣΤΗΝ Α'
      ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α <-- ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α+1
    ΑΛΛΙΩΣ
      ΑΝ ΜΕΓΕΘΟΣ_ΔΕΜΑΤΟΣ<Α ΤΟΤΕ
        ΓΡΑΨΕ 'ΘΑ ΤΟΠΟΘΕΤΗΘΕΙ ΣΤΗΝ Α'
        ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α <-- ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α+1
      ΑΛΛΙΩΣ_ΑΝ ΜΕΓΕΘΟΣ_ΔΕΜΑΤΟΣ<Β ΤΟΤΕ
        ΓΡΑΨΕ 'ΘΑ ΤΟΠΟΘΕΤΗΘΕΙ ΣΤΗΝ Β'
        ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Β <-- ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Β+1
      ΑΛΛΙΩΣ_ΑΝ ΜΕΓΕΘΟΣ_ΔΕΜΑΤΟΣ>Α ΚΑΙ ΜΕΓΕΘΟΣ_ΔΕΜΑΤΟΣ>Β ΤΟΤΕ
        ΓΡΑΨΕ 'Προοώθηση'
        ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_ΕΚΤΟΣ <-- ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_ΕΚΤΟΣ+1
      ΤΕΛΟΣ_ΑΝ
    ΤΕΛΟΣ_ΑΝ
  ΜΕΧΡΙΣ_ΟΤΟΥ ΜΕΓΕΘΟΣ_ΔΕΜΑΤΟΣ = 0
!δ--------------------------------------------------------------
  ΚΑΛΕΣΕ ΑΠΟΘΗΚΕΣ (ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Α,ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_Β,ΑΡΙΘΜΟΣ_ΔΕΜΑΤΩΝ_ΕΚΤΟΣ)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ ΘΕΜΑ_Γ

!Γ2---------------------------------------------------------------
ΔΙΑΔΙΚΑΣΙΑ  ΑΠΟΘΗΚΕΣ (ΑΔΑ,ΑΔΒ,ΑΔΕ)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ:ΑΔΑ,ΑΔΒ,ΑΔΕ
ΑΡΧΗ
  ΑΝ ΑΔΑ=ΑΔΒ ΚΑΙ ΑΔΑ <> 0 ΚΑΙ ΑΔΒ <> 0 ΤΟΤΕ
    ΓΡΑΨΕ 'Ισάριθμα'
  ΑΛΛΙΩΣ_ΑΝ ΑΔΑ>ΑΔΒ ΤΟΤΕ
    ΓΡΑΨΕ 'ΑΠΟΘΗΚΗ Α'
  ΑΛΛΙΩΣ_ΑΝ ΑΔΒ>ΑΔΑ ΤΟΤΕ
    ΓΡΑΨΕ 'ΑΠΟΘΗΚΗ Β'
  ΑΛΛΙΩΣ_ΑΝ ΑΔΑ=0 ΚΑΙ ΑΔΒ=0 ΤΟΤΕ
    ΓΡΑΨΕ 'Καμία αποθήκευση στο αεροδρόμιο'
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

[*] Προηγούμενη σελίδα

Μετάβαση στην πλήρη έκδοση