Γενικό Λύκειο > Εξετάσεις 2014-2015

Θέμα Γ

(1/13) > >>

gpapargi:
Εδώ σχολιάζουμε το θέμα Γ

progmat:
Μια γρήγορη λύση στο Γ ...

--- Κώδικας: ---ΠΡΟΓΡΑΜΜΑ ΘΕΜΑΓ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΧΑ, ΧΒ, ΜΕΓ, ΠΛΑ, ΠΛΒ

ΑΡΧΗ
  ΠΛΑ <- 0
  ΠΛΒ <- 0
  ΔΙΑΒΑΣΕ ΧΑ, ΧΒ
  ΔΙΑΒΑΣΕ ΜΕΓ
  ΟΣΟ ΜΕΓ <> 0 ΕΠΑΝΑΛΑΒΕ
    ΑΝ ΧΑ >= ΧΒ ΚΑΙ ΜΕΓ <= ΧΑ ΤΟΤΕ
      ΓΡΑΨΕ 'ΑΠΟΘΗΚΗ Α'
      ΧΑ <- ΧΑ - ΜΕΓ
      ΠΛΑ <- ΠΛΑ + 1
    ΑΛΛΙΩΣ_ΑΝ ΧΒ > ΧΑ ΚΑΙ ΜΕΓ <= ΧΒ ΤΟΤΕ
      ΓΡΑΨΕ 'ΑΠΟΘΗΚΗ Β'
      ΧΒ <- ΧΒ - ΜΕΓ
      ΠΛΒ <- ΠΛΒ + 1
    ΑΛΛΙΩΣ
      ΓΡΑΨΕ 'ΠΡΟΩΘΗΣΗ'
    ΤΕΛΟΣ_ΑΝ
    ΔΙΑΒΑΣΕ ΜΕΓ
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΚΑΛΕΣΕ Δ(ΠΛΑ, ΠΛΒ)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΔΙΑΔΙΚΑΣΙΑ Δ(ΠΛ1, ΠΛ2)
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΠΛ1, ΠΛ2
ΑΡΧΗ
 ΑΝ ΠΛ1 = 0 ΚΑΙ ΠΛ2 = 0 ΤΟΤΕ
  ΓΡΑΨΕ "ΚΑΜΙΑ ΑΠΟΘΗΚΕΥΣΗ"
  ΑΛΛΙΩΣ_ΑΝ ΠΛ1 > ΠΛ2 ΤΟΤΕ
    ΓΡΑΨΕ 'Α'
  ΑΛΛΙΩΣ_ΑΝ ΠΛ1 < ΠΛ2 ΤΟΤΕ
    ΓΡΑΨΕ 'Β'
  ΑΛΛΙΩΣ
    ΓΡΑΨΕ "ΙΣΑΡΙΘΜΑ"
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

--- Τέλος κώδικα ---

nightchild:
Σου ξέφυγε μια περίπτωση στην διαδικασία
Αν ΠΛ1=0 ΚΑΙ ΠΛ2=0 ΤΟΤΕ
        ΓΡΑΨΕ 'Καμία αποθήκευση στο αεροδρόμιο'

progmat:
Ευχαριστώ για την επισήμανση το διόρθωσα...

soc_h:
Πιστεύω πως το
"Η διαδικασία παραλαβής τερματίζεται"
να μην υπονοεί πως πρέπει να λυθεί με διαδικασία. Δηλαδή για μένα δεν χρειάζεται υποπρόγραμμα.

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση