Γενικό Λύκειο > Εξετάσεις 2013-2014

Επαναληπτικές Εξετάσεις 2014

(1/8) > >>

stark:
Τα θέματα:http://www.minedu.gov.gr/publications/docs2014/them_plir_kat_c_hmer_epan_140624.pdf

Με μια πρώτη ανάγνωση,ως μαθητής,τα κρίνω εμφανώς πιο απαιτητικά από αυτά των κανονικών εξετάσεων.Εκ του ασφαλούς,θα τα σχολιάσω αύριο,αφού πρώτα τα επεξεργαστώ.Πάντως αίσθηση μου έκανε το ζήτημα Α2.β.Εκτιμώ ότι θα «ξάφνιασε» τους πανελληνιομάχους που εξετάζονταν σήμερα στο συγκεκριμένο μάθημα.

petrosp13:
Έλεος, τι πήγαν και έβαλαν...

amanou:
Ας δούμε τις  λύσεις :

Θέμα Α

Α1. 1.Λ
      2.Λ (επειδή στις στατικές δομές δεν μπορούμε να κάνουμε  διαγραφή)
      3.Λ
      4.Σ
      5.Σ

Α2.α  θεωρία ορισμός σελ 8

Α2.β  όπως το παράδειγμα στην σελίδα 11 του σχολικού ( Απορώ για την επιλογή του συγκεκριμένου θέματος .
        Προσωπικά την θεωρώ άστοχη)

Α3.    Για  j από 1 μέχρι 6
                temp <-  A[2,j]
                A[2,j] <- A[5,j]                Δεν μπορεί να χρησιμοποιηθεί η εντολή Αντιμετάθεσε γιατί χρησιμοποιούμε ΓΛΩΣΣΑ
                A[5,j] <-  temp
         τέλος_επανάληψης



 
 

amanou:
Α4. Χρησιμοποιούμε στοίβα γιατί κατά την διαδοχική κλήση υποπρογραμμάτων (πχ αναδρομή) όταν ολοκληρωθεί το τρέχον υποπρόγραμμα θέλουμε να επιστρέφουμε στο τελευταίο που καλέσαμε και όχι στο πρώτο (αυτό θα συνεβαινε αν είχαμε χρησιμοποιήσει ουρά)

Α5. α   Ορισμός σελ 187 σχολικού

Α5. β    Αλγόριθμος Συνένωση
           Δεδομένα // Α,Ν,Β,Μ//
           Για i  από 1 μέχρι Ν
              Γ[ i ] <- Α [ i ]
           τέλος_επανάληψης
           Για i  από Ν+1 μέχρι Ν+Μ
              Γ[ i ] <- Β[ i - Ν ]                               
           τέλος_επανάληψης   
           Τέλος Συνένωση 
 
         Η δεύτερη επανάληψη μπορεί να γραφεί ισοδύναμα και ως εξής:

           Για i  από 1 μέχρι Μ
              Γ[ i + Ν ] <- Β[ i ]                               
           τέλος_επανάληψης   

Νίκος Αδαμόπουλος:

--- Παράθεση από: amanou στις 24 Ιουν 2014, 08:00:29 μμ ---Α5. β    Αλγόριθμος Συνένωση
           Δεδομένα // Α,Ν,Β,Μ//
           Για i  από 1 μέχρι Ν
              Γ[ i ] <- Α [ i ]
           τέλος_επανάληψης
           Για i  από Ν+1 μέχρι Ν+Μ
              Γ[ i ] <- Β[ i - Ν ]                               
           τέλος_επανάληψης   
           Τέλος Συνένωση 
 
         Η δεύτερη επανάληψη μπορεί να γραφεί ισοδύναμα και ως εξής:

           Για i  από 1 μέχρι Μ
              Γ[ i + Ν ] <- Β[ i ]                               
           τέλος_επανάληψης   

--- Τέλος παράθεσης ---

"Συνένωση πινάκων" (2011):
https://alkisg.mysch.gr/steki/index.php?topic=3761

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση