Γενικό Λύκειο > Εξετάσεις 2013-2014

Θέμα Δ

(1/11) > >>

gpapargi:
Εδώ σχολιάζουμε το θέμα Δ

eara:
Δ4. Ταπεινή μου άποψη: χρειάζεται διευκρίνηση προς βαθμολογητές για την κατανομή των 9 μονάδων, προς αποφυγή παρεξηγήσεων.

amanou:
Αλγόριθμος ΘέμαΔ
!Δ1
 Για ι από 1 μέχρι 10
    Διάβασε Ον[ι]
    Για j από 1 μέχρι 28
      Διάβασε Ε[i,j]
    τέλος_επανάληψης
τέλος_επανάληψης

!Δ2
Για ι από 1 μέχρι 10
    Σ<-0
    Για j από 1 μέχρι 28
      Σ<-Σ+ Ε[i,j]
    τέλος_επανάληψης
    εμφάνισε Ον[ι],Σ
τέλος_επανάληψης

!Δ3
δ<-ψευδής
 Για ι από 1 μέχρι 10
    Π<-0
    Για j από 1 μέχρι 28
      Αν Ε[ι,j] <=500 τότε Π<-Π+1
    τέλος_επανάληψης
    Αν Π=0 τότε
       εμφάνισε Ον[ι]
       δ<-αληθής
    τέλος_αν
τέλος_επανάληψης
Αν δ=ψευδής τότε εμφάνισε "δεν υπάρχει τέτοιος ιστότοπος"

amanou:
!Δ4
Αρχή_επανάληψης
  Διάβασε ονομα
  δ <- ψευδής
  ι<- 1
  Όσο ι<=10 και  δ = ψευδής επανάλαβε
     Αν Ον[ι]=ονομα τότε
       δ<-αληθής
       ρ<- ι
      αλλιώς
       ι<- ι+1
      τέλος_αν
   τέλος_επανάληψης

Μέχρις_ότου δ= αληθής

Για ι από 1 μέχρι 4
  Κ <-(ι-1)*7
  Σ < - 0
  Για j από Κ+1 μέχρι Κ+7
    Σ <-  Σ + Ε[ρ,j]
  τέλος_επανάληψης
  Εβδ[ι] <- Σ
τέλος_επανάληψης

max <-Εβδ[1]
Για ι από 2 μέχρι 4
 Αν max <Εβδ[ι] τοτε
   max <-Εβδ[ι]
  τέλος_αν
τέλος_επαναληψης

Για ι από 1 μέχρι 4
 Αν max =Εβδ[ι] τοτε
   εμφάνισε ι 
τέλος_επαναληψης

Τέλος ΘεμαΔ

apanagio:
Εγώ θα πρότεινα τρισδιαστατο πίνακα:

Αλγόριθμος ΘέμαΔ
!Δ1
 Για ι από 1 μέχρι 10
    Διάβασε Ον[ι]
    Για j από 1 μέχρι 4
        Για κ από 1 μέχρι 7
            Διάβασε Ε[i, j, κ]
      τέλος_επανάληψης
   τέλος_επανάληψης
τέλος_επανάληψης

!Δ2
Για ι από 1 μέχρι 10
    Σ<-0
    Για j από 1 μέχρι 4
        Για κ από 1 μέχρι 7
          Σ<-Σ+ Ε[i, j, κ]
      τέλος_επανάληψης
   τέλος_επανάληψης
    εμφάνισε Ον[ι],Σ
τέλος_επανάληψης

!Δ3
δ<- ψευδης
 Για ι από 1 μέχρι 10
    Για j από 1 μέχρι 4
        Για κ από 1 μέχρι 7
          Αν Ε[ι, j, κ] <=500 τότε Π<-Π+1
    τέλος_επανάληψης
    τέλος_επανάληψης
    Αν Π=0 τότε
       εμφάνισε Ον[ι]
       δ<-αληθής
    τέλος_αν
τέλος_επανάληψης
Αν δ=ψευδής τότε εμφάνισε "δεν υπάρχει τέτοιος ιστότοπος"

!Δ4
Αρχή_επανάληψης
  Διάβασε ονομα
  δ <- ψευδής
  ι<- 1
  Όσο ι<=10 και  δ = ψευδής επανάλαβε
     Αν Ον[ι]=ονομα τότε
       δ<-αληθής
       ρ<- ι
      αλλιώς
       ι<- ι+1
      τέλος_αν
   τέλος_επανάληψης

Μέχρις_ότου δ= αληθής

Για ι από 1 μέχρι 4
  Για j από 1 μέχρι 7
    Σ <-  Σ + Ε[ρ, i, j]
  τέλος_επανάληψης
  Εβδ[ρ] <- Σ
τέλος_επανάληψης

max <-Εβδ[1]
Για ι από 2 μέχρι 4
 Αν max <Εβδ[ι] τοτε
   max <-Εβδ[ι]
  τέλος_αν
τέλος_επαναληψης

Για ι από 1 μέχρι 4
 Αν max =Εβδ[ι] τοτε
   εμφάνισε ι
τέλος_επαναληψης

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση