Γενικό Λύκειο > Εξετάσεις 2004-2005

Επαναληπτικές 2005

(1/3) > >>

αντώνης:
Δεν ξέρω αν είδατε τα θέματα των επαναληπτικών εξετάσεων. Υπάρχουν στο site του Υπουργείου http://www.ypepth.gr/docs/them_plir_kat_c_hmer_epan_0605.pdf .

Αυτά και αν είναι απαιτιτικά θέματα. Πιστεύω ότι μπαίνουμε σε νέα εποχή θεμάτων από του χρόνου αφού πηγαίνουμε στις παλιές δέσμες.

Περιμένω τον δικό σας σχολιασμό.

Φιλικά

Μανουσάκης Αντώνης

Ηλεκτρονικός Μηχανικός &
Μηχανικός Υπολογιστών

Αντώνης:
Απαντήσεις Θεμάτων

Θέμα 1ο
Α
1. Λ
2. Σ
3. Σ
4. Σ
5. Σ

Β.  
     1  β
     2  δ
     3  α
     4  β
5  γ

Γ. 1

     Πρόταση Α : ΨΕΥΔΗΣ
     Πρόταση Β : ΑΛΗΘΗΣ
     Πρόταση Γ :  ΨΕΥΔΗΣ
     Πρόταση Δ : ΑΛΗΘΗΣ
Γ.2

     Α ή Β    : ΑΛΗΘΗΣ
     Α ή Γ    : ΨΕΥΔΗΣ
Γ και Δ : ΨΕΥΔΗΣ
Α και Δ:  ΨΕΥΔΗΣ
Όχι Α   : ΑΛΗΘΗΣ
Όχι Β   :  ΨΕΥΔΗΣ

Δ.
           Για Ι από 2 μέχρι 10 με_βήμα 2
           Διάβασε Α
           Εμφάνισε Α
     Τέλος_επανάληψης

Ε.       Σχολικό βιβλίο σελ:  65

ΣΤ.       Σχολικό βιβλίο σελ: 208

Αντώνης:
Α)
ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: Θ, Μέση, Σύνολο
ΑΚΕΡΑΙΕΣ: i
ΑΡΧΗ
Σύνολο 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
   ΓΡΑΨΕ “∆ώσε τη θερμοκρασία”
   ∆ΙΑΒΑΣΕ  Θ
   Σύνολο  Σύνολο + Θ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Μέση   Σύνολο/30
ΓΡΑΨΕ “Μέση Θερμοκρασία:”, Μέση
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Β)   ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: Θ, Φ,  Μέση, Σύνολο
ΑΚΕΡΑΙΕΣ: i
ΑΡΧΗ
Σύνολο  0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
   ΓΡΑΨΕ “∆ώσε τη θερμοκρασία”
   ∆ΙΑΒΑΣΕ  Θ
  Φ  ΜΕΤΑΤΡΟΠΗ ( Θ )    
   Σύνολο  Σύνολο + Θ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Μέση   Σύνολο/30
ΓΡΑΨΕ “Μέση Θερμοκρασία:”, Μέση
       ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

      ΣΥΝΑΡΤΗΣΗ ΜΕΤΑΤΡΟΠΗ ( Θ ) : ΠΡΑΓΜΑΤΙΚΗ  
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: Θ

     ΑΡΧΗ
     
     ΜΕΤΑΤΡΟΠΗ  32 + (9*Θ)/5
   
     ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Σχόλιο : Πολύ πρωτότυπο αλλά και αρκετά απαιτητικό ειδικά για δεύτερο θέμα. Να ετοιμάζεστε για του χρόνου!!

amanou:
Α)
ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: Θ, Μέση, Σύνολο
ΑΚΕΡΑΙΕΣ: i
ΑΡΧΗ
Σύνολο <- 0
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
   ΓΡΑΨΕ "Δώσε τη θερμοκρασία"
   ΔΙΑΒΑΣΕ  Θ
   Σύνολο <- Σύνολο + Θ
    ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Μέση  <- Σύνολο/30
ΓΡΑΨΕ "Μέση Θερμοκρασία:", Μέση
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Β)  
ΠΡΟΓΡΑΜΜΑ Θερμοκρασίες
ΜΕΤΑΒΛΗΤΕΣ
ΠΡΑΓΜΑΤΙΚΕΣ: Θ, Φ,  Μέση, Σύνολο
ΑΚΕΡΑΙΕΣ: i
ΑΡΧΗ
 Σύνολο <- 0
 ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 30
    ΓΡΑΨΕ "Δώσε τη θερμοκρασία"
    ΔΙΑΒΑΣΕ  Θ
    Φ <- ΜΕΤΑΤΡΟΠΗ ( Θ )    
    Σύνολο <- Σύνολο + Φ
 ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
 Μέση  <- Σύνολο/30
 ΓΡΑΨΕ "Μέση Θερμοκρασία", Μέση
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

ΣΥΝΑΡΤΗΣΗ ΜΕΤΑΤΡΟΠΗ ( Θ ) : ΠΡΑΓΜΑΤΙΚΗ  
ΜΕΤΑΒΛΗΤΕΣ
  ΠΡΑΓΜΑΤΙΚΕΣ: Θ
  ΑΡΧΗ

       ΜΕΤΑΤΡΟΠΗ <- 32 + (9*Θ)/5
 
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


Σχόλιο : Πολύ πρωτότυπο αλλά και αρκετά απαιτητικό ειδικά για δεύτερο θέμα. Να ετοιμάζεστε για του χρόνου!!

amanou:
ΠΡΟΓΡΑΜΜΑ ΑΣΕΠ
ΜΕΤΑΒΛΗΤΕΣ
 ΧΑΡΑΚΤΗΡΕΣ: Ο[100]
 ΠΡΑΓΜΑΤΙΚΕΣ: Β[100,3], Max, Min, Μέσος
 ΑΚΕΡΑΙΕΣ: i , j
  ΑΡΧΗ
  ! ερ'ωτημα α
   ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
         ΔΙΑΒΑΣΕ  O
         ΓΙΑ j ΑΠΟ 1 ΜΕΧΡΙ 3
         ΔΙΑΒΑΣΕ  B[i,j]
        ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
   ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ερώτημα β

ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
  Max <- B[i,1]
  Min <-  B[i,1]
   ΓΙΑ j ΑΠΟ 2 ΜΕΧΡΙ 3
       AN B[i,j] > Max TOTE
          Max <- B[i, 1]
       ΑΛΛΙΩΣ_ΑΝ   B[i,j] < Min TOTE
           Min <-  B[i,1]      
       ΤΕΛΟΣ_ΑΝ
     ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
     ΓΡΑΨΕ   Max, Min
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

! ερώτημα γ
ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
   Μέσος  <-  Μέσος_Όρος( Β[i,1], Β[i,2], Β[i,3])
   ΓΡΑΨΕ " Ο Μέσος Όρος του μαθητή ", Ο, "είναι : ", Μέσος
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΣΥΝΑΡΤΗΣΗ Μέσος_Όρος ( Α,Β,Γ ) : ΠΡΑΓΜΑΤΙΚΗ  
ΜΕΤΑΒΛΗΤΕΣ  
 ΠΡΑΓΜΑΤΙΚΕΣ: Α, Β, Γ

     ΑΡΧΗ      
     Μέσος_Όρος <- (Α + Β + Γ)/3
   
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

Σχόλιο : Επιτέλους ζητήθηκε και άσκηση κατασκευής αλλά και κλήσης υποπρογράμματος, κάτι που αναμέναμε πολύ καιρό. Αλλά μου φαίνεται ότι το τώρα το παράκαναν ( θέμα 2 - θέμα 3).

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση