Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Τμηματικός προγραμματισμός => Γ΄ Λυκείου => Συναρτήσεις => Μήνυμα ξεκίνησε από: Stop GOTO στις 04 Νοε 2012, 01:16:36 μμ

Τίτλος: ΠΡΟΒΛΗΜΑ
Αποστολή από: Stop GOTO στις 04 Νοε 2012, 01:16:36 μμ
Μπορείτε να μου πείτε το λάθος που έχω κάνει εδώ;

ΠΡΟΓΡΑΜΜΑ ασκηση
ΑΡΧΗ
 ΣΥΝΑΡΤΗΣΗ πρόσθεση(α, β, γ):ΑΚΕΡΑΙΑ
 ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
 ΑΡΧΗ
    πρόσθεση <- α + β + γ
 ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ

 ΔΙΑΔΙΚΑΣΙΑ εκτύπωση( α, β, γ)
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
  ΑΡΧΗ
     ΓΡΑΨΕ 'Το άθροισμα των α, β, και γ είναι ' , πρόσθεση( α, β, γ)
  ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

ΑΡΧΗ
  ΚΑΛΕΣΕ εκτύπωση(2, 3, 4)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ
Τίτλος: Απ: ΠΡΟΒΛΗΜΑ
Αποστολή από: P.Tsiotakis στις 04 Νοε 2012, 01:44:34 μμ
πιο σωστό φαντάζει το:

ΠΡΟΓΡΑΜΜΑ ασκηση
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
ΑΡΧΗ
  α <- 2
  β <- 3
  γ <- 4
  ΚΑΛΕΣΕ εκτύπωση(α, β, γ)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 ΔΙΑΔΙΚΑΣΙΑ εκτύπωση( α, β, γ)
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
  ΑΡΧΗ
     ΓΡΑΨΕ 'Το άθροισμα των α, β, και γ είναι ' , πρόσθεση( α, β, γ)
  ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

 ΣΥΝΑΡΤΗΣΗ πρόσθεση(α, β, γ):ΑΚΕΡΑΙΑ
 ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
 ΑΡΧΗ
    πρόσθεση <- α + β + γ
 ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
Τίτλος: Απ: ΠΡΟΒΛΗΜΑ
Αποστολή από: Stop GOTO στις 04 Νοε 2012, 07:55:35 μμ
πιο σωστό φαντάζει το:

ΠΡΟΓΡΑΜΜΑ ασκηση
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
ΑΡΧΗ
  α <- 2
  β <- 3
  γ <- 4
  ΚΑΛΕΣΕ εκτύπωση(α, β, γ)
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


 ΔΙΑΔΙΚΑΣΙΑ εκτύπωση( α, β, γ)
    ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
  ΑΡΧΗ
     ΓΡΑΨΕ 'Το άθροισμα των α, β, και γ είναι ' , πρόσθεση( α, β, γ)
  ΤΕΛΟΣ_ΔΙΑΔΙΚΑΣΙΑΣ

 ΣΥΝΑΡΤΗΣΗ πρόσθεση(α, β, γ):ΑΚΕΡΑΙΑ
 ΜΕΤΑΒΛΗΤΕΣ
    ΑΚΕΡΑΙΕΣ:  α, β, γ
 ΑΡΧΗ
    πρόσθεση <- α + β + γ
 ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
Ναι, συμφωνω αλλα επειδή έχω δει αυτή τη λύση σε ένα tutorial και μόλις την περασα στο Διερμηνευτη τα εβγαζε λαθος... τελος παντων. Ευχαριστω πολύ
Τίτλος: Απ: ΠΡΟΒΛΗΜΑ
Αποστολή από: P.Tsiotakis στις 05 Νοε 2012, 09:11:46 πμ
tutorial σχετικού με ΑΕΠΠ?
στη ΓΛΩΣΣΑ δεν τοποθετούνται τα υποπρογράμματα στο τμήμα δηλώσεων του προγράμματος, άρα εκ προοιμίου δεν κολλάει!!
Τίτλος: Απ: ΠΡΟΒΛΗΜΑ
Αποστολή από: Stop GOTO στις 05 Νοε 2012, 12:01:25 μμ
σχετικό με Pascal... γι'αυτο το εχω λαθος μαλλον ε;
Τίτλος: Απ: ΠΡΟΒΛΗΜΑ
Αποστολή από: petrosp13 στις 05 Νοε 2012, 12:36:57 μμ
Σε Pascal θέλεις να το υλοποιήσεις ή σε ΓΛΩΣΣΑ;
Τίτλος: Απ: ΠΡΟΒΛΗΜΑ
Αποστολή από: Stop GOTO στις 05 Νοε 2012, 09:16:52 μμ
Σε Pascal θέλεις να το υλοποιήσεις ή σε ΓΛΩΣΣΑ;
σε ΓΛΩΣΣΑ