Γενικό Λύκειο > Εξετάσεις 2017-2018

Θέμα Γ

(1/11) > >>

evry:
Εδώ σχολιάζουμε το Θέμα Γ

mikezante:
Με μια γρηγορη ματιά



--- Κώδικας: ---ΠΡΟΓΡΑΜΜΑ θεμαΓ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ΑΘΡ, ΑΠΟΘΗΚΗ, μαξ, παραμονη, τεμπ, πληθος, ν, εισοδος, εξοδος, διαφορα, διακινηση
  ΧΑΡΑΚΤΗΡΕΣ: απ
ΑΡΧΗ
  ΑΘΡ <- 0
  ΑΠΟΘΗΚΗ <- 0
  ν <- 0
  μαξ <- 0
  παραμονη <- 0
  τεμπ <- 0
  πληθος <- 0
  ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
                                                                             !Γ1
    ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
      ΔΙΑΒΑΣΕ εισοδος, εξοδος
      διαφορα <- εισοδος - εξοδος
      τεμπ <- ΑΠΟΘΗΚΗ + διαφορα
    ΜΕΧΡΙΣ_ΟΤΟΥ τεμπ >= 0 ΚΑΙ τεμπ <= 170
    ΑΠΟΘΗΚΗ <- τεμπ
                                                                             !Γ2
    ΑΝ εισοδος > μαξ ΤΟΤΕ
      μαξ <- εισοδος
    ΤΕΛΟΣ_ΑΝ
                                                                             !Γ3
    διακινηση <- διακινηση + εισοδος + εξοδος
    ν <- ν + 1
                                                                             !Γ4
    ΑΝ ΑΠΟΘΗΚΗ >= 10 ΤΟΤΕ
      παραμονη <- παραμονη + 1
    ΤΕΛΟΣ_ΑΝ
                                                                             !Γ5
    πληθος <- πληθος + ΑΠΟΘΗΚΗ
    ΓΡΑΨΕ "Τελος Εισαγωγης. ΝΑΙ/ΟΧΙ;"
    ΔΙΑΒΑΣΕ απ
  ΜΕΧΡΙΣ_ΟΤΟΥ απ = 'ΝΑΙ'
  ΓΡΑΨΕ μαξ
  ΓΡΑΨΕ διακινηση/ν
  ΓΡΑΨΕ παραμονη
  ΓΡΑΨΕ πληθος/ν
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

--- Τέλος κώδικα ---

gthal:
Σωστό μου φαίνεται, κι εμένα με μια γρήγορη ματιά ;)

pstasinos:
Στο Γ5 νομίζω λέει στο τέλος κάθε μέρας να εμφανίζει ... μήπως πρέπει να μπεί μεσα στη δομή επανάληψης ;

tkon:
Ένας μαθητής μου εκανε το συγκεκριμένο θεμα με χρήση πινάκων

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση