Γενικό Λύκειο > Εξετάσεις 2012-2013

Θέμα Γ

(1/14) > >>

gpapargi:
Εδώ μιλάμε για θέμα Γ

katif:
Μια πρόταση για το Γ3
ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 30
      ΑΝ 2*ΜΟ[ι,1]>ΜΟ[ι,2] ΤΟΤΕ
          ΜΑΧ<-- 2*ΜΟ[ι,1]
     ΑΛΛΙΩΣ
         ΜΑΧ<--ΜΟ[ι,2]
    ΤΕΛΟΣ_ΑΝ

   ΑΝ ΜΑΧ<=3,6 ΤΟΤΕ
       ΓΡΑΨΕ 'Χαμηλός SAR'
   AΛΛΙΩΣ_ΑΝ ΜΑΧ<=4 ΤΟΤΕ
       ΓΡΑΨΕ 'Κοντά στα όρια'
   ΑΛΛΙΩΣ
       ΓΡΑΨΕ 'Έκτος ορίων'
   ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

manosteach:
Κατά την γνώμη μου το παράδειγμα που δίνει είναι άστοχο και θα μπερδέψει πολύ τους μαθητές.
Θα έπρεπε να το θέσει ανάποδα.
ΜΟ SAR  άκρων 1.9 και ΜΟ SAR  κεφαλής 3.4 τότε κοντά στα όρια.
Εκτός και αν εγώ δεν κατάλαβα κάτι σωστά

Βασίλης Παπαχρήστος:
Μία άλλη προσέγγιση για το Γ3 είναι η εξής:

Για i από 1 μέχρι 30
  Εμφάνισε ΚΩΔ[ i ]
  Αν ΜΟ[i,1] <= 1.8 και ΜΟ[i,2] <= 3.6 τότε
    Εμφάνισε "Χαμηλός SAR"
  Αλλιώς_αν ΜΟ[i,1] <= 2 και ΜΟ[i,2] <= 4 τότε
    Εμφάνισε "Κοντά στα όρια"
  Αλλιώς
    Εμφάνισε "Εκτός ορίων"
  Τέλος_αν
Τέλος_επανάληψης

petrosp13:
Δεν νομίζω ότι δουλεύει το παραπάνω..

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση