Γενικό Λύκειο > Θεωρία

Κενό αλφαριθμητικό

(1/3) > >>

thanasisgr:
Συνάδελφοι καλημέρα,
να ρωτήσω αν η αρχικοποίηση αλφαριθμητικού
ον<-'' , δηλαδή εκχωρώ στη μεταβλητή ον την κενή συμβολοσειρά , είναι σωστό ή όχι.

Αφορμή είναι το θέμα Γ των εξετάσεων 2018-2019.
Ως maxtitle δεν πρέπει να δοθεί μια αρχική τιμή;

Φιλικά
Θανάσης

George Eco:
Αν χρησιμοποιήσεις ΟΣΟ, θα βάλεις πριν αυτής μια ΔΙΑΒΑΣΕ για τον τίτλο, οπότε θα παίρνει τιμή, κι αν χρησιμοποιήσεις ΜΕΧΡΙΣ_ΟΤΟΥ μέσα της θα βάλεις τη ΔΙΑΒΑΣΕ κι έτσι δε θα είναι πουθενά empty string εκτός κι αν πατήσει enter ο χρήστης δίχως να δώσει τίτλο, αλλά δε σε νοιάζει βάσει εκφώνησης. Σε νοιάζει η τιμή φρουρός "ΤΕΛΟΣ" μόνο.
Βάζουμε ΟΣΟ γιατί μπορεί ο χρήστης να θέλει να μη βάλει κανένα βίντεο, οπότε εξ αρχής να γράψει ΤΕΛΟΣ.

Φέρει πειν για το τμήμα αυτό...


--- Κώδικας: ---ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΙΤΛΟ. Η ΛΕΞΗ ΤΕΛΟΣ ΘΑ ΤΕΛΕΙΩΣΕΙ ΤΗ ΔΙΑΔΙΚΑΣΙΑ'
ΔΙΑΒΑΣΕ τιτλος
ΟΣΟ τίτλος <> 'ΤΕΛΟΣ'
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΕΠΙΣΚΕΨΕΙΣ (ΑΚΕΡΑΙΟΣ ΘΕΤΙΚΟΣ)'
            ΔΙΑΒΑΣΕ επίσκέψεις
      ΜΕΧΡΙΣ_ΟΤΟΥ επισκέψεις >= 0

      ! Στο τέλος δίνω νέα τιμή στο τίτλο πρίν κάνω λούπα.
      ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΙΤΛΟ. Η ΛΕΞΗ ΤΕΛΟΣ ΘΑ ΤΕΛΕΙΩΣΕΙ ΤΗ ΔΙΑΔΙΚΑΣΙΑ'
      ΔΙΑΒΑΣΕ τιτλος
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


--- Τέλος κώδικα ---

Σε περίπτωση που θες να χρησιμοποιήσεις ΟΣΟ τίτλος <> 'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ θα πρέπει να έχεις αναγκαστικά μια ΔΙΑΒΑΣΕ πριν.
Κι έτσι κανένα πρόβλημα φαντάζομαι.


Αυτό το θέμα λέμε έτσι;

ΘΕΜΑ Γ
"Το Υπουργείο Παιδείας παρέχει μέσω του διαδικτύου μια συλλογή από
εκπαιδευτικά βίντεο. "

Λαμπράκης Μανώλης:

--- Παράθεση από: thanasisgr στις 30 Οκτ 2019, 10:54:45 πμ ---Συνάδελφοι καλημέρα,
να ρωτήσω αν η αρχικοποίηση αλφαριθμητικού
ον<-'' , δηλαδή εκχωρώ στη μεταβλητή ον την κενή συμβολοσειρά , είναι σωστό ή όχι.

Αφορμή είναι το θέμα Γ των εξετάσεων 2018-2019.
Ως maxtitle δεν πρέπει να δοθεί μια αρχική τιμή;

Φιλικά
Θανάσης

--- Τέλος παράθεσης ---

Καλημέρα

Αν x>max τοτε
    max<--x
    max_title<--ον
Τέλος_αν

η βοηθητική μεταβλητή "max_title" λαμβάνει τιμή άμεσα από τη μεταβλητή ον, οπότε δεν είναι απαραίτητο να έχει κάποια αρχική τιμή .. ακόμη και να μην εκτελεστούν επαναλήψεις σε μία επανάληψη με "τιμή φρουρό", μπορούμε να το ελέγξουμε πχ αν max<>-1 τότε, οπότε πάλι δεν χρειάζεται να έχει τιμή

πάντως και να το αρχικοποιήσεις νομίζω πως είναι μια χαρά

thanasisgr:
Ευχαριστώ για την απάντηση, αλλά υπάρχει το εξής θέμα.
Στο Γ3 ερώτημα "Να βρίσκει και να εμφανίζει τον τίτλο του βίντεο με τον μεγαλύτερο αριθμό επισκέψεων.", χρειάζεσαι 2 μεταβλητές : το μεγαλύτερο αριθμο των επισκέψεων μεγΕπ και τον αντίστοιχο τίτλο μεγΤιτλ.
Αν ΔΕΝ αρχικοποιήσεις τον τίτλο και πάς να τον εμφανίσεις έξω από την οσο π.χ ΓΡΑΨΕ μεγΤιτλ, και στην οριακή περίπτωση που δώσεις την 1η φορά ως τίτλο βίντεο το ΄ΤΕΛΟΣ', θα βγάλει runtime λάθος, εκτός και αν έχεις μια αν:
π΄χ ΑΝ  μεγΕπ <> -1 ΤΟΤΕ
            ΓΡΑΨΕ μεγΤιτλ
ΤΕΛΟΣ_ΑΝ
Συνεπώς αν αρχικοποιούσαμε την μεγΤιτλ έξω από το ΌΣΟ δεν θα χρειαζόταν η ΑΝ.
Θα μπορούσα βέβαια να την αρχικοποιήσω με ένα κενο ΧΑΡΑΚΤΗΡΑ πχ μεγΤιτλ<-- '  '.
Αυτό που ρωτάω είναι αν κάπου αναφέρεται ότι μπορούμε να αρχικοποιήσουμε αλφαριθμητικά με το την κενή συμβολοσειρά ως εξής: μεγΤιτλ<-- ''. Αυτό βέβαια επιτρέπεται σε όλες τις γλώσσες προγραμματισμού. Στο ΑΕΠΠ τι ισχύει;

Ευχαριστώ





--- Παράθεση από: George Eco στις 30 Οκτ 2019, 11:29:48 πμ ---Αν χρησιμοποιήσεις ΟΣΟ, θα βάλεις πριν αυτής μια ΔΙΑΒΑΣΕ για τον τίτλο, οπότε θα παίρνει τιμή, κι αν χρησιμοποιήσεις ΜΕΧΡΙΣ_ΟΤΟΥ μέσα της θα βάλεις τη ΔΙΑΒΑΣΕ κι έτσι δε θα είναι πουθενά empty string εκτός κι αν πατήσει enter ο χρήστης δίχως να δώσει τίτλο, αλλά δε σε νοιάζει βάσει εκφώνησης. Σε νοιάζει η τιμή φρουρός "ΤΕΛΟΣ" μόνο.
Βάζουμε ΟΣΟ γιατί μπορεί ο χρήστης να θέλει να μη βάλει κανένα βίντεο, οπότε εξ αρχής να γράψει ΤΕΛΟΣ.

Φέρει πειν για το τμήμα αυτό...


--- Κώδικας: ---ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΙΤΛΟ. Η ΛΕΞΗ ΤΕΛΟΣ ΘΑ ΤΕΛΕΙΩΣΕΙ ΤΗ ΔΙΑΔΙΚΑΣΙΑ'
ΔΙΑΒΑΣΕ τιτλος
ΟΣΟ τίτλος <> 'ΤΕΛΟΣ'
      ΑΡΧΗ_ΕΠΑΝΑΛΗΨΗΣ
            ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΕΠΙΣΚΕΨΕΙΣ (ΑΚΕΡΑΙΟΣ ΘΕΤΙΚΟΣ)'
            ΔΙΑΒΑΣΕ επίσκέψεις
      ΜΕΧΡΙΣ_ΟΤΟΥ επισκέψεις >= 0

      ! Στο τέλος δίνω νέα τιμή στο τίτλο πρίν κάνω λούπα.
      ΓΡΑΨΕ 'ΠΑΡΑΚΑΛΩ ΔΩΣΤΕ ΤΙΤΛΟ. Η ΛΕΞΗ ΤΕΛΟΣ ΘΑ ΤΕΛΕΙΩΣΕΙ ΤΗ ΔΙΑΔΙΚΑΣΙΑ'
      ΔΙΑΒΑΣΕ τιτλος
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ


--- Τέλος κώδικα ---

Σε περίπτωση που θες να χρησιμοποιήσεις ΟΣΟ τίτλος <> 'ΤΕΛΟΣ' ΕΠΑΝΑΛΑΒΕ θα πρέπει να έχεις αναγκαστικά μια ΔΙΑΒΑΣΕ πριν.
Κι έτσι κανένα πρόβλημα φαντάζομαι.


Αυτό το θέμα λέμε έτσι;

ΘΕΜΑ Γ
"Το Υπουργείο Παιδείας παρέχει μέσω του διαδικτύου μια συλλογή από
εκπαιδευτικά βίντεο. "

--- Τέλος παράθεσης ---

thanasisgr:
Ναι αν βάλεις ΑΝ δεν χρειάζεται αρχικοποίηση.
Στη σελίδα 267 του βιβλιου που έχει τον πίνακα ASCII υπάρχει ο χαρακτήρας NUL με δεκαδική τιμή 0.
Οπότε ισχύει. Το θέμα είναι αν πρέπει να το πω ή θα μπερδέψω τους μαθητές , οπότε να μην το αρχικοποιήσω και να βάλω μια εντολή ΑΝ έξω από το ΟΣΟ.
Τι λέτε;


--- Παράθεση από: Λαμπράκης Μανώλης στις 30 Οκτ 2019, 12:17:12 μμ ---Καλημέρα

Αν x>max τοτε
    max<--x
    max_title<--ον
Τέλος_αν

η βοηθητική μεταβλητή "max_title" λαμβάνει τιμή άμεσα από τη μεταβλητή ον, οπότε δεν είναι απαραίτητο να έχει κάποια αρχική τιμή .. ακόμη και να μην εκτελεστούν επαναλήψεις σε μία επανάληψη με "τιμή φρουρό", μπορούμε να το ελέγξουμε πχ αν max<>-1 τότε, οπότε πάλι δεν χρειάζεται να έχει τιμή

πάντως και να το αρχικοποιήσεις νομίζω πως είναι μια χαρά

--- Τέλος παράθεσης ---

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση