Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γ΄ Λυκείου => Μήνυμα ξεκίνησε από: alby στις 25 Μαΐ 2016, 08:27:50 μμ

Τίτλος: Χρόνος εκτέλεσης με δομή επιλογής
Αποστολή από: alby στις 25 Μαΐ 2016, 08:27:50 μμ
Καλησπέρα. Θα ήθελα να με βοηθήσετε στον υπολογισμό του χρόνου εκτέλεσης των παρακάτω τμημάτων.

Κ <-- 1
Αν Κmod 2 = 0 τότε
      Εμφάνισε Κ
      Ζ <-- Κ*2
Αλλιώς
    Εμφάνισε Κ
    Ζ <-- Κ+2
    Εμφάνισε Ζ
Τέλος_αν

!------------
Διάβασε Κ
Αν Κmod 2 = 0 τότε
      Εμφάνισε Κ
      Ζ <-- Κ*2
Αλλιώς
    Εμφάνισε Κ
    Ζ <-- Κ+2
    Εμφάνισε Ζ
Τέλος_αν


Στην 1η περίπτωση θα πρέπει να μετρηθούν οι πράξεις στο αλλιώς λόγω συνθήκης;;
Στη 2η περίπτωση θα πρέπει να μετρηθούν οι πράξεις με περιπτώσεις για το Κ ή συνολικά όλες οι πράξεις;;;

Ευχαριστώ εκ των προτέρων