Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Γ΄ Λυκείου => Μονοδιάστατοι πίνακες => Μήνυμα ξεκίνησε από: Mannou στις 13 Ιαν 2016, 06:44:07 μμ

Τίτλος: Γέμισμα πίνακα... ('Ασκηση)
Αποστολή από: Mannou στις 13 Ιαν 2016, 06:44:07 μμ
Χαίρεται και καλώς σας βρήκα :)

Είναι μια άσκηση εδώ, που ζητά ουσιαστικά από έναν αλγόριθμο, να γεμίσουμε τον τελικό πίνακα, μόνο που με δυσκολεύει...

Ο Αλγόριθμος είναι:

Χ<- 1
Υ<- 8
Για i από 1 μέχρι 12
   Αν [i mod 2=0] τότε
     Α[ i]<- i*Χ
     Χ<- Χ+1
   αλλιώς
      Αν ((i+χ mod 2=1) τότε
        Α[ i] <- Υ+Χ
        Υ<- Υ-1
      αλλιώς
        A[ i] <- 0
     Τέλος_αν
  Τέλος_αν
Τέλος_επανάληψης

(Να τρέξετε το ακόλουθο αλγόριθμο και να γράψετε την τελική μορφή του πίνακα Α.)
Τίτλος: Απ: Γέμισμα πίνακα... ('Ασκηση)
Αποστολή από: Laertis στις 13 Ιαν 2016, 08:20:07 μμ
Καλώς τον.
Δε βλέπω καμιά ιδαίτερη δυσκολία. Απλά μπερδεύεσαι με τις υπο συνθήκη πράξεις και προφανώς με την αναγνώριση των συνθηκών.
Μην περιμένεις να σου το λύσει κάποιος άλλος. Προσπάθησε να γεμίσεις τον πίνακα (θα σε βοηθήσει ένας πίνακας τιμών) και στείλε το αποτέλεσμα για να το δούμε.  ;)
Τίτλος: Απ: Γέμισμα πίνακα... ('Ασκηση)
Αποστολή από: Mannou στις 13 Ιαν 2016, 09:06:17 μμ
Δεν ξέρω, οι πίνακες με ζορίζουν κάπως...
Το πρόβλημά μου είναι πως τον γεμίζουμε τον πίνακα :S
Τίτλος: Απ: Γέμισμα πίνακα... ('Ασκηση)
Αποστολή από: dski στις 14 Ιαν 2016, 12:01:01 πμ
Τον πίνακα Α τον γεμίζει η επανάληψη: Για i από 1 μέχρι 12. Σε κάθε βήμα (κύκλο) της γεμίζει και η αντίστοιχη θέση του πίνακα (αρχικά η Α[1]. μετά η Α[2] κ.ο.κ μέχρι την Α[12]). Η τιμή της κάθε θέσης εξαρτάται από τις συνθήκες της δομής επιλογής μέσα στο σώμα της επανάληψης και τις τιμές των μεταβλητών Χ, Υ και i. Απλά πρέπει να κάνεις τους σχετικούς υπολογισμούς για κάθε i. Ο πίνακας τιμών θα σε βοηθήσει να αποφύγεις λάθη στους υπολογισμούς.