Αποστολέας Θέμα: Unable to boot - please use a kernel appropriate for your cpu  (Αναγνώστηκε 1769 φορές)

nikos33

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 100
Unable to boot - please use a kernel appropriate for your cpu
« στις: 04 Δεκ 2012, 07:55:53 μμ »
Γεια σας,

σε ένα σχετικά παλιό μηχάνημα μου βγάζει το παραπάνω μήνυμα και:

This kernel requires the following features not present on the cpu: pae cx8

(PAE physical address extension)

Μήπως θα πρέπει να βγεί υποστήριξη και για παλιότερα - πιο Lite μηχανήματα αφού εκεί βρίσκεται και όλη η ουσία του project ??

Ευχαριστώ.

apapakL

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 367
    • ΕΛ/ΛΑΚ και εκπαίδευση - Πληροφορική στο Δημοτικό
Απ: Unable to boot - please use a kernel appropriate for your cpu
« Απάντηση #1 στις: 04 Δεκ 2012, 09:14:58 μμ »
Συνάδελφε μάλλον η περίπτωσή σου πρέπει να εμπίπτει σε αυτό:

"Το Ubuntu 12.04 από προεπιλογής χρησιμοποιεί τον πυρήνα linux-image-generic-pae, ο οποίος υποστηρίζει τη μέθοδο Physical Address Extensions για να προσπελαύνει μέχρι και 64 GB RAM κι ας είναι το λειτουργικό σύστημα 32 bit.

Κάποιοι clients μπορεί να μην υποστηρίζουν αυτή τη μέθοδο, και να βγάζουν το παρακάτω μήνυμα:


This kernel requires the following features not present on the cpu: pae.
Unable to boot – please use a kernel appropriate for your cpu.

Σ' αυτήν την περίπτωση, πατήστε Alt+Ctrl+T για να ανοίξετε ένα τερματικό, και δώστε:

Κώδικας: [Επιλογή]
sudo apt-get install linux-image-generic
για να εγκαταστήσετε τον απλό kernel. Στη συνέχεια κάντε  Δημοσίευση εικονικού δίσκου  από τα sch-scripts, και επανεκκινήστε τους clients."

πηγή: http://ts.sch.gr/wiki/Linux/LTSP/Προχωρημένα/Πυρήνες
« Τελευταία τροποποίηση: 06 Δεκ 2012, 01:06:13 πμ από apapakL »

nikos33

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 100
Απ: Unable to boot - please use a kernel appropriate for your cpu
« Απάντηση #2 στις: 04 Δεκ 2012, 10:10:24 μμ »
Ευχαριστώ!!

Θα το δοκιμάσω άμεσα!!

Σε  LTSP10.04 έκδοση έτρεξε κανονικά αλλά θελω να τρέξει και σε 12!

bdaloukas

  • Θαμώνας
  • ***
  • Μηνύματα: 21
Απ: Unable to boot - please use a kernel appropriate for your cpu
« Απάντηση #3 στις: 05 Δεκ 2012, 10:25:20 πμ »
Μετά την αφαίρεση του πυρήνα pae ο σέρβερ θα βλέπει πάνω από 4GB;

apapakL

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 367
    • ΕΛ/ΛΑΚ και εκπαίδευση - Πληροφορική στο Δημοτικό
Απ: Unable to boot - please use a kernel appropriate for your cpu
« Απάντηση #4 στις: 05 Δεκ 2012, 11:18:41 πμ »
Με την εγκατάσταση του απλού πυρήνα ο pae δεν αφαιρείται και χρησιμοποιείται από προεπιλογής στον server και σε όσους clients τον υποστηρίζουν. Απλά οι clients που δεν υποστηρίζουν το pae extension χρησιμοποιούν τον απλό πυρήνα.

gidarakos

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 384
    • http://www.gidarakos.com/
Απ: Unable to boot - please use a kernel appropriate for your cpu
« Απάντηση #5 στις: 11 Μαΐ 2015, 01:16:31 μμ »
Θέλουμε να κάνουμε εγκατάσταση 12.04.3 sch σε ένα IBM T42 (CPU: Pentium M).
Δοκιμάσαμε το Workaround 4: Ubuntu 12.04.5 and 14.04 (or later) on Pentium M only και προχώρησε η εγκατάσταση.
Με το ISO της Τεχνικής Στήριξης δεν λειτουργεί. Ισως επειδή είναι το 12.04.3

Υπάρχει λύση με χρήση των ISO της Τεχνικής Στήριξης;

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 6096
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Unable to boot - please use a kernel appropriate for your cpu
« Απάντηση #6 στις: 12 Μαΐ 2015, 12:03:44 πμ »
Μπορείς να χρησιμοποιήσεις τα δοκιμαστικά CD μας της 12.04.5: http://ts.sch.gr/repo/livecd/12.04/
Όταν τελειώσεις όμως την εγκατάσταση, δες λίγο στο `ls /boot` αν έχει μόνο τον 3.13 kernel γιατί αν έχει και τον 3.2 θέλει βγάλσιμο.

gidarakos

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 384
    • http://www.gidarakos.com/
Απ: Unable to boot - please use a kernel appropriate for your cpu
« Απάντηση #7 στις: 12 Μαΐ 2015, 01:41:50 μμ »
Η εγκατάσταση ολοκληρώθηκε επιτυχώς, στο 'ls /boot' υπήρχε μόνο ο 3.13 kernel, έγιναν κανονικά τα updates, εκτός όμως από το update του kernel 3.13.0.52 - αν θυμάμαι καλά -, ο οποίος δεν εγκαθίσταται.
Στη συνέχεια κάποιες από τις εφαρμογές που επιλέγουμε για εγκατάσταση βγάζουν μηνύματα λάθους τύπου 'Packages have unmet dependencies'.

Δεν ξέρω αν παίζει ρόλο αλλά στη συγκεκριμένη εγκατάσταση θέλουμε αγγλικό περιβάλλον οπότε κατά την εγκατάσταση έχουμε επιλέξει Γλώσσα: Αγγλικά!

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 6096
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Unable to boot - please use a kernel appropriate for your cpu
« Απάντηση #8 στις: 12 Μαΐ 2015, 04:02:05 μμ »
Δεν θα έπρεπε να σου κάνει τέτοια, οπότε έλα από το IRC να τα δούμε live.

Για τα Αγγλικά, την εγκατάσταση καλύτερα να την κάνετε πάντα στα Ελληνικά ώστε να ρυθμίζεται σωστά το σύστημα (κάποια αρχεία ρυθμίσεων στο /etc, π.χ. keyboard, locale), και στη συνέχεια όποιος χρήστης θέλει μπορεί να διαλέξει αγγλική συνεδρία κατά τη σύνδεσή του στον LightDM.

gidarakos

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 384
    • http://www.gidarakos.com/
Απ: Unable to boot - please use a kernel appropriate for your cpu
« Απάντηση #9 στις: 13 Μαΐ 2015, 09:14:15 πμ »
όποιος χρήστης θέλει μπορεί να διαλέξει αγγλική συνεδρία κατά τη σύνδεσή του στον LightDM.
Χρησιμοποιήσαμε το ISO ubuntu-12.04.5-desktop-i386-sch.iso αλλά η εγκατάσταση δεν είναι για LTSP αλλά για standalone χρήση.

Αν κάνουμε την εγκατάσταση με Ελληνική γλώσσα μετά θα μπορέσουμε να αλλάξουμε μόνιμα σε Αγγλικά;

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 6096
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Unable to boot - please use a kernel appropriate for your cpu
« Απάντηση #10 στις: 13 Μαΐ 2015, 10:49:41 πμ »
Χρησιμοποιήσαμε το ISO ubuntu-12.04.5-desktop-i386-sch.iso αλλά η εγκατάσταση δεν είναι για LTSP αλλά για standalone χρήση.

Τι εννοείς; Τα Live CD μας δεν είναι φτιαγμένα ειδικά για LTSP, το LTSP μπαίνει εκ των υστέρων ακολουθώντας τα βήματα 2 ως 7 της σελίδας http://ts.sch.gr/wiki/Linux/LTSP.
Αν κάποιος κάνει μόνο το βήμα 1, δηλαδή την εγκατάσταση, δεν εγκαθίσταται το LTSP, δηλαδή τα Live CD μας είναι κατάλληλα και για standalone χρήση.

Παράθεση
Αν κάνουμε την εγκατάσταση με Ελληνική γλώσσα μετά θα μπορέσουμε να αλλάξουμε μόνιμα σε Αγγλικά;
Η γλώσσα που επιλέγει κάποιος κατά το login αλλάζει μόνιμα μέχρι τυχόν να θελήσει να επιλέξει κάποια άλλη σε επόμενο login.
Βέβαια θα πρέπει για μία φορά κάθε χρήστης του PC να διαλέξει ελληνικά κατά το login, εάν τυχόν έχει πολλούς χρήστες.

gidarakos

  • Δεινόσαυρος
  • *****
  • Μηνύματα: 384
    • http://www.gidarakos.com/
Απ: Unable to boot - please use a kernel appropriate for your cpu
« Απάντηση #11 στις: 13 Μαΐ 2015, 11:25:41 πμ »
Κατανοητό αυτό για το LTSP.. απλά επειδή αλλαγή γλώσσας μου βγάζει μόνο από thin client ανέφερα ότι είναι standalone εγκατάσταση..

Δηλαδή στη standalone - αλλά κ σε μία LTSP server που κοίταξα - στο login δεν βγάζει επιλογή για αλλαγή γλώσσας.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 6096
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Unable to boot - please use a kernel appropriate for your cpu
« Απάντηση #12 στις: 13 Μαΐ 2015, 12:00:28 μμ »
Ναι έχεις δίκιο το άλλαξαν σε κάποια φάση και δεν είναι πια στην οθόνη σύνδεσης.
Τώρα είναι στον πίνακα ελέγχου => Λογαριασμοί χρηστών => Γλώσσα.