Αποστολέας Θέμα: Αριθμός client σε εργαστήριο LTSP  (Αναγνώστηκε 2830 φορές)

Βασίλης Κασαπίδης

  • Οπαδός
  • **
  • Μηνύματα: 17
Αριθμός client σε εργαστήριο LTSP
« στις: 25 Νοε 2013, 12:06:30 πμ »
Συνάδελφοι καλησπέρα.
Προσπαθώ να στήσω ένα εργαστήριο LTSP με 10 fat clients. Μέχρι στιγμής έχω 2 προβλήματα:
1. Δεν μπορούν να bootάρουν περισσότερα από 5 μηχανήματα ταυτόχρονα. (BIOS settings σωστά και στους 10 clients)
Τα μηχανήματα είναι AMD Sempron του 2005 με 1GB Ram και 30GB SSD (τα SSD αγορασμένα πρόσφατα). Ο server είναι ένα AMD FX4000 με 2GB Ram και δίσκο 1TB και το switch είναι ένα LinkSys 100Mb/s. Γνωρίζω ότι το switch πρέπει να είναι 1Gb/s τουλάχιστον αλλά θα ήθελα να ξέρω αν για αυτό δεν ξεκινούν περισσότερα από 5 clients.
2. για κάποιο λόγο στο εργαλείο "Διαχείριση ΣΕΠΕΗΥ" δεν μπορώ να εισάγω λογαριασμούς από CSV ή από passwd αρχείο. Πιο συγκεκριμένα δεν ανοίγει ο πίνακας διαλόγου μετά την επιλογή αρχείου για ανάγνωση. Bug;...

Ευχαριστώ εκ των προτέρων,

Βασίλης

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 6011
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Αριθμός client σε εργαστήριο LTSP
« Απάντηση #1 στις: 25 Νοε 2013, 09:37:36 πμ »
Δεν υπάρχει περιορισμός στο πόσοι clients μπορούν να ξεκινήσουν ταυτόχρονα. Τι μήνυμα λάθους βγάζουν;
Και, έχεις το συνηθισμένο setup με μία κάρτα δικτύου στον LTSP server, ή έχεις 2 κάρτες και εσωτερικό υποδίκτυο ειδικά για LTSP;

Βασίλης Κασαπίδης

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: Αριθμός client σε εργαστήριο LTSP
« Απάντηση #2 στις: 25 Νοε 2013, 01:53:36 μμ »
Δεν υπάρχει περιορισμός στο πόσοι clients μπορούν να ξεκινήσουν ταυτόχρονα. Τι μήνυμα λάθους βγάζουν;
Και, έχεις το συνηθισμένο setup με μία κάρτα δικτύου στον LTSP server, ή έχεις 2 κάρτες και εσωτερικό υποδίκτυο ειδικά για LTSP;

Περιμένουν στο lan boot... (PXE entry point...) μόλις όμως σβήσω το 1 από αυτά που έχουν ξεκινήσει και κάνω reset bootάρει κανονικά...
Μία κάρτα έχω στον server αλλά αν λειτουργεί καλύτερα μπορώ να βάλω και δεύτερη στον server.
Ευχαριστώ.

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 6011
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Αριθμός client σε εργαστήριο LTSP
« Απάντηση #3 στις: 25 Νοε 2013, 02:03:30 μμ »
Ίσως ο router σου να μην έχει διαθέσιμα DHCP leases, δοκίμασε να του κάνεις ένα reset.
Αν δεν παίξει, γράψε τις 3-4 τελευταίες γραμμές που βλέπεις, η φράση "PXE entry point" δεν αρκεί...

Από πλευράς LTSP server δεν υπάρχουν τέτοια όρια.

Βασίλης Κασαπίδης

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: Αριθμός client σε εργαστήριο LTSP
« Απάντηση #4 στις: 25 Νοε 2013, 04:51:11 μμ »
Ίσως ο router σου να μην έχει διαθέσιμα DHCP leases, δοκίμασε να του κάνεις ένα reset.
Αν δεν παίξει, γράψε τις 3-4 τελευταίες γραμμές που βλέπεις, η φράση "PXE entry point" δεν αρκεί...

Από πλευράς LTSP server δεν υπάρχουν τέτοια όρια.

Ok θα στείλω ένα screenshot αύριο. Ο router είναι ένας Cisco 876W. Από leases δεν νομίζω ότι έχει πρόβλημα. Έχω ορίσει το dhcp pool από το 129 μέχρι το 254 και όλα και όλα τα μηχανήματα στο σχολείο δεν είναι πάνω από 20. Reset τον έχω κάνει. Θα αλλάξω το lease expiry μήπως φταίει και αυτό. το ασύρματο είναι απενεργοποιημένο...
 
« Τελευταία τροποποίηση: 25 Νοε 2013, 06:04:57 μμ από Βασίλης Κασαπίδης »

Βασίλης Κασαπίδης

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: Αριθμός client σε εργαστήριο LTSP
« Απάντηση #5 στις: 27 Νοε 2013, 03:40:05 μμ »
Ok θα στείλω ένα screenshot αύριο. Ο router είναι ένας Cisco 876W. Από leases δεν νομίζω ότι έχει πρόβλημα. Έχω ορίσει το dhcp pool από το 129 μέχρι το 254 και όλα και όλα τα μηχανήματα στο σχολείο δεν είναι πάνω από 20. Reset τον έχω κάνει. Θα αλλάξω το lease expiry μήπως φταίει και αυτό. το ασύρματο είναι απενεργοποιημένο...
 

Βγάζει αυτό στη φωτογραφία. Έχουμε θέμα με τα MAC Address; Γιατί εγώ έχω πρόβλημα με το BIOS των περισσοτέρων διότι μετά από 2 ή 3 φορές restart μου βγάζουν checksum error - defaults loaded και χάνω το config τις κάρτας δικτύου... Πήγα να βάλω διαφορετικό MAC Address στην κάρτα στο BIOS της μορφής f1ffffffffff... f2fffffff κλπ ή f1f1f1 ... f2f2f2... κλπ αλλά μόνο με fffff σε όλα ξεκινάνε αλλά όλα με το ίδιο IP (Προφανώς αφού έχουν όλα την ίδια MAC)
 

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 6011
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Αριθμός client σε εργαστήριο LTSP
« Απάντηση #6 στις: 27 Νοε 2013, 05:41:51 μμ »
Ακούγεται για προβληματική ROM της κάρτας δικτύου, δοκίμασε με το iPXE:

http://ts.sch.gr/wiki/Linux/LTSP/Εκκίνηση_από_το_δίκτυο/Win32-loader

Βασίλης Κασαπίδης

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: Αριθμός client σε εργαστήριο LTSP
« Απάντηση #7 στις: 28 Νοε 2013, 09:28:32 μμ »
Ακούγεται για προβληματική ROM της κάρτας δικτύου, δοκίμασε με το iPXE:

http://ts.sch.gr/wiki/Linux/LTSP/Εκκίνηση_από_το_δίκτυο/Win32-loader

Στα clients έχω και σε αυτά ubuntu 12.04. Θα το δω αύριο...

Βασίλης Κασαπίδης

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: Αριθμός client σε εργαστήριο LTSP
« Απάντηση #8 στις: 29 Νοε 2013, 11:17:12 πμ »
δεν μπορώ να εμφανίσω το grub-menu κατά την εκκίνηση του 12.04.3 για pxe boot (έχω βάλει σε μερικά clients το 12.04) καμία ιδέα;

Βασίλης Κασαπίδης

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: Αριθμός client σε εργαστήριο LTSP
« Απάντηση #9 στις: 29 Νοε 2013, 05:35:14 μμ »
Μετά κόπων και βασάνων... ούτε αυτό λειτουργεί... καμιά ιδέα;

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 6011
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Αριθμός client σε εργαστήριο LTSP
« Απάντηση #10 στις: 29 Νοε 2013, 11:43:50 μμ »
Βασίλη κάνε λίγο την παρακάτω δοκιμή για να περιορίσουμε το τι φταίει και τι όχι:

Στον LTSP server, κλικ στο εικονίδιο δικτύου, επεξεργασία συνδέσεων, και βάζεις στατική IP 192.168.67.1.
Στο switch, βγάζεις για λίγο το καλώδιο του router ώστε αυτός να μην επικοινωνεί με το σχολικό εργαστήριο.
Μετά ξεκινάς όλους μαζί τους clients, δοκιμάζοντας είτε μέσω BIOS είτε μέσω iPXE.
Αν μπουτάρουν όλοι, όπως υποθέτω, σιγουρευόμαστε ότι το πρόβλημα είναι είτε στη ROM της κάρτας δικτύου, είτε σε κάποια ρύθμιση του router, οπότε επικεντρωνόμαστε εκεί.

Γράψε και το ακριβές μοντέλο του router.

Βασίλης Κασαπίδης

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: Αριθμός client σε εργαστήριο LTSP
« Απάντηση #11 στις: 30 Νοε 2013, 11:06:51 μμ »
Βασίλη κάνε λίγο την παρακάτω δοκιμή για να περιορίσουμε το τι φταίει και τι όχι:

Στον LTSP server, κλικ στο εικονίδιο δικτύου, επεξεργασία συνδέσεων, και βάζεις στατική IP 192.168.67.1.
Στο switch, βγάζεις για λίγο το καλώδιο του router ώστε αυτός να μην επικοινωνεί με το σχολικό εργαστήριο.
Μετά ξεκινάς όλους μαζί τους clients, δοκιμάζοντας είτε μέσω BIOS είτε μέσω iPXE.
Αν μπουτάρουν όλοι, όπως υποθέτω, σιγουρευόμαστε ότι το πρόβλημα είναι είτε στη ROM της κάρτας δικτύου, είτε σε κάποια ρύθμιση του router, οπότε επικεντρωνόμαστε εκεί.

Γράψε και το ακριβές μοντέλο του router.

Ok, τη Δευτέρα θα το κάνω. Όσο για τον router:
Ορίστε το output του version:
r-gym-gennad@sch.gr#sh ver
Cisco IOS Software, C870 Software (C870-ADVSECURITYK9-M), Version 12.4(15)T5, RELEASE SOFTWARE (fc4)
Technical Support: http://www.cisco.com/techsupport
Copyright (c) 1986-2008 by Cisco Systems, Inc.
Compiled Thu 01-May-08 02:31 by prod_rel_team

ROM: System Bootstrap, Version 12.3(8r)YI1, RELEASE SOFTWARE

r-gym-gennad@sch.gr uptime is 1 day, 18 hours, 40 minutes
System returned to ROM by power-on
System image file is "flash:c870-advsecurityk9-mz.124-15.T5.bin"

...

Cisco 876W (MPC8272) processor (revision 0x100) with 118784K/12288K bytes of memory.
Processor board ID FHK092822KU
MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10
4 FastEthernet interfaces
1 ISDN Basic Rate interface
1 ATM interface
1 802.11 Radio
128K bytes of non-volatile configuration memory.
24576K bytes of processor board System flash (Intel Strataflash)

Configuration register is 0x2102

Και το dhcp status και config:

r-gym-gennad@sch.gr#sh ip dhcp pool

Pool lan :
 Utilization mark (high/low)    : 100 / 0
 Subnet size (first/next)       : 0 / 0
 Total addresses                : 254
 Leased addresses               : 24
 Pending event                  : none
 1 subnet is currently in the pool :
 Current index        IP address range                    Leased addresses
 10.102.0.151         10.102.0.1       - 10.102.0.254      24

r-gym-gennad@sch.gr#sh run

...

no ip dhcp use vrf connected
no ip dhcp conflict logging
ip dhcp excluded-address 10.102.0.0 10.102.0.127
!
ip dhcp pool lan
   network 10.102.0.0 255.255.255.0
   domain-name dod.sch.gr
   dns-server 10.102.0.10 194.63.239.164 194.63.237.4 194.63.238.4
   default-router 10.102.0.1
   netbios-node-type b-node
   lease 30

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 6011
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Αριθμός client σε εργαστήριο LTSP
« Απάντηση #12 στις: 01 Δεκ 2013, 06:36:19 πμ »
Βγάζει αυτό στη φωτογραφία. Έχουμε θέμα με τα MAC Address; Γιατί εγώ έχω πρόβλημα με το BIOS των περισσοτέρων διότι μετά από 2 ή 3 φορές restart μου βγάζουν checksum error - defaults loaded και χάνω το config τις κάρτας δικτύου... Πήγα να βάλω διαφορετικό MAC Address στην κάρτα στο BIOS της μορφής f1ffffffffff... f2fffffff κλπ ή f1f1f1 ... f2f2f2... κλπ αλλά μόνο με fffff σε όλα ξεκινάνε αλλά όλα με το ίδιο IP (Προφανώς αφού έχουν όλα την ίδια MAC)

Σόρρυ αυτό το "έχασα", μάλλον όταν το διάβασα έτρεχα με άλλα... ναι προφανώς αν έχουν όλες οι κάρτες την ίδια MAC θα γίνεται χαμός.
Άνοιξε έναν client, τρέξε "lspci -nn -k | grep -A 2 Ethernet" σε αυτόν και δες το pci id των καρτών, και μετά googleαρε με αυτό το pci id για να βρεις valid mac addresses της εταιρίας αυτής. Ή πήγαινε στο http://www.coffer.com/mac_find/ και γράψε το όνομα των καρτών δικτύου σου (π.χ. realtek) για να βρεις το πρόθεμα από το οποίο θα πρέπει να ξεκινάνε οι mac addresses σου (π.χ. 00:0c:76), και τέλος όρισε σωστές mac address στις κάρτες σου (π.χ. 00:0c:76:00:00:01, 00:0c:76:00:00:02...).

Βασίλης Κασαπίδης

  • Οπαδός
  • **
  • Μηνύματα: 17
Απ: Αριθμός client σε εργαστήριο LTSP
« Απάντηση #13 στις: 02 Δεκ 2013, 05:55:47 μμ »
Σόρρυ αυτό το "έχασα", μάλλον όταν το διάβασα έτρεχα με άλλα... ναι προφανώς αν έχουν όλες οι κάρτες την ίδια MAC θα γίνεται χαμός.
Άνοιξε έναν client, τρέξε "lspci -nn -k | grep -A 2 Ethernet" σε αυτόν και δες το pci id των καρτών, και μετά googleαρε με αυτό το pci id για να βρεις valid mac addresses της εταιρίας αυτής. Ή πήγαινε στο http://www.coffer.com/mac_find/ και γράψε το όνομα των καρτών δικτύου σου (π.χ. realtek) για να βρεις το πρόθεμα από το οποίο θα πρέπει να ξεκινάνε οι mac addresses σου (π.χ. 00:0c:76), και τέλος όρισε σωστές mac address στις κάρτες σου (π.χ. 00:0c:76:00:00:01, 00:0c:76:00:00:02...).

Φίλε Άλκη, ευχαριστώ πολύ. Τελικά όντως ήταν τα mac address. Οι VIA Rhine II έχουν mac της μορφής 00.0F.EA.40.2B.C1... Το μόνο μου πρόβλημα είναι ότι χάνουν τα μηχανήματα τις ρυθμίσεις του BIOS με checksum error. Πιστεύω ότι είναι οι μπαταρίες του ρολογιού... Τώρα φτιάχνω λογαριασμούς... :)
 

alkisg

  • Τεχνικός / καθαρίστρια
  • *****
  • Μηνύματα: 6011
    • Ο Διερμηνευτής της ΓΛΩΣΣΑΣ
Απ: Αριθμός client σε εργαστήριο LTSP
« Απάντηση #14 στις: 02 Δεκ 2013, 06:28:34 μμ »
Πιστεύω ότι είναι οι μπαταρίες του ρολογιού...

Jumbo/ΙΚΕΑ κλπ, το χαρτί με τις 6-8 μπαταρίες έχει 1-2 ευρώ. :)