Γενικό Λύκειο > Μονοδιάστατοι πίνακες

ποσότητα των επαναλήψεων στους πίνακες

(1/1)

nokotsos:
Συνήθως στις ασκήσεις κάνουμε μια επανάλήψη για να διαβάσουμε έναν πίνακα και μετά ξανα ανοίγουμε για να κάνουμε διάφορες ενέργειες(για παραδειγμα να βρούμε κάποιο πλήθος μέσα στον πίνακα ,έναν μέσο όρο ίσως κτλπ). Είναι λάθος να τα κάνουμε σε μία επανάληψη? Γιατί τα βοηθήματα συνήθως ανοίγουμε για κάθε μία επεξεργασία και μια επαναληψη.Δυσκολεύομαι να χρησιμοποιώ πολλές επαναλήψεις χωρίς λόγο.

--- Παράθεση ---ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
 ΔΙΑΒΑΣΕ Α[Ι]
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΠΛ <-- 0
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
 ΑΝ Α[Ι] > 5 ΤΟΤΕ
  ΠΛ <-- ΠΛ + 1
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

--- Τέλος παράθεσης ---

Εναλλακτική


--- Παράθεση ---ΠΛ <-- 0
ΓΙΑ Ι ΑΠΟ 1 ΜΕΧΡΙ 5
 ΔΙΑΒΑΣΕ Α[Ι]
 ΑΝ Α[Ι] > 5 ΤΟΤΕ
  ΠΛ <-- ΠΛ + 1
 ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

--- Τέλος παράθεσης ---

petrosp13:
Λάθος δεν είναι καμία λύση που υπολογίζει σωστά τα ζητούμενα
Όσο απλωμένη ή "συμπυκνωμένη" και να είναι

nokotsos:
Ευχαριστώ πολύ!

evry:
Καλό θα ήταν κάθε ερώτημα να είναι και σε ξεχωριστή επανάληψη. Βοηθάει πολύ τους βαθμολογητές.

Πλοήγηση

[0] Λίστα μηνυμάτων

Μετάβαση στην πλήρη έκδοση