Αλλαγή των στοιχείων σε μονοδιάστατο πίνακα

Ξεκίνησε από nikolasmer, 19 Ιαν 2013, 12:15:22 ΜΜ

« προηγούμενο - επόμενο »

nikolasmer

Έβαλα αυτή την ασκησούλα και το 90% των μαθητών έβγαλαν ως αποτέλεσμα το Α Ι Ρ Ι Α. Μερικοί έκαναν και πίνακα τιμών για αυτό.  :(
Πώς πρέπει τέλος πάντων να τους το δείξεις;

Π[1] <- "Μ"
Π[2] <- "Α"
Π[3] <- "Ρ"
Π[4] <- "Ι"
Π[5] <- "Α"
Για Ι από 1 μέχρι 5
   Π[ Ι ] <- Π[ 6 - Ι]
Τέλος_επανάληψης
Για Ι από 1 μέχρι 5
   Εμφάνισε Π[ Ι ]
Τέλος_επανάληψης
Μερεντίτης Νικόλαος
Πληροφορικός

petrosp13

Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

andreas_p

Π[ Ι ] <- Π[ 6 - Ι]

Αλλάζει το περιεχόμενο του πίνακα Π !

nikolasmer

Συγνώμη. Από ταχύτητα έγραψα το σωστό. Ήθελα να γραψω πως οι περισσοτεροι μου έδωσαν ως απάντηση το Α Ι Ρ Α Μ. Στις απαντήσεις τους είδα πως σχεδίασαν από κάτω τον πίνακα και έβαλαν τα καινούρια στοιχεία του στην ουσία σε ένα αντίγραφο του αρχικού πίνακα Π.
Μερεντίτης Νικόλαος
Πληροφορικός

petrosp13

Πες τους ότι τα στοιχεία των πινάκων είναι θέσεις μνήμης και (όπως οι μεταβλητές) αποθηκεύουν την τελευταία τιμή που τους δόθηκε και μόνο
Παπαδόπουλος Πέτρος
Καθηγητής Πληροφορικής

nikolasmer

Θα το ξαναπώ μήπως και βάλουν μυαλό. Είναι κρίμα να χαθούν μονάδες από αυτό το θεματάκι.
Μερεντίτης Νικόλαος
Πληροφορικός

evry

Βάλε τους να κάνουν πίνακα τιμών όπου κάθε μεταβλητή θα είναι στοιχείο του πίνακα και πες τους να τα αντιμετωπίσουν σαν απλές μεταβλητές.

ή αν έχεις χρόνο κάνε το παρακάτω

Δώσε τους τον αλγόριθμο χωρίς πίνακα και χωρίς επανάληψη κάπως έτσι

Α1 <-- Α5
Α2 <-- Α4
Α3 <-- Α3
Α4 <-- Α2
Α5 <-- Α1

βάλτους να κάνουν το παραπάνω με πίνακα τιμών

μετά απλά βάλε αγκύλες και πες τους ότι είναι ακριβώς το ίδιο και δεν έχει καμία απολύτως διαφορά με πριν

Α[1] <-- Α[5]
Α[2] <-- Α[4]
Α[3] <-- Α[3]
Α[4] <-- Α[2]
Α[5] <-- Α[1]

και στη συνέχεια παραμετροποίησέ το με το i κάπως έτσι και βάλε τους να συμπληρώσουν τα κενά έτσι ώστε τα δύο τμήματα αλγορίθμου να κάνουν ακριβώς τα ίδια.
Βάλε κάθε μια εντολή δίπλα σε κάθε ζευγαράκι εκσχώρησης πίνακα με i

i <-- 1
A[i] <-- A[...]
i<-- ....
A[i] <-- A[....]
i<-- ...
A[i] <-- A[....]
i<-- ...
A[i] <-- A[....]
i<-- ...
A[i] <-- A[....]
i<-- ...

μετά γενικεύεις σε επανάληψη

Μετά για να τους ελέγξεις δώσε τους να τρέξουν με το χέρι κάτι σαν το παρακάτω

Για ι από 2 μέχρι 4
   Α[ι] <-- Α[ι+1] + Α[ι-1]
ΤΕ


σε έναν πίνακα με τους παρακάτω αριθμούς
10 20 30 40 50

ΥΓ. Επίσης διαφωνώ ότι δεν πρέπει να χαθούν μονάδες για κάτι τέτοιο. Σαφώς και πρέπει να χαθούν γιατί το λάθος δείχνει έλλειψη κατανόησης του μαθητή σε βασική έννοια.
What I cannot create I do not understand -- Richard Feynman
http://evripides.mysch.gr

nikolasmer

Φοβερό. Σε ευχαριστώ evry. Από το ειδικό στο γενικό. Αυτή η μέθοδος πάντα πιάνει.
Μερεντίτης Νικόλαος
Πληροφορικός