Γενικό Λύκειο > Εισαγωγή στοιχείων, εμφάνιση και υπολογισμοί

ΓΕΝΝΗΤΡΙΑ ΤΥΧΑΙΩΝ ΑΡΙΘΜΩΝ

(1/1)

thaaanos:
QUICK AND DIRTY από numerical recipes


--- Κώδικας: ---ΠΡΟΓΡΑΜΜΑ rand
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: RN, i
ΑΡΧΗ
  RN <- 2354543
  ΓΙΑ i ΑΠΟ 1 ΜΕΧΡΙ 100
    RN <- DIRTY_RAND(RN)
    ΓΡΑΨΕ  RN
    ΓΡΑΨΕ SCALE( RN,20, 1444)
    ΓΡΑΨΕ Α_Μ(SCALE( RN, 0, 100))
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ

ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


ΣΥΝΑΡΤΗΣΗ SCALE(RN, MIN, MAX): ΠΡΑΓΜΑΤΙΚΗ
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: RN, MIN, MAX
ΑΡΧΗ
  SCALE<- MIN + (MAX - MIN)*RN/2^32
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ


ΣΥΝΑΡΤΗΣΗ DIRTY_RAND(seed): ΑΚΕΡΑΙΑ
ΣΤΑΘΕΡΕΣ
  c1 = 1664525
  c3 = 1013904223
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: seed, idum
ΑΡΧΗ
  idum <- seed
  idum <- (c1*idum) mod 2^32
  idum <- (c3 + idum) mod 2^32
  DIRTY_RAND <- idum
ΤΕΛΟΣ_ΣΥΝΑΡΤΗΣΗΣ
--- Τέλος κώδικα ---

Πλοήγηση

[0] Λίστα μηνυμάτων

Μετάβαση στην πλήρη έκδοση