Γενικό Λύκειο > Αναζήτηση

ΑΝΑΖΗΤΗΣΗ ΣΕ ΤΑΞΙΝΟΜΗΜΕΝΟ ΠΙΝΑΚΑ ΜΕ ΕΠΑΝΑΛΗΨΕΙΣ ΣΤΟΙΧΕΙΩΝ

(1/1)

droopy:
Καλησπέρα,

στην περίπτωση που έχουμε ταξινομημένο πίνακα σε αύξουσα διάταξη και με επαναλήψεις στοιχείων και θέλουμε να εμφανίζει τις θέσεις στις οποίες βρίσκεται το στοιχείο που ψάχνουμε ή το μήνυμα ότι δεν υπάρχει το στοιχείο αυτό, η παρακάτω λύση είναι σωστή;

done ← ψευδής
pos ← 0
i ← 1
 Όσο (done=ψευδής) και (i<=N) επανάλαβε
         Αν A|i|=key τότε
              pos<--i
              ΓΡΑΨΕ ‘ΒΡΕΘΗΚΕ ΣΤΗ ΘΕΣΗ’,pos
               i<--i+1
        αλλιώς_αν Α|i|>key τότε   
               done <-- αληθής
        αλλιώς
               i <-- i+1
       Τέλος_αν
Τέλος_επανάληψης
Αν pos = 0 TOTE
   ΓΡΑΨΕ ‘Δεν βρέθηκε’
Τέλος_αν

Ευχαριστώ.

ikariofil:
μια χαρά φαίνεται ...

Πλοήγηση

[0] Λίστα μηνυμάτων

Μετάβαση στην πλήρη έκδοση