Γενικό Λύκειο > Δομή επανάληψης

Μετατροπή από μια δομή επανάληψης σε μια άλλη

(1/3) > >>

theoni:
Γειά  σας θα ήθελα την βοήθεια  σας  υπάρχει ο εξής αλγόριθμος
α<--0
Ι<--1
Αρχή  επανάληψης
     α<--α+Ι^2
      Ι<--Ι+2
Μέχρις ότου Ιdiv7>5
Εμφάνισε α
Η εκφώνηση είναι να μετατρέψετε τη δομή επανάληψης στις άλλες δύο δομές επανάληψης ..Σε όσο μετατρέπεται σϊγουρα σε για μπορεί να μετατραπεί????? Υπαρχουν βοηθήματα που λένε πως γίνεται με για και άλλα πως όχι  η δική σας άποψη ποια είναι???

Laertis:
Φυσικά και γίνεται σε Για γιατί η μεταβλητή Ι πέρνει συγκεκριμένες τιμές και με συγκεκριμένο βήμα :

α<--0
Για Ι απο 1 μέχρι 41 με βήμα 2
      α<--α+Ι^2
Τέλος_επανάληψης
Εμφάνισε α

orion42:
 ! Κάνω μετατροπή σε ΟΣΟ, αφού κάνω πρώτα πίνακα τιμών με την ΜΕΧΡΙΣ_ΟΤΟΥ και βρω μέχρι ποιόν αριθμό θα φτάσω (41)
α <-- 0
Ι <-- 1
α <-- α+Ι^2       
Ι <-- Ι+2         
Όσο Ι <=41 επανάλαβε
  α <-- α+Ι^2
  Ι <-- Ι+2
Τέλος_επανάληψης
Γράψε α

  ! Μετά κάνω τη μετατροπή σε ΓΙΑ
α <-- 0
Ι <-- 1
α <-- α+Ι^2     ! (α <-- 0 + 1,  δηλαδή, α=1)
Ι <-- Ι+2         ! (Ι <-- 1 + 2, δηλαδή,  Ι =3)
Για Ι από 3 μέχρι 41 με βήμα 2
  α <-- α+Ι^2
Τέλος_επανάληψης
Γράψε α

andreas_p:
Στον 1ο έλεγχο η Σ της Όσο είναι Αληθής.
Ο βρόχος
  α <-- α+Ι^2       
  Ι <-- Ι+2
για ποιο λόγο προτάσσεται ;   

orion42:
Γιατί προέρχεται από την Μέχρις_ότου και θα γίνει  1 φορά υποχρεωτικά. Αυτό ήθελα να δείξω. Μπορεί και να παραλειφθεί.

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση