Γενικό Λύκειο > Εντολή ΓΙΑ...ΑΠΟ...ΜΕΧΡΙ

Απορία στην ΓΙΑ

(1/16) > >>

tkon:
Στην επαναληπτική δομή ΓΙΑ η επαναληπτική διαδικασία δεν ικανοποιεί το κριτήριο της περατότητας μόνο στην περίπτωση που το Βήμα είναι μηδέν
Σωστό ή Λάθος;
Και γιατί;

thanos_xg:
H ΓΙΑ συμπεριφέρεται όπως και η αντίστοιχή της ΟΣΟ. Αν το βήμα είναι 0 τότε η μεταβλητή ελέγχου της ΓΙΑ άρα και της ΟΣΟ δεν μεταβάλλεται. Έτσι έχουμε ατέρμονα βρόχο.
Σε κάθε άλλη περίπτωση η ΓΙΑ δεν θα εκτελείται καθόλου ή θα εκτελείται κάποιες συγκεκριμένες φορές σύμφωνα με τον τύπο
(τελ_τιμή-αρχ_τιμη) div βήμα +1....

Μετά από αυτά η απάντηση στο σωστό-λάθος είναι ΣΩΣΤΟ

tkon:
Σε διαγώνισμα 11/12/2016 ( Εκπαίδευση εν τάξη)
Στις απαντήσεις το δίνει ΛΑΘΟΣ

evry:
Δίνω δυο τμήματα κώδικα με Για

--- Κώδικας: Pascal ---Για i από 10 μέχρι 1 με βήμα 0

--- Κώδικας: Pascal ---Για i από 1 μέχρι 10 με βήμα 0
Αφού για τις παραπάνω υπάρχει ισοδύναμο τμήμα της Όσο ποιο είναι αυτό σε κάθε περίπτωση?

--- Παράθεση από: thanos_xg στις 02 Ιουν 2017, 05:34:47 μμ ---H ΓΙΑ συμπεριφέρεται όπως και η αντίστοιχή της ΟΣΟ. Αν το βήμα είναι 0 τότε η μεταβλητή ελέγχου της ΓΙΑ άρα και της ΟΣΟ δεν μεταβάλλεται. Έτσι έχουμε ατέρμονα βρόχο.

--- Τέλος παράθεσης ---

Λαμπράκης Μανώλης:
εγώ αυτό που έχω στο μυαλό μου  είναι το εξής: (αν δεν κάνω λάθος το είχα διαβάσει εδώ από τον συνάδελφο Παναγιώτη Τσιωτάκη, για να μην το ψάχνω το γράφω απευθείας)

όταν εκτελείται ένας βρόγχος ΓΙΑ είναι σαν να εκτελείται το ακόλουθο

Αν βήμα= 0 τότε
   γράψε "άπειρες"
Αλλιώς_αν βήμα>'τότε
   κ<-- τιμή_από
   'Οσο κ<= τιμή_μέχρι επανάλαβε
       εντολές
       κ<--κ+βήμα
   Τέλος_επανάληψης
Αλλιώς   ! βήμα<0 τότε
   κ<-- τιμή_από
   'Οσο κ>= τιμή_μέχρι επανάλαβε
       εντολές
       κ<--κ+βήμα
   Τέλος_επανάληψης
Τέλος_αν

..... εγώ έτσι το αντιλαμβάνομαι, το βήμα 0 οδηγεί "αυτόματα" σε ατέρμων βρόχο

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση