Γενικό Λύκειο > Μονοδιάστατοι πίνακες

helpp

(1/2) > >>

Eleftheria_k:
Πως θα ελεξω το περιεχόμενο ενος πινακα
αν ειναι ταξινομημενος κατά αύξουσα σειρα η κατα φθίνουσα η δεν ειναι καθολου ταξινομημενος..σεολες τις παραπανω ενεργειες να εμφανίζει κατάλληλο μηνυμα..

evry:
Θα ψάξεις να βρεις αν υπάρχουν δυο διαδοχικά στοιχεία τα οποία δεν είναι στη σειρά που θέλεις. Αν βρεις τέτοιο αντιπαράδειγμα θα θέσεις μια λογική μεταβλητή ΑΥΞΟΥΣΑ με τιμή ψευδής. Στην αρχή η λογική αυτή μεταβλητή θα είναι αληθής. Αν δεν βρει στοιχεία τα οποία να μην είναι σε αύξουσα σειρά θα παραμείνει αληθής αλλιώς αν βρει έστω και ένα θα γίνει ψευδής.

Αυτή είναι η βασική ιδέα.

Eleftheria_k:
Ναι και στο τελος θα πω:
Αν ΑΥΞΟΥΣΑ= ΑΛΗΘΗΣ τοτε γραψε"αυξουσα διαταξη"
Αλλιως γραψε "φθινουσα διαταξη"
Εγω ομως θελω τρεις περιπτώσεις..αν δεν ειναι ταξινομημενος πως θα το εμφανιζω.αυτο δεν εχω καταλαβει

evry:
Αν δεν είναι αύξουσα δεν σημαίνει ότι είναι φθίνουσα, μπορεί να μην είναι τίποτα.


--- Κώδικας: Pascal ---ΑΥΞΟΥΣΑ <- ΑΛΗΘΗΣΦΘΙΝΟΥΣΑ <- ΑΛΗΘΗΣi <- 2ΟΣΟ (ΑΥΞΟΥΣΑ Ή ΦΘΙΝΟΥΣΑ) ΚΑΙ i<=N ΕΠΑΝΑΛΑΒΕ    ΑΝ A[i-1] < A[i] Τότε        ΦΘΙΝΟΥΣΑ <- ΨΕΥΔΗΣ     ΤΕΛΟΣ_ΑΝ    ΑΝ A[i-1] > A[i] Τότε        ΑΥΞΟΥΣΑ <- ΨΕΥΔΗΣ     ΤΕΛΟΣ_ΑΝ    i <- i + 1ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
Σκέψου τι θα πρέπει να γράψεις έξω από την επανάληψη ώστε να εμφανιστούν τα σωστά μηνύματα

Eleftheria_k:
Ενταξει θα το προσπαθήσω!!ευχαριστω :D

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση