Γενικό Λύκειο > Μονοδιάστατοι πίνακες

Ακέραιος δείκτης πίνακα στα "Βασικά στατιστικά μεγέθη"

(1/1)

Νίκος Αδαμόπουλος:
Αν θεωρούμε ότι:
α) ο τελεστής  / δίνει εξ ορισμού πραγματικού τύπου αποτέλεσμα
β) οι δείκτες στους πίνακες πρέπει να είναι ακέραιοι
τότε στο παράδειγμα του σχολικού βιβλίου με τα βασικά στατιστικά μεγέθη (σελ. 188 της παλιάς έκδοσης, βλ: https://alkisg.mysch.gr/steki/index.php?topic=1436.0) υπάρχει προβληματάκι!
 
!Υπολογισμός διαμέσου
ΑΝ Ν MOD 2 =0 TOTE
    Διάμεσος <- (X[N/2]+X[N/2+1])/2
ΑΛΛΙΩΣ
    Διάμεσος <- X[(N+1)/2]
ΤΕΛΟΣ_ΑΝ

andreas_p:
!Υπολογισμός διαμέσου
ΑΝ Ν MOD 2 =0 TOTE
    Διάμεσος <- (X[N div 2]+X[N div 2+1])/2
ΑΛΛΙΩΣ
    Διάμεσος <- X[(N+1) div 2]
ΤΕΛΟΣ_ΑΝ

Πλοήγηση

[0] Λίστα μηνυμάτων

Μετάβαση στην πλήρη έκδοση