Αποστολέας Θέμα: Διαγωνισμός tango: Ιδιόμορφο γέμισμα πίνακα  (Αναγνώστηκε 2096 φορές)

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 810
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Στην τελική φάση ενός διαγωνισμού tango, συμμετέχουν 10 ζευγάρια χορευτών. 

Να κατασκευάσετε πρόγραμμα που θα καταχωρίζει τα ονόματα των 20 συμμετεχόντων σε μονοδιάστατο πίνακα με 20 στοιχεία.  Τα ονόματα των ανδρών να καταχωρίζονται στις μονές και των γυναικών στις αντίστοιχες ζυγές θέσεις του πίνακα. 

Για λόγους .. ευγένιας, κατά την είσοδο των στοιχείων η εφαρμογή να ζητάει, για κάθε ζευγάρι, τα ονόματα με "ανάποδη" σειρά (πρώτα το όνομα της διαγωνιζόμενης και μετά του παρτενέρ της) εμφανίζοντας μήνυμα της μορφής «ποιό είναι το όνομα της γυναίκας στο 1ο ζευγάρι;» και στη συνέχεια (έστω πως δόθηκε το όνομα Μαρία για τη διαγωνιζόμενη) «ποιό είναι το όνομα του παρτενέρ της διαγωνιζόμενης: Μαρία;». 

Τέλος να εμφανίζει τα ζευγάρια αριθμημένα (από το 1 μέχρι το 10) με ένα μήνυμα για κάθε ζευγάρι (π.χ. 1ο ζευγάρι: Μαρία - Γιώργος)
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

programmer

  • Θαμώνας
  • ***
  • Μηνύματα: 44
Απ: Διαγωνισμός tango: Ιδιόμορφο γέμισμα πίνακα
« Απάντηση #1 στις: 09 Φεβ 2015, 05:34:27 πμ »
ΠΡΟΓΡΑΜΜΑ ζευγαρια_χορος
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ι, κ
  ΧΑΡΑΚΤΗΡΕΣ: ζευγαρια[20]
ΑΡΧΗ
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 10
    ΓΡΑΨΕ "ΠΩΣ ΛΕΝΕ ΤΗΝ ΚΟΠΕΛΑ ΤΟΥ ", ι, "ου ΖΕΥΓΑΡΙΟΥ;"
    ΔΙΑΒΑΣΕ ζευγαρια[2*ι]
    ΓΡΑΨΕ "ΠΟΙΟΣ ΕΙΝΑΙ Ο ΠΑΡΤΕΝΕΡ ΤΗΣ ", ζευγαρια[2*ι], "Σ ;"
    ΔΙΑΒΑΣΕ ζευγαρια[2*(ι - 1) + 1]
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  κ <- 1
  ΓΙΑ ι ΑΠΟ 1 ΜΕΧΡΙ 20 ΜΕ_ΒΗΜΑ 2
    ΓΡΑΨΕ "ΤΟ ", κ, "ο ΖΕΥΓΑΡΙ ΕΙΝΑΙ ΤΟ: ", ζευγαρια[ι + 1], " ----- ", ζευγαρια[ι]
    κ <- κ + 1
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ