Γενικό Λύκειο > Δομή επανάληψης

Πολλαπλασιασμός αλά ρωσικά ??

<< < (5/5)

Σάκης Δημόπουλος:
https://www.youtube.com/watch?v=5LlHaoqBfbk&t=

Κωστας τζιαννης:

προγραμμα σε Γλωσσα πολλαπλασιασμου αλλα ρωσικα χωρις συντελεστη * και χωρις Αν


ΠΡΟΓΡΑΜΜΑ πολσμος_αλα_ρωσικα
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α, β
  ΠΡΑΓΜΑΤΙΚΕΣ: αθρ
ΑΡΧΗ

  αθρ <- 0
  ΔΙΑΒΑΣΕ α, β
  ΟΣΟ α >= 1 και β<>0 ΕΠΑΝΑΛΑΒΕ  !0^0 δεν οριζεται και υπαρχει πιθανοτητα αν δεν βαλω τη δευτερη συνθηκη να προκυψει αυτο μεσα στην επαναληψη

    αθρ <- αθρ + β^(α mod 2) - (1 - α mod 2)
    α <- α div 2
    β <- β + β
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
  ΓΡΑΨΕ Α_Μ(αθρ)         !για να φαινεται χωρις τα μηδενικα δεκαδικα,ως ακεραιος


ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ


2η ΕΚΔΟΧΗ  που λαμβανει υποψιν και αρνητικους αριθμους με τους ιδιους περιορισμους που εχω παραπανω(χωρις *,ΑΝ):


ΠΡΟΓΡΑΜΜΑ πολσμος_αλα_ρωσικα
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: α, β
  ΠΡΑΓΜΑΤΙΚΕΣ: αθρ, χ
ΑΡΧΗ

  αθρ <- 0
  ΔΙΑΒΑΣΕ α, β
  χ <- Α_Τ(α) + Α_Τ(β)
  χ <- Α_Τ(α + β) - χ + 1
             !αν α*β>=0 το χ ειναι 1 αλλιως ειναι αρνητικο(αποδεικνυεται ευκολα)
  α <- Α_Τ(α)
  β <- Α_Τ(β)
  ΟΣΟ α >= 1 ΚΑΙ β <> 0 ΕΠΑΝΑΛΑΒΕ!0^0 δεν οριζεται και υπαρχει πιθανοτητα αν δεν βαλω τη δευτερη συνθηκη να προκυψει αυτο μεσα στην επαναληψη

    αθρ <- αθρ + β^(α mod 2) - (1 - α mod 2)
    α <- α div 2
    β <- β + β
  ΤΕΛΟΣ_ΕΠΑΝΑΛΗΨΗΣ
       !το div χρησιμοποειται με ακεραιους για αυτο χρησιμοποιω τη συναρτηση Α_Μ
  ΓΡΑΨΕ (Α_Μ(αθρ)) div (Α_Μ(χ) div Α_Μ(Α_Τ(χ)))


ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ

Πλοήγηση

[0] Λίστα μηνυμάτων

[*] Προηγούμενη σελίδα

Μετάβαση στην πλήρη έκδοση