Γενικό Λύκειο > Δομή επανάληψης

Πολλαπλασιασμός αλά ρωσικά ??

(1/5) > >>

P.Tsiotakis:

Ο ανηψούλης μου από την Τενεούπολη με ρώτησε αν ο παρακάτω αλγόριθμος (για τον πολ/σμό αλά ρωσικά) είναι σωστός (δεν τον σκέφτηκε μόνος του):

   Δεδομένα // Μ1, Μ2 //
   P ← 0
   Για Ε από Μ2 μέχρι 0 με_βήμα Κ
      Αν Ε mod 2 = 1 τότε
           P ← P + M1
      Τέλος_αν
      M1 ← M1*2
      K ← M2 div 2
   Τέλος_επανάληψης
   Αποτελέσματα // P //

Ο γιατρός μου είπε οτι ήμουν πολύ τυχερός που τη γλύτωσα και πως πρέπει να προσέχω πολύ στο εξής. Σε επόμενη παρόμοια...συγκίνηση μπορεί να μην είμαι τόσο τυχερός. Δεν είναι και πολύ συνηθισμένες τέτοιες κρίσεις στα 29...

Με εκτίμηση,

nekis:
:) :) :)

Vangelis:
Ποιός τον έγραψε αυτόν βρε παιδιά!!!

gpapargi:
Σε αντιπαράθεση των παραπάνω περιγράφω μια λύση μαθήτριας που είδα πρόσφατα
Αφού περιέγραψα στα παιδιά τη διαδικασία και κάναμε έναν πολλαπλασιασμό με το χέρι για να δούμε τα βήματα, τους είπα να υλοποιήσουν τον αλγόριθμο σε ψευδογλώσσα.
Είχα τη χαρά να δω μια μαθήτρια να συλλαμβάνει έναν από τους πιο ωραίους αλγορίθμους.

Δεδομένα //χ, ψ//
γινόμενο < - 0
Αρχή_επανάληψης
  γινόμενο < - γινόμενο + χ * (ψ mod2)   ! Τι σκέφτηκε το άτομο!!!
  χ < - 2* χ
  ψ < - ψ div 2
Μέχρις_ότου ψ = 0
Εμφάνισε γινόμενο

EleniK:
Είστε τυχεροί!!!
Μακάρι να είχα και εγώ τετοιες συγκινήσεις έστω και στα 31 πιστεύω να το άντεχα. :-)

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση