Αποστολέας Θέμα: Θέματα κατανόησης για min, max, θέση  (Αναγνώστηκε 3487 φορές)

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2843
  • Πύργος Ηλείας
Θέματα κατανόησης για min, max, θέση
« στις: 24 Ιαν 2011, 06:24:46 μμ »
Θέματα προς μαθητές για κατανόηση ζητημάτων εντοπισμού του min, max, θέσης αυτών, κλπ, από μονοδιάστατο πίνακα

Ο παρακάτω αλγόριθμος εντοπίζει την ελάχιστη τιμή ενός μονοδιάστατου πίνακα Α που περιέχει Ν διαφορετικές τιμές:

Παράθεση
Αλγόριθμος Ελάχιστη_τιμή
Δεδομένα // Α, Ν //
ελάχιστο <- Α[1]
Για ι από 2 μέχρι N
  Αν Α[ι] < ελάχιστο τότε ελάχιστο <- Α[ι]
Τέλος_επανάληψης
Αποτελέσματα // ελάχιστο //
Τέλος Ελάχιστη_τιμή

1. Αν ο αλγόριθμος αλλάξει όπως παρακάτω, συνεχίζει να εντοπίζει την ελάχιστη τιμή; Γιατί;

Παράθεση
Αλγόριθμος Ελάχιστη_τιμή
Δεδομένα // Α, Ν //
ελάχιστο <- Α[1]
Για ι από 1 μέχρι N
  Αν Α[ι] < ελάχιστο τότε ελάχιστο <- Α[ι]
Τέλος_επανάληψης
Αποτελέσματα // ελάχιστο //
Τέλος Ελάχιστη_τιμή

2. Αν ο αλγόριθμος αλλάξει όπως παρακάτω, συνεχίζει να εντοπίζει την ελάχιστη τιμή; Γιατί;

Παράθεση
Αλγόριθμος Ελάχιστη_τιμή
Δεδομένα // Α, Ν //
ελάχιστο <- Α[1]
Για ι από 2 μέχρι N
  Αν Α[ι] <= ελάχιστο τότε ελάχιστο <- Α[ι]
Τέλος_επανάληψης
Αποτελέσματα // ελάχιστο //
Τέλος Ελάχιστη_τιμή

3. Αν ο πίνακας μπορεί να περιέχει και ίσες τιμές, τότε οι παραπάνω αλγόριθμοι συνεχίζουν να εντοπίζουν την ελάχιστη τιμή; Γιατί;

4. Υπό ποιες προϋποθέσεις θα μπορούσε ο παρακάτω αλγόριθμος να είναι σωστός; Γιατί;

Παράθεση
Αλγόριθμος Ελάχιστη_τιμή
Δεδομένα // Α, Ν //
ελάχιστο <- 0
Για ι από 1 μέχρι N
  Αν Α[ι] < ελάχιστο τότε ελάχιστο <- Α[ι]
Τέλος_επανάληψης
Αποτελέσματα // ελάχιστο //
Τέλος Ελάχιστη_τιμή
« Τελευταία τροποποίηση: 05 Μαρ 2011, 02:00:42 μμ από Νίκος Αδαμόπουλος »

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2843
  • Πύργος Ηλείας
Απ: Θέματα κατανόησης για min, max, θέση
« Απάντηση #1 στις: 24 Ιαν 2011, 06:34:34 μμ »
Ο παρακάτω αλγόριθμος εντοπίζει την ελάχιστη τιμή ενός μονοδιάστατου πίνακα Α που περιέχει Ν διαφορετικές τιμές. Επίσης, εντοπίζει τη θέση της ελάχιστης τιμής μέσα στον πίνακα:

Παράθεση
Αλγόριθμος Ελάχιστo_και_θέση
Δεδομένα // Α, Ν //
ελάχιστο <- Α[1]
θέση <- 1
Για ι από 2 μέχρι N
  Αν Α[ι] < ελάχιστο τότε
     ελάχιστο <- Α[ι]
     θέση <- ι
  Τέλος_αν
Τέλος_επανάληψης
Αποτελέσματα // ελάχιστο, θέση //
Τέλος Ελάχιστo_και_θέση

1. Αν ο αλγόριθμος αλλάξει όπως παρακάτω, συνεχίζει να εντοπίζει την ελάχιστη τιμή και τη θέση της στον πίνακα; Γιατί;

Παράθεση
Αλγόριθμος Ελάχιστo_και_θέση
Δεδομένα // Α, Ν //
ελάχιστο <- Α[1]
θέση <- 1
Για ι από 1 μέχρι N
  Αν Α[ι] < ελάχιστο τότε
     ελάχιστο <- Α[ι]
     θέση <- ι
  Τέλος_αν
Τέλος_επανάληψης
Αποτελέσματα // ελάχιστο, θέση //
Τέλος Ελάχιστo_και_θέση

2. Αν ο αλγόριθμος αλλάξει όπως παρακάτω, συνεχίζει να εντοπίζει την ελάχιστη τιμή και τη θέση της στον πίνακα; Γιατί;

Παράθεση
Αλγόριθμος Ελάχιστo_και_θέση
Δεδομένα // Α, Ν //
ελάχιστο <- Α[1]
θέση <- 1
Για ι από 2 μέχρι N
  Αν Α[ι] <= ελάχιστο τότε
     ελάχιστο <- Α[ι]
     θέση <- ι
  Τέλος_αν
Τέλος_επανάληψης
Αποτελέσματα // ελάχιστο, θέση //
Τέλος Ελάχιστo_και_θέση

3. Αν ο πίνακας μπορεί να περιέχει και ίσες τιμές, τότε ο αρχικός αλγόριθμος τι εντοπίζει; Γιατί;

4. Αν ο πίνακας μπορεί να περιέχει και ίσες τιμές, τότε ο αλγόριθμος του 2ου ερωτήματος τι εντοπίζει; Γιατί;

5. Υπό ποιες προϋποθέσεις θα μπορούσε ο παρακάτω αλγόριθμος να είναι σωστός; Γιατί;

Παράθεση
Αλγόριθμος Ελάχιστo_και_θέση
Δεδομένα // Α, Ν //
ελάχιστο <- Α[1]
Για ι από 2 μέχρι N
  Αν Α[ι] < ελάχιστο τότε
     ελάχιστο <- Α[ι]
     θέση <- ι
  Τέλος_αν
Τέλος_επανάληψης
Αποτελέσματα // ελάχιστο, θέση //
Τέλος Ελάχιστo_και_θέση
« Τελευταία τροποποίηση: 05 Μαρ 2011, 02:02:28 μμ από Νίκος Αδαμόπουλος »

gthal

  • Ομάδα διαγωνισμάτων 2017
  • *
  • Μηνύματα: 948
Απ: Θέματα κατανόησης για min, max, θέση
« Απάντηση #2 στις: 26 Ιαν 2011, 01:43:11 μμ »
Πράγματι, Νίκο,
ωραίες ασκησούλες για την κατανόηση των παραλλαγών σ' αυτό το θέμα
Φιλικά,
Γιώργος Θαλασσινός

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 810
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Θέματα κατανόησης για min, max, θέση
« Απάντηση #3 στις: 05 Μαρ 2011, 08:44:08 πμ »
Ποοολύ καλό.. Στο κλεψα ;)  Τους το δίνω, σήμερα κιόλας :)

Δύο σημεία μόνο με προβληματίζουν:
Ο παρακάτω αλγόριθμος εντοπίζει την ελάχιστη τιμή ενός μονοδιάστατου πίνακα Α που περιέχει Ν διαφορετικές αριθμητικές τιμές:
Αλγόριθμος Ελάχιστo
Δεδομένα // Α, Ν //
ελάχιστο <- Α[1]
...

1. Μήπως να αλλάζαμε όνομα στον αλγόριθμο σε Εύρεση_Μέγιστου ή κάτι παρόμοιο; Έχουμε και μεταβλητή με το ίδιο όνομα ..
2. Γιατί απαραίτητα να αναφερόμαστε σε αριθμητικές τιμές στην εκφώνηση; Ο αλγόριθμος δουλεύει για οτιδήποτε τιμές. Έτσι δεν είναι;
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2843
  • Πύργος Ηλείας
Απ: Θέματα κατανόησης για min, max, θέση
« Απάντηση #4 στις: 05 Μαρ 2011, 02:04:51 μμ »
Έχεις δίκιο! Οι αλλαγές έγιναν...

Νίκος Αδαμόπουλος

  • Γενικός διαχειριστής
  • *****
  • Μηνύματα: 2843
  • Πύργος Ηλείας
Απ: Θέματα κατανόησης για min, max, θέση
« Απάντηση #5 στις: 07 Μαρ 2011, 07:28:36 μμ »
(Συμπλήρωμα)

Ο παρακάτω αλγόριθμος εντοπίζει την ελάχιστη τιμή ενός μονοδιάστατου πίνακα Α που περιέχει Ν διαφορετικές τιμές. Επίσης, εντοπίζει τη θέση της ελάχιστης τιμής μέσα στον πίνακα:

Παράθεση
Αλγόριθμος Ελάχιστo_και_θέση
Δεδομένα // Α, Ν //
ελάχιστο <- Α[1]
θέση <- 1
Για ι από 2 μέχρι N
  Αν Α[ι] < ελάχιστο τότε
     ελάχιστο <- Α[ι]
     θέση <- ι
  Τέλος_αν
Τέλος_επανάληψης
Αποτελέσματα // ελάχιστο, θέση //
Τέλος Ελάχιστo_και_θέση

6. Για λόγους "λιτότητας", προκειμένου να μειωθούν οι μεταβλητές που χρησιμοποιεί ο αλγόριθμος, αποφασίστηκε να μη γίνει χρήση της μεταβλητής: ελάχιστο. Συμπληρώστε κατάλληλα τον παρακάτω αλγόριθμο ώστε να επιτελεί το ίδιο σκοπό:

Παράθεση
Αλγόριθμος Ελάχιστo_και_θέση
Δεδομένα // Α, Ν //
θέση <- 1
Για ι από 2 μέχρι N
  Αν Α[ι] < ....... τότε
     θέση <- ι
  Τέλος_αν
Τέλος_επανάληψης
Αποτελέσματα // ........., θέση //
Τέλος Ελάχιστo_και_θέση

7. Αναφέρετε πιθανές προϋποθέσεις ώστε ο παρακάτω "αλγόριθμος" να επιτελεί τον ίδιο σκοπό (!):

Παράθεση
Αλγόριθμος Ελάχιστo_και_θέση
Δεδομένα // Α, Ν //
θέση <- 1
ελάχιστο <- Α[1]
Αποτελέσματα // ελάχιστο, θέση //
Τέλος Ελάχιστo_και_θέση

Sergio

  • Αστέριος Φανίκος, Καθηγητής Πληροφορικής, fanikosaATschDOTgr
  • Δεινόσαυρος
  • *****
  • Μηνύματα: 810
  • Κάλλιο γνώση, παρά γρόσι.. (ΛΑΪΚΗ ΠΑΡΟΙΜΙΑ)
    • Προσωπική Σελίδα
Απ: Θέματα κατανόησης για min, max, θέση
« Απάντηση #6 στις: 07 Μαρ 2011, 10:26:21 μμ »
Ποοοοολύ ωραίες ερωτήσεις.. Μπράβο Νίκο !
(εννοείται ότι τις χρησιμοποιειώ... as of now  ;) )
Απ τη μια η θητεία μου σε σχολικές αίθουσες: να φλυαρώ - να ελπίζω πως κατι κατάλαβαν - να εξερευνώ - να μαθαίνω. Απ την άλλη, σχεδόν συνομήλικη, η Διδακτική της Πληροφορικής: ερευνά διαδικασίες μάθησης - φλερτάρει με την Ψυχολογία - με καλεί να αφήσω το βλέμμα του Πληροφορικού και να δω με τα μάτια του δασκάλου. Τέκνα των 2, οι απόψεις μου.. (προσαρμοσμένο από τον πρόλογο του βιβλίου "Το μακρόν Φυσική προ του βραχέως διδάσκω" του Ανδρέα Κασσέτα)