Το Στέκι των Πληροφορικών

Γενικό Λύκειο => Μονοδιάστατοι πίνακες => Γ΄ Λυκείου => Αναζήτηση => Μήνυμα ξεκίνησε από: droopy στις 27 Νοε 2019, 01:07:04 μμ

Τίτλος: ΑΝΑΖΗΤΗΣΗ ΣΕ ΤΑΞΙΝΟΜΗΜΕΝΟ ΠΙΝΑΚΑ ΜΕ ΕΠΑΝΑΛΗΨΕΙΣ ΣΤΟΙΧΕΙΩΝ
Αποστολή από: droopy στις 27 Νοε 2019, 01:07:04 μμ
Καλησπέρα,

στην περίπτωση που έχουμε ταξινομημένο πίνακα σε αύξουσα διάταξη και με επαναλήψεις στοιχείων και θέλουμε να εμφανίζει τις θέσεις στις οποίες βρίσκεται το στοιχείο που ψάχνουμε ή το μήνυμα ότι δεν υπάρχει το στοιχείο αυτό, η παρακάτω λύση είναι σωστή;

done ← ψευδής
pos ← 0
i ← 1
 Όσο (done=ψευδής) και (i<=N) επανάλαβε
         Αν A|i|=key τότε
              pos<--i
              ΓΡΑΨΕ ‘ΒΡΕΘΗΚΕ ΣΤΗ ΘΕΣΗ’,pos
               i<--i+1
        αλλιώς_αν Α|i|>key τότε   
               done <-- αληθής
        αλλιώς
               i <-- i+1
       Τέλος_αν
Τέλος_επανάληψης
Αν pos = 0 TOTE
   ΓΡΑΨΕ ‘Δεν βρέθηκε’
Τέλος_αν

Ευχαριστώ.

Τίτλος: Απ: ΑΝΑΖΗΤΗΣΗ ΣΕ ΤΑΞΙΝΟΜΗΜΕΝΟ ΠΙΝΑΚΑ ΜΕ ΕΠΑΝΑΛΗΨΕΙΣ ΣΤΟΙΧΕΙΩΝ
Αποστολή από: ikariofil στις 27 Νοε 2019, 02:33:28 μμ
μια χαρά φαίνεται ...