Γενικό Λύκειο > Πολυδιάστατοι πίνακες

Ταξινόμηση

(1/2) > >>

Aischinis:
Συνάδελφοι,

πως ταξινομείται ένας μονοδιάστατος πίνακας και ταυτόχρονα ένας δισδιάστατος πίνακας;  :o

Μπορούμε να έχουμε ένα παράδειγμα;

thanks  :angel:

petrosp13:
Αν ο μονοδιάστατος είναι παράλληλος με τις γραμμές του δισδιάστατου, τότε κάθε φορά που αντιμετατίθενται 2 στοιχεία του μονοδιάστατου, θα πρέπει να αντιμετατίθενται και οι αντίστοιχες γραμμές του δισδιάστατου

Λαμπράκης Μανώλης:
Καλημέρα σε όλους

υποθέτω συνάδελφε ζητάς κάτι τέτοιο ?? έστω έχουμε 100 πωλητές σε μία εταιρία με τις μηνιαίες πωλήσεις τους σε ένα χρόνο
σε πωλ[100,12] και παράλληλο πίνακα με τα ονόματα των μηνών μήνες[12]  .. ζητάμε τις 5 μεγαλύτερες πωλήσεις κάθε πωλητή και σε ποιους μήνες τις πέτυχε .. κατά την αντιμετάθεση στοιχείων  των γραμμών "χαλάει η παραλληλότητα" με τους μήνες και κατά συνέπεια με όλες τις άλλες γραμμές, οπότε χρειάζονται αρκετές αντιμετεθέσεις για να παραμείνουν παράλληλες οι επόμενες γραμμές με τους μήνες για τις ταξινομήσεις των επόμενων γραμμών

Αλγόριθμος ταξινόμηση_δισδιάστατου
    Δεδομένα //πωλ, μήνες//   
    Για γρ από 1 μέχρι 100   
        Για i από 2 μέχρι 12   
   Για j από 12 μέχρι i με_βήμα -1   
       Αν  πωλ[γρ, j-1]<πωλ[γρ, j] τότε
      ! αντιμετάθεσε τους μήνες
             Αντιμετάθεσε μην[j-1], μην[j]
! και όλες τις γραμμές για να παραμείνουν παράλληλες   
             Για κ από 1 μέχρι 100
                Αντιμετάθεσε πωλ[κ, j-1], πωλ[κ,j]
             Τέλος_επανάληψης
       Τέλος_αν
             Τέλος_επανάληψης
          Τέλος_επανάληψης
           Για λ από 1 μέχρι 5   ! εμφάνισε τα 5 πρώτα στοιχεία και μήνες
       Εμφάνισε πωλ[γρ, λ], μην[λ]
        Τέλος_επανάληψης
    Τέλος_επανάληψης
Τέλος  ταξινόμηση_δισδιάστατου

Aischinis:
Καλημέρα  :)

Ακριβώς αυτό ζητούσα, έτσι το σκέφτηκα!
Και έχω να πω πως κάτι τέτοιο είναι πολύ χρήσιμο και αποτελεί καλή άσκηση για τους μαθητές μας.

Ευχαριστώ!

eris_st:
μια λύση για αυτή την άσκηση;

Πλοήγηση

[0] Λίστα μηνυμάτων

[#] Επόμενη σελίδα

Μετάβαση στην πλήρη έκδοση